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Topics in this chapter

Welcome to 
Technical Edition

The Visio® 2000 Technical Edition drawing 
application gives you templates, stencils, 
shapes, wizards, and drawing tools to create 
precise 2-D (two-dimensional) technical 
drawings and diagrams. In this User Guide, 
you will find

• Descriptions of new and improved features. 

• Visio basics, including everything you need 
to know to start creating drawings quickly 
and efficiently.

• Conceptual discussions, step-by-step pro-
cedures, and helpful tips for quickly creat-
ing all types of technical drawings.

You can also view this guide online by install-
ing the PDF files located in the Docs folder on 
the Visio 2000 CD. 

Finding the information you need................... 2

What’s new in Visio 2000 ................................. 4
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Finding the information you need

The Technical Edition User Guide covers the 
fundamentals of  Visio 2000, and focuses on 
the drawing types and methods you’re likely to 
use most often. The guide includes a glossary of 
commonly used terms. Glossary terms appear 
in bold italics the first time they’re mentioned 
or discussed.  

This symbol in the margin 
accompanies useful  hints and 
how-tos.  

In addition to this guide, the following 
resources offer a wide range of information 
about working with Visio products.

Installation
For information about installing your 
Visio 2000 program, refer to the Quick Refer-
ence card included in the product box. 

Visio on the Web
To reach Visio Corporation and the Visio 
Knowledge Base using the World Wide Web, 
in Visio 2000 choose Help > Visio On The 
Web.  The Visio Knowledge Base offers the lat-
est tips on using Visio 2000 products and 
includes articles that answer frequently asked 
questions (FAQs). 

The Visio Web site also contains information 
on service releases, support forums, and training 
opportunities.  You’ll find the Visio Web site at

• www.visio.com

Sources of other information
More resources for getting the answers you 
need to work efficiently in your Visio 2000 
application are available.

• The Developing Visio Solutions manual con-
tains information about building custom 
shapes or solutions with Visio applications. 
You can order the manual or view the 
online version on the Visio 2000 CD.

• For information about Technical Support,  
in Visio 2000 choose Help > Visio Help, 
and then on the Contents tab, look under 
the Technical Support heading. 

Online Help 
This guide provides the big-picture informa-
tion for working in Visio 2000. More details 
and how-to information are just a click away in 
the online Help. 

Throughout this book, this 
cross-reference icon indicates 
that more information on that 

topic is available in online Help.  To see the 
additional information, just search online Help 
using the keywords provided.

To search online Help for a keyword 

1 Press F1, and then click the Index tab. (If 
necessary, click the Show button.)

2 Under Type In The Keyword To Find, type 
the keyword you want to use. (Keywords are 
listed under the cross-reference icon.)

3 Click Display.
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Navigating the Visio Help 
window 
The first time you choose the Visio Help com-
mand, or click F1 or Shift+F1, the Visio Help 
window opens. You can use the following 
tabbed pages in the navigation pane of the 
Help window while you work: 

• Contents contains headings with topics 
listed below. Click the plus sign (+) to 
expand the heading and see the topics.

• Index contains index terms. Click this tab 
to view and search index entries.

• Favorites contains topics you designate for 
quick reference.

The navigation pane appears by default the 
first time you open Help. You can open or 
close the navigation pane, select a tab in the 
navigation pane, and resize or reposition the 
Help window. Each time you open Help, the 
window appears in the same state as the last 
time you used it. 

To hide the navigation pane 

• Click the Hide button ( ) on the Help 
window toolbar.

To show the navigation pane 

• Click the Show button ( ) on the Help 
window toolbar.  

Get help quickly while you work 

For help about Do this

Concepts, terms, features Press F1, click Search (if necessary, click the Show button), and then 
type your question to use the Visio intelligent search capability.

Shapes Do one of the following:

• Pause your pointer over the shape in the stencil window until a 
ScreenTip appears.

• Press F1, click the Index tab (if necessary, click the Show button), 
type the name in the index text field, and then click Display.

• Right-click a shape on the page or the stencil, and then choose Help.

Menu commands Press F1, click the Index tab (if necessary, click the Show button), type 
the name in the index, and then click Display.

Dialog boxes Click the Help button ( ) in the dialog box.

Automation, 
ShapeSheet® spreadsheet

Choose Help > Developer Reference, or press F1 in a ShapeSheet cell.
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What’s new in Visio 2000 

New and powerful additions to Visio 2000 
make it easier than ever to create technical 
drawings and diagrams. 

Common tasks made easy 
You can work faster and smarter using a core 
group of enhanced features that all of the 
Visio 2000 products share.

• Easily create custom data for shapes that 
you can later use for reports.

• Set tabs, margins, and hanging indents 
using a text editing ruler.

• Nudge selected shapes using the arrow keys 
for precise placement in your drawing.

• Easily navigate, rearrange, and rename 
pages using page tabs.

• Edit groups the same way you edit regular 
shapes.

• Edit stencils directly in the drawing 
window.

• Customize menus and toolbars.

• Perform tasks right in the drawing window 
using quick editing windows. The following 
table lists the window types and the tasks 
you can perform.  

New and enhanced technical 
solutions
Visio 2000 offers new and enhanced technical 
solutions that make it easy to assemble draw-
ings by dragging industry-standard shapes 
onto a page.

Precision drawing tools
• Draw shapes using the shape extension 

lines, which provide visual feedback about 
shape angles, tangents, and other geometric 
relationships.

• Position and align shapes instantly with the 
dynamic grid, which provides visual cues to 
help you align shapes.

• Snap lines to geometric points, such as end 
points, tangents, and line intersections, for 
more accurate drawing.

Quick editing windows in Visio 2000 

Window type Purpose

Pan & Zoom 
window

Easily zoom in or out with 
increased precision

Custom Properties 
window

View and edit a shape’s 
custom properties

Size & Position 
window

Change a shape’s size, 
position, or rotation

Document Explorer 
window

View all of the elements 
in your document
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DWG and DGN support
• Insert CAD drawings created in Autodesk 

AutoCAD DWG or DXF format or Bentley 
MicroStation DGN format.

• Convert CAD drawings into Visio format 
more easily by using the new Convert Wiz-
ard.

• Choose an industry-standard scale for 
inserted CAD drawings that either matches 
the Visio drawing scale or is independent of 
the Visio drawing scale.

• Snap shapes, such as electrical outlets, 
HVAC ducts, and furniture shapes, to 
inserted CAD floor plans.

Process Engineering
• Draw P&IDs (piping and instrumentation 

diagrams) and PFDs (process flow dia-
grams) faster using intelligent pipeline 
connections that automatically reroute.

• Store specification data about process com-
ponents in customizable datasheets.

• Quickly and easily generate component lists 
from the data stored in your diagrams.

• Convert your legacy CAD symbols or block 
libraries into intelligent Process Engineer-
ing shapes.

• New Print datasheets for many compo-
nents at once.

• New Edit data for multiple components in 
the Datasheet window, which you can keep 
open for ease of data entry.

Facilities Management
• Graphically manage office moves and track 

your facilities assets and employees.

• View relational information about your 
facilities in the easy-to-navigate Visio 
CAFM Explorer, which can now be docked 
so that you can view the Explorer and your 
drawing at the same time.

• Easily add configured Steelcase 9000 furni-
ture to your facility plan.

• New Link to enterprise data in existing 
corporate databases.

Building Architecture
• Quickly lay out a floor plan by using room 

and space shapes that you can easily convert 
to fully dimensioned walls.

• Quickly add dimension lines and guides to 
any wall, and resize rooms by dragging 
guides.

• Use space shapes inside rooms to show the 
room area, which you can update with a 
single command when you resize the room.

Building Services
• Create HVAC diagrams by using ductwork 

shapes that automatically rotate, align, and 
snap to each other.

Office layouts
• Quickly lay out office floor plans by using 

room and space shapes to automatically 
create walls and dimension lines. 





Topics in this chapter

1

Visio basics

While each Visio® 2000 Technical Edition 
template contains a unique set of shapes, tools, 
and styles, some tasks are common to all types 
of Visio drawings or diagrams. This chapter 
explains the drawing tasks that can get you 
started using the Visio program in minutes, 
regardless of the type of drawing you’re 
creating.

This chapter begins with an overview of the 
drawing process, and then describes how 
you can

• Create your drawing.

• Work with stencils and shapes.

• Add and edit text.

• Work with groups of shapes.

• Work with multiple pages.

Subsequent chapters focus on creating specific 
types of drawings, such as floor plans, facility 
plans, and P&IDs (piping and instrumentation 
diagrams).

The big picture .................................................. 8

Creating a drawing.......................................... 10

Adding and changing text .............................. 17

Grouping shapes in your drawings............... 19

Working with pages ........................................ 21

Enhancing your drawing ................................ 23

Saving and printing your work ...................... 24
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The big picture

The Visio 2000 products share a core set of 
features. This means that you can use common 
methods to work with all of the Visio 2000 
programs to create your drawings—whether 
they are business drawings or diagrams you 
create with Standard Edition, such as 
flowcharts or block diagrams; technical 
drawings you create with Technical Edition, 
such as P&IDs or electrical schematics; or 

database design and modeling drawings you 
create with Professional Edition or Enterprise 
Edition, such as Web site schematics or object 
role modeling diagrams. 

The illustration below shows five steps all 
Visio 2000 drawings have in common. The fol-
lowing page shows the actual workspace you’ll 
use to create Visio drawings.      

Five steps to

making a Visio

drawing

1 Start a drawing or diagram by 
opening a drawing type, or template.

2 Add shapes by dragging them from 
the stencil and dropping them onto 
the drawing page.

3 Connect the shapes in your 
drawing.

4 Add text to shapes in your 
drawing, and add independent text 
for titles.

5 Publish your drawing to the Web, or print your drawing to share it 
with others.

M

x
c

W y

R

z
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The Visio 2000 

workspace 

Each drawing type 
opens with stencils,  
shapes, and toolbars 
appropriate to that 
drawing type.

A Tools are grouped in functional sets on toolbars. You 
can specify which toolbars you want to display by 
choosing View > Toolbars. 

B The drawing page opens with size, orientation, 
scale, grid, and measurements appropriate for the 
drawing type.

C You can find additional related tools by clicking the 
arrows next to the buttons.

D You can use the drawing page grid to align shapes 
to each other.

E ScreenTips appear when you pause the mouse 
pointer over a toolbar button. 

F Stencils, or collections of masters, dock to the left of 
the drawing page, by default. 

G With page tabs you can quickly insert new pages, 
navigate multiple-page drawings, delete pages, 
rename pages, and reorder pages. 

H Masters are shapes you can add to your drawings. 
To quickly view information about a shape, pause 
the mouse pointer over the shape.

I When your drawing has multiple pages, you can 
move the horizontal scroll bar to view all of the 
page tabs. 

CA EB D

F G H I
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Creating a drawing

When you base a drawing or diagram on a 
Visio drawing type (also called a template) in 
Visio 2000, you automatically get all the tools 
and features you need to create that particular 
type of drawing.

For example, to create an organization chart, 
you open the Organization Chart drawing 
type.  

To start an organization chart 

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Organization Chart.

You can see a preview of the drawing types 
in the Drawing Type box. 

3 In the Drawing Type box, double-click  
Organization Chart.

A drawing page appears, with the stencils 
and tools you need to begin your drawing.

Working with stencils
When you start a new drawing or diagram by 
opening a template, Visio 2000 opens one or 
more task-related stencils. Stencils contain 
shapes you can drag onto the drawing page to 
create your drawing. You can arrange, resize, 
and connect the shapes in your drawing to cre-
ate the drawing you want. 

To move stencils within the Visio window

1 Click the icon ( ) on the stencil title bar.

A menu appears.

2 Choose Position, and then choose the 
stencil placement you want from the 
submenu. 

You can dock or “float”—make movable—stencils as 
you work on your drawing.  

TIP For quick access to stencil menu commands 
use the Stencil toolbar. Choose View > 
Toolbars > Stencil.

To open additional stencils

• Choose File > Stencils > Open Stencil, 
choose the stencil you want to open, and 
then click OK.

To locate a specific 
shape quickly, use 
the Shape Explorer™ 
to find it. Choose 
Tools > Macros > 
Shape Explorer.
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Adding shapes to your drawing  
The easiest way to create a drawing or diagram 
is to drag shapes from a stencil onto the draw-
ing page.  When you drop a shape onto the 
drawing page, Visio 2000 snaps the shape to 
the nearest grid line so you can position it pre-
cisely in your drawing. 

TIP You can use a dynamic grid (dashed lines) to 
indicate the location for the center of the next 
shape you drag onto the page, based on the loca-
tion of shapes already on the page. Choose 
Tools > Snap & Glue, and then check Dynamic 
Grid.

To add a shape to your drawing 

1 Choose the pointer tool ( ) from the Stan-
dard toolbar, located just below the menu 
bar.

2 In the stencil, select the shape you want.

3 Hold down the left mouse button and drag 
the shape onto the drawing page.

4 Release the mouse button to drop the shape 
onto the drawing page.

NOTE If you make a mistake, you can use the 
Undo toolbar button ( ) to cancel your most 
recent actions, and the Redo button ( ) if you 
change your mind.  

Using shape handles 
Visio shapes have handles you can use to resize 
or move the shape, or to change the shape’s 
appearance, position, or behavior. You use 
selection handles ( ) to resize shapes, and 
control handles ( ) to perform actions that 
are unique to the particular shapes on which 
they appear.   

For example, you might use a control handle to 
adjust the position of a shape or move a line in 
a shape. To display a ScreenTip about what the 
control handle does, pause the mouse pointer 
over the control handle.  

For details, use these 
online Help keywords:

• Shape basics

• Guides and
guide points

• Handles

The control handle looks 
just like a selection 
handle, but has darker 
shading.

To see a ScreenTip for 
what a control handle 
does, pause the pointer 
over the control handle.

Adjust line spacing
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Moving and resizing shapes
Moving Visio shapes is as easy as selecting the 
shapes and then dragging the selection to the 
new location in your drawing or diagram. You 
can resize shapes quickly by simply dragging 
selection handles. 

To move or resize a shape

1 To move the shape, select the shape with the 
pointer tool ( ), hold the left mouse button 
while dragging the shape to the location you 
want in your drawing, and then release.

The pointer turns white when the shape is 
movable.

2 To resize a selected shape, point to a selec-
tion handle ( ) until the pointer changes to 
a four-headed arrow ( ), and then drag 
the handle to change the size.

To move multiple shapes   

1 Click to select a shape, hold down the Shift 
key, and then click the other shapes you 
want to select.

2 Move the pointer over one of the shapes 
until the pointer turns white.  

The shape is movable when the pointer 
changes from a black arrow to a white 
arrow.

3 Drag the shape to its new position. 

All selected shapes move, and retain their 
original spatial relationship.

TIP To limit the movement of shapes to hori-
zontal or vertical, hold the Shift key while 
dragging.

Using 1-D and 2-D shapes
Visio shapes can be one-dimensional (1-D) or 
two-dimensional (2-D).   

To nudge a shape 
slightly in one 
direction, select the 
shape, and then click 
the up, down, left, or 
right arrow key.

1-D shapes behave like lines and display endpoints you 
can drag to resize the shapes when you select them 
with the pointer tool.

2-D shapes have corner handles you can drag to resize 
the shapes proportionally, and side selection handles 
you can drag to resize them horizontally or vertically.
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Connecting shapes
Flowcharts, organization charts, block dia-
grams, and network diagrams are all connected 
drawings—drawings that show relationships 
between shapes.

In a Visio connected drawing, a connector is any 
1-D shape that connects 2-D shapes. Connected 
shapes stay connected when one of the shapes 
is moved. When you attach a connector to a 
connection point ( ) on a shape or to the 
shape itself, you glue the connector to the shape. 

You can use two types of connections in 
Visio 2000, shape-to-shape and point-to-point. 
The type of connection you use depends on 
how much control you want over your drawing.

With shape-to-shape connections, Visio 2000 
maintains the most direct connection between 
the shapes. This means that the actual points of 
connection might change when you move the 
connected shapes in relation to each other. 

With point-to-point connections, the actual 
points of connection stay the same no matter 
how you move the connected shapes. 

Shape-to-shape 

connections

When you move shapes that have shape-to-shape connections, the connector attaches at the closest points 
between the shapes, which might be different from the original connection points.

Point-to-point 

connections

When you move shapes that have point-to-point connections, no matter how you arrange the shapes in relation to 
each other on the drawing page, the shapes maintain their original connection points. 
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To connect shapes automatically, 

shape-to-shape

1 Click the connector tool ( ) on the 
Standard toolbar.

2 Drag a shape from a stencil onto the 
drawing page.

3 While the shape is still selected, drag 
another shape from a stencil onto the draw-
ing page.

The shapes are automatically connected 
shape-to-shape.

To connect shapes on the drawing page, 

shape-to-shape  

1 Use the pointer tool ( ) to drag two shapes, 
one at a time, from a stencil onto the draw-
ing page.

2 From the Standard toolbar, click the con-
nector tool ( ), and then position the 
connector tool over the center of the first 
shape until a red box appears around the 
entire shape. Hold down the mouse button 
and drag to draw a connector.

3 While holding the mouse button, position 
the connector tool over the center of the 
shape to which you want to connect until a 
red box appears around the entire shape, 
and then release the mouse button. 

The shapes are connected shape-to-shape. 

Using connections

Connection type When to use it How

Shape-to-shape To connect shapes 
when their specific 
points of connection 
don’t matter. 

Click the connector tool ( ), and then 
drag shapes you want to connect onto 
the drawing page. The shapes are 
connected shape-to-shape by default.

Point-to-point To control where the 
connector attaches to 
the 2-D shape. 

Drag a connector shape onto the 
drawing page, and then drag the 
endpoint of the connector shape to the 
point on the 2-D shape to which you 
want to connect. 
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To connect shapes point-to-point

1 Use the pointer tool to drag two shapes, 
one at a time, from a stencil onto the 
drawing page.

2 From the Standard toolbar, click the con-
nector tool, and then drag from the connec-
tion point on the first shape to a connection 
point on the second shape. 

The connection points turn red, and the 
shapes are connected point-to-point. 

To add a connection point to a shape

1 Click the arrow next to the connector tool 
on the Standard toolbar, and then click the 
connection point tool ( ). 

2 Hold down the Ctrl key, and then click the 
shape where you want to add the connec-
tion point. 

The new connection point appears (in 
magenta) on the shape. 

To change a connection from shape-to-shape to 

point-to-point 

• Drag a red (glued) connector endpoint ( ) 
away from the shape and then back to one 
of the shape’s connection points. 

When you drag the endpoint back to the 
shape, a box appears only around the con-
nector endpoint.

Modifying shapes
You can use Visio tools to flip and rotate 
shapes in your drawings or diagrams, as well as 
to add color and change line styles.

You can use Visio tools on the Action toolbar 
to modify shapes.  

To view the Action toolbar 

• Choose View > Toolbars > Action. 

You can add color and shadows to shapes and 
instantly make your drawings more visually 
dynamic. You can also change the format of 
lines and line ends in your drawings. By apply-
ing line ends, you can turn any line into an 
arrow. 

Flip and rotate shapes with Action tools

Action Tool

Flip a shape horizontally
   

Flip a shape vertically
   

Rotate a shape right
   

Rotate a shape left
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To view the fill color palette

• Click the arrow next to the Fill Color button 
on the Format toolbar.

The fill color palette. Click More Fill Colors for 
additional colors.

To apply color to a shape

• Select the shape and choose the fill color 
you want to use from the fill color palette 
on the Format toolbar.

To apply or remove a shadow

1 Select the shape.

2 Choose Format > Shadow.

3 In the Shadow dialog box, choose the 
options you want to apply from the Color, 
Pattern, and Pattern Color lists.

4 Click Apply to view the options you chose 
before closing the dialog box, or click OK to 
apply the formatting and close the dialog 
box.

5 To remove a shadow, choose None from the 
Pattern list in the Shadow dialog box.

Use the Shadow dialog box to add, change, or delete  
shadows for shapes in your drawings.

To format a line style 

• Select the shape and choose the Line 
Weight, Line Pattern, and Line Ends but-
tons on the Format toolbar to select the for-
matting you want to use.

For details about drawing your own shapes, see 
Chapter 9, “Go further: Creating shapes, styles, 
and templates.” 
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Adding and changing text

Text can clarify the meaning of your Visio 
drawings or diagrams, and you can use text to 
document changes you or other Visio users 
make to a drawing. You can use text to

• Describe the process a shape represents in a 
process flow drawing.

• Add title blocks and bulleted lists to your 
drawings.

• Annotate a drawing.

Most Visio shapes, including connectors, 
are designed so that you can add text to them. 
You can also edit the text in a shape by 
double-clicking the shape, and then editing 
the text block.

In addition, you can create text-only shapes—
shapes that have no lines or fill—to add notes, 
titles, and lists to a drawing.

NOTE Text for some shapes, such as the Wall 
shape in the Office Layout template, is generated 
automatically from data in the shape’s custom 
properties. Also, some shapes, such as the Switch 
shape (also in the Office Layout template), are 
locked against adding text. The Visio program 
displays a message letting you know that text 
cannot be added to locked shapes.

To add text to a shape  

1 Select the shape, and then type the text you 
want.

2 When you finish typing, press the Esc key or 
click outside the shape.

TIP To quickly select text in shapes, double-click 
the shape. You can change the default behavior 
for the double-click action by choosing Format > 
Behavior. Click the Double-Click tab, and then 
select the option you want.

To delete text from a shape

1 Choose the text tool ( ) from the Standard 
toolbar, located just below the menu bar.

2 Click the shape containing the text you 
want to delete.

3 Select the text you want to delete, and then 
press the Delete key.

4 Click outside the text block to close it.

To edit existing text 

1 Double-click the shape to open the shape’s 
text block, and then type. You can also click 
the Text tool ( ) on the Standard toolbar,  
click the text, and then type. 

2 Click in the text block where you want to 
place the insertion point, and then type the 
text you want.

3 When you finish typing, click outside the 
shape.

For details, use these 
online Help keywords:

• Text and text blocks
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To format text, do one of the following  

• Use the commands on the Format menu or 
the tools on the Format toolbar to apply  
formatting to the selected text.

• Use the Text style lists on the Format tool-
bar to apply a style to the selected text.

To create a text-only shape

1 From the Standard toolbar, click the text 
tool ( ).

2 Click the drawing page where you want the 
text to begin, and then type. 

Or, drag the mouse until the text block is 
the size you want, release the mouse button, 
and then type.

3 When you finish typing, press the Esc key or 
click outside the text block.

Using the text ruler
You can turn on the text ruler to help you 
format text in a shape as you edit it. The ruler 
shows the initial settings for the indents and 
tab stops of the selected paragraph.

You can quickly change the settings for the 
selected text by dragging the tab stops and 
indent markers to the location on the scale you 
want in the text edit window. 

To turn on the text ruler

1 Double-click a shape to open the shape’s 
text block, or click the text using the text  
tool ( ) on the Standard toolbar.

2 Right-click the shape with its text block 
selected, and then choose Text Ruler from 
the shortcut menu.

The text ruler appears above the shape.

The text ruler appears for all subsequent 
shapes when you edit their text. To turn off 
the text ruler, right-click the shape in text-
edit mode, and then choose Text Ruler.

The text ruler appears directly above the text edit 
window.

To find and change 
text in large 
drawings, use the 
Find And Replace 
dialog box. Choose 
Edit > Replace, and 
then type the 
replacement text.

Visio
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Grouping shapes in your drawings

You can group shapes so they function as a 
unit. It is useful to group shapes when you reg-
ularly use them together. For example, when 
you create an office layout, you can group 
office shapes with cubicles, and then you can  
duplicate the group and use it over and over 
again or move it easily to a different location in 
your drawing. 

Creating groups of shapes
You can group any combination of Visio 
shapes, including those you draw yourself, 
other groups, and shapes from other programs. 
After you create a group, you can add and 
delete shapes from the group.

To create a group

1 Drag the shapes you want to group, one at a 
time, from a stencil onto the drawing page.

2 Select the first shape, hold down the Shift 
key, and then click to select the other shapes 
one at a time. 

3 Choose Shape > Grouping > Group.

Modifying groups and shapes in 
groups  
You can modify groups just as you would any  
individual shape. You can select, move, resize, 
or rotate a group as a single shape, but its 
members retain their original appearance and 
properties.

You can also select and modify the individual 
shapes that make up the group. 

To select a group of shapes

• Click one of the shapes in the group. 

A dashed line appears around the grouped 
shapes. 

NOTE The pointer tool turns from black ( ) to 
white ( ) when positioned over an individual 
shape in a group.

For details, use these 
online Help keywords:

• Groups

• Shapes
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To select an individual shape in a group 

1 Select the group by clicking a shape with the 
pointer tool. 

2 Click the shape you want to modify in the 
group.

Make any changes you want to the shape, 
and then click anywhere outside the shape.

The following table provides a quick summary 
of how you can work with shapes and groups 
of shapes.   

Methods for working with groups

To Do this

Group shapes Select the shapes you want to group, and then choose Shape > 
Grouping > Group.

Ungroup shapes Select the group, and then choose Shape > Grouping > Ungroup.

Modify individual shapes in a group Select the group, and then click the shape you want to modify. 

Delete a shape from a group Select the group, click the shape you want to delete, and then 
press the Delete key.

Add a shape to a group Select the group. Shift+click any other shapes you want to add to 
the group, and then choose Shape > Grouping > Add To Group.

Move a group Select the group, and then drag it to the location you want.
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Working with pages

For some drawing projects, you might want 
your drawing file to contain many drawing 
pages. For example, a file could represent a 
management project with a high-level timeline 
for the project on one drawing page, a flow-
chart of the processes in the project on another 
page, and the plan for staffing and resources on 
another page. You can change the orientation 
and size of your page using the Page Setup dia-
log box.

You can also add, delete, rename, and reorder 
pages easily using the page tab controls located 
at the bottom of the drawing window.

Setting page orientation
If you want to change drawing page settings, 
such as orientation or size, as you create your 
drawing, you can use the Page Setup dialog box 
to verify that your printer page settings work 
with the new drawing page settings you 
specified.

To set page orientation 

1 Display the drawing page you want to 
change, and then choose File > Page Setup.

2 In the Page Setup dialog box, click the Page 
Size tab, and then select the page orienta-
tion you want.

To set printed page orientation

1 Display the drawing page you want to 
change, and then choose File > Page Setup.

2 On the Print Setup tab, choose the paper 
orientation you want (Portrait or Land-
scape), and then click OK.

Adding and deleting drawing 
pages
When you add a new drawing page to your dia-
gram, the new page inherits the size, 
orientation, scale, measurement unit, shadow 
offset, and grid settings of the page currently 
displayed.

You can change these settings using the Page 
Setup dialog box when you insert the page, or 
at any time.

You can also delete pages you no longer use. If 
you delete the last page in a file, Visio replaces 
that page with a blank page.

TIP To view all the page tabs for multiple-page 
drawings, you might have to move the horizontal 
scroll bar. Pause the cursor over the slider box  
( ) until it changes to a two-headed arrow, and 
then drag it to the right. You can also click the 
scroll arrows to the left of the page tabs.

For details, use these 
online Help keywords:

• Pages

• Drawing scales

• Background pages
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To add a drawing page

1 Right-click the page tab at the bottom of the 
drawing page window, and then choose 
Insert Page from the shortcut menu.

2 In the Page Setup dialog box, click the Page 
Properties tab, and then type a name for the 
page, or use the default name.

You can also double-click the page tab, and 
then type, to quickly change the page name.

TIP Add a background page to your drawing file 
when you want the same shape(s) to appear on 
more than one drawing page, such as your com-
pany logo on all pages of a mutiple-page draw-
ing. For details about backgrounds, see “Using 
background pages to display common page ele-
ments” on page 129. 

To delete a drawing page

• Right-click the page tab, located at the bot-
tom of the drawing page window, for the 
page you want to delete, and then choose 
Delete Page from the shortcut menu. 

NOTE If you change your mind after you delete a 
page, you can click the Undo button ( ) on the 
Standard toolbar to retrieve it.

To navigate between pages

• Click the page tab at the bottom of the 
drawing window for the page to which you 
want to navigate.

If any of the page tabs are hidden, use the 
arrow buttons and scroll bar to display mul-
tiple page tabs.

Click page tabs to navigate between pages. Right-click 
page tabs to view page menu commands.

Resizing pages
Resizing pages enables you to enlarge a page 
where you need it and remove empty space 
you do not need, both without changing the 
drawing scale.

To resize a page 

1 Choose File > Page Setup.

The Page Setup dialog box appears.

2 Click the Page Size tab, type the page 
dimensions you want under Custom Size, 
or select a page size option, such as Size To 
Fit Drawing Contents, and then click OK.

For details about page setup, see “Printing your 
drawings” on page 116. 

To quickly resize your 
drawing page, hold 
down the Ctrl key and 
use the pointer tool to 
drag the edge of the 
drawing page to the 
size you want.
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Enhancing your drawing

You can use color and style formats to make 
your drawing a more powerful communication 
tool, or simply to make it more aesthetically 
appealing.  

Add a color scheme to your drawing, or use 
styles to modify the look of lines, colors, and 
text.

NOTE Color schemes are available for all 
drawing types except Directional Map and 
Office Layout.

To apply a color scheme

1 Open the drawing for which you want to 
create a color scheme.

2 Choose Tools > Macros > Visio Extras > 
Color Schemes.

3 In the Color Schemes dialog box, select the 
color scheme you want to use, and then 
click OK.

To apply a style

1 Open the drawing for which you want to 
apply a style.

2 Select one or more shapes you want to for-
mat.

3 Choose Format > Style, and then select the 
style you want from the lists. All the styles 
available in a drawing, both those pre-
defined in a template and those you define 
yourself, are listed in the Style dialog box.

For details about creating your own styles, see 
“Defining and editing styles” on page 128. 

For details, use these 
online Help keywords:

• Color schemes

• Styles
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Saving and printing your work 

You should frequently save drawings or dia-
grams as you work. You should also be sure to 
save any stencil and template files that you 
change.

The first time you save a drawing, Visio 2000 
prompts you for document properties, such as 
whether to save a preview, a small thumbnail 
version of the drawing. The properties you 
specify appear in the Open dialog box when 
you select the drawing file name.

You can print your drawings by choosing a 
menu command or toolbar button. 

To save a drawing for the first time

1 Choose File > Save or Save As.

2 For File Name, type a name for the drawing 
file.

3 Under Save In, open the folder in which you 
want to save the file.

4 Click Save.

5 In the Properties dialog box, enter the 
information you want, and then click OK.

6 Click Save.

To print your drawing, do one of the following

• Click the Print button ( ) on the Standard 
toolbar.

• Choose File > Print.

For details about printing and delivering your 
drawings, see Chapter 8, “Sharing your draw-
ings with others.” 
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Drawing precisely

Engineering and architectural diagrams and 
drawings require accurate measurements and 
precise positioning of shapes. Visio® 2000 
Technical Edition provides drawing and posi-
tioning tools that are easy to use but powerful 
enough for the most complex drawings.

This chapter describes how you can

• Set the drawing scale and choose measure-
ment units.

• Add dimension lines to shapes.

• Position shapes precisely by using grids, 
guides, and snap options.

• Position shapes by using coordinates.

• Work with large drawings.
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Measuring and dimensioning

You can set up your Visio drawings with the 
drawing scale and measurement units you need 
to create a wide range of engineering and archi-
tectural drawings. 

Setting the drawing scale
Many engineering or architectural drawings 
require a drawing scale that makes it possible 
to represent very large or very small objects on 
a sheet of paper. The drawing scale is a ratio 
that compares the size of the drawn object to 
the actual size of the object the drawing repre-
sents. For example, in an architectural floor 
plan, the drawing scale might be 1/8" = 1'0", 
where 1/8 inch on the drawing page represents 
1 foot in the real world. In a drawing of a bolt, 
the scale might be 10:1, where 10 millimeters 
on the drawing page represents 1 millimeter of 
the actual bolt.

When you start a measured drawing in 
Visio 2000, the drawing page opens with a 
default drawing scale. For example, floor plans 
have a drawing scale of 1/8" = 1'0". Some sche-
matic diagrams, such as electrical diagrams, 
have a scale of 1:1. You can change the drawing 
scale at any time, and you can set a different 
drawing scale for each page of your drawing. 

To change the drawing scale for a page

1 Display the page whose scale you want 
to set.

2 Choose File > Page Setup, and then click the 
Drawing Scale tab.

3 Click Pre-Defined Scale, and then select an 
engineering or architectural scale. Or, click 
Custom Scale, and then type a custom scale. 

When you type a custom scale, enter the 
measurement units, or select the appropri-
ate measurement units on the Page Proper-
ties tab.

4 Click OK.

As the drawing scale changes, shapes take up more or 
less space on the page. The rulers in each drawing 
show the actual size of the objects the drawing 
represents in the measurement units you have chosen.

1/4" = 1'0"

1:25
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Setting measurement units
Measurement units are the measurements that 
appear on the ruler and in dimensions. Mea-
surement units represent sizes in the real 
world. For example, in an architectural draw-
ing, the measurement units might be feet and 
inches.

Selecting a predefined drawing scale automati-
cally sets the measurement units. If you are 
creating a custom scale, you might need to 
specify the measurement units. For example, if 
you want 1 inch on a landscape layout to repre-
sent 3 yards in the real world, set your 
measurement units to yards.

To set measurement units for a page

1 Display the page for which you want to 
change the measurement units.

2 Choose File > Page Setup, and then click the 
Page Properties tab.

3 From the Measurement Units list, select the 
units you want.

Showing size by using 
dimension lines
Engineering and architectural drawings fre-
quently show the dimensions of shapes in the 
drawing. Visio 2000 provides dimension lines 
that calculate and display linear and angular 
dimensions. When you resize a shape that has 
attached dimension lines, the dimensions are 
automatically updated.

You dimension a shape by dragging a dimen-
sion shape onto your drawing and connecting 
the dimension shape’s endpoints to geometric 
points on the shape you want to measure. You 
can choose from a wide variety of dimension-
ing shapes, including horizontal and vertical 
baselines, horizontal and vertical outside 
dimensions, and diameter and radius 
dimensions. 

A Linear dimension line
B Angle dimension line

C Radius dimension line

For details, use these 
online Help keywords:

• Drawing scales

• Measurements

• Dimensions of 
shapes

A

B

C
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Positioning shapes precisely

When you are positioning shapes on a drawing 
page, speed and precision count. You can easily 
align shapes with other shapes or with loca-
tions indicated by guides, rulers, or grids. For 
example, you can snap cabinet shapes to wall 
shapes, or you can snap Process Engineering 
shapes to grid lines to align them with the grid 
and make it easier to draw pipelines between 
them.

You can also position a shape by typing its 
exact location in a coordinate system.

Snapping to grids, guides, and 
guide points
To position shapes quickly and accurately, you 
can snap them into position. Snapping pulls 
shapes to rulers, grids, or guides and is useful 
for positioning and aligning shapes. 

To set snap settings for grids, guides, and rulers

1 Choose Tools > Snap & Glue.

2 Under Currently Active, make sure Snap is 
checked.

3 Under Snap To, check Ruler Subdivisions, 
Grid, and Guides, and then click OK.

Snapping to shapes
You can snap to geometric points on shapes, 
such as the endpoints of lines or the center 
point of circles, or to shape handles. Snapping 
to shapes is useful when you want to position a 
shape at an exact point on another shape with-
out knowing that point’s coordinates. For 
example, you can snap a line to a quadrant on a 
circle.

Snapping to geometric points is similar to 
using object snaps in Autodesk AutoCAD. 

To set snap settings for shapes

1 Choose Tools > Snap & Glue.

2 Under Currently Active, make sure Snap is 
checked.

3 Under Snap To, check Shape Handles 
(selection handles), Shape Vertices, and 
Connection Points, and then click OK.
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Positioning shapes by using the 
dynamic grid
When you turn on the dynamic grid, dotted 
lines show the most desirable position of a 
shape in relation to the shapes near it. The grid 
lines help you align shapes at their center 
points. For example, if you are positioning a 
chair shape near a desk shape, the dynamic grid 
indicates when the centers of the two shapes 
are aligned.

To turn on the dynamic grid

1 Choose Tools > Snap & Glue. 

2 Under Currently Active, check Dynamic 
Grid, and then click OK.

Positioning shapes by using 
coordinates
You can position shapes at exact x- and y-coor-
dinates in your drawing. The x- and y-
coordinate values determine the position of a 
shape’s reference point, or pin, on the page. 
You can change the location of a reference 
point on a shape. For example, the reference 
point of a desk could be the center point or the 
lower-left point of the desk.

To position a shape by using coordinates

1 Drag a shape to the approximate location 
you want on the page. 

2 Choose View > Windows > Size & Position, 
or double-click the status bar.

3 To change the shape’s reference point, click 
in the Pin Pos box, and then select a loca-
tion from the list.

4 To position the shape at an exact location, 
enter values for the new location in the X 
and Y boxes. 

5 Click OK to position the shape.

For details, use these 
online Help keywords:

• Snapping shapes 
into place

• Guides and guide 
points

• Grid lines

• Positioning shapes
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Moving a shape a specified 
distance
You can move a shape by simply selecting the 
shape and dragging it to a new location on the 
drawing page. To move a shape a small amount 
in one direction, use the arrow keys to nudge 
the shape.

If you want to move a shape a specified dis-
tance, use the Move command. By using this 
command, you can specify the distance along 
the x- and y-axes, or the distance and the angle 
of the move. 

Move a shape by specifying the distance along the 
x- and y-axes of the page.

Move a shape by specifying the distance and angle of 
the move.

To move a shape a specified distance along the 

x- and y-axes of the page

1 Select the shape you want to move.

2 Choose Tools > Macros > Visio Extras > 
Move.

3 Under Relative To, click Page.

4 Under Coordinates, click X-Y.

5 In the X and Y boxes, specify the horizontal 
and vertical distances you want to move the 
shape. For example, to move a shape 1 inch 
to the right and 2 inches up on the page, 
type 1 inch in the X box and 2 inches in the Y 
box.

6 Click OK to move the shape.

Drawing shapes by using shape 
extension lines
When you are drawing shapes, you can snap to 
points on other shapes by using extension lines 
that appear when your pointer is positioned 
near the target point. For example, when you 
are drawing a mechanical part, you can use 
shape extension lines to draw a line that inter-
sects another line at its exact midpoint.

If you are drawing isometric diagrams, you can 
turn on isometric extension lines to help you 
draw lines along isometric planes.

For details, use these 
online Help keywords:

• Move tool

y

x

Ay

x

B

27o

y

x
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To turn on shape extensions

1 Choose Tools > Snap & Glue.

2 On the General tab, under Snap To, check 
Shape Extensions.

3 On the Advanced tab, under Shape Exten-
sion Options, check the ones you want. 
Click the Help button ( ) to see an expla-
nation of the options. 

4 Click OK.

5 While using a drawing tool, move the 
pointer toward or along a shape to see a 
shape extension.

Shape extensions work with the line, arc, free-
form, pencil, ellipse, rectangle, and connection 
point tools.

To turn on isometric extensions

1 Choose Tools > Snap & Glue.

2 On the General tab, under Snap To, check 
Shape Extensions.

3 On the Advanced tab, under Shape Exten-
sion Options, check Isometric Angle Lines. 

4 In the Isometric Angles box, type the angles 
you want. For example, type 30, 90, 150.

5 Click OK.

6 While using a drawing tool, move the 
pointer toward or along a shape to see an 
isometric shape extension line.

Offsetting shapes
You can offset shapes to create a set of parallel 
shapes on either side of the original shape. For 
example, you can offset a circle to create con-
centric circles for a mechanical part drawing.

You can offset lines, arcs, circles, rectangles, 
and polylines. If the offset to a curve is not an 
arc, the curve is approximated by a spline (a 
curve that passes through specified points). 

To offset a shape

1 Select the shape and choose Shape > Opera-
tions > Offset. 

2 In the Offset dialog box, enter the distance 
for the offset. Click OK to create the offset 
shapes.

3 If you do not need both inside and outside 
offsets, delete the one you don’t want.

Original circle Offsets on the inside and 
outside of the original 
circle
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Working with large drawings

Many engineering drawings are large and con-
tain many shapes. Visio 2000 provides tools 
that let you easily locate and magnify details in 
a drawing.

Zooming and panning drawings
Instead of frequently zooming in and zooming 
out of a drawing, you can use the Pan & Zoom 
window to quickly locate and magnify an area 
of a large drawing. Panning moves the visible 
part of the drawing in the drawing window. 
Zooming changes the magnification of the 
drawing. 

To zoom and pan a drawing

1 Choose View > Windows > Pan & Zoom.

2 In the Pan & Zoom window, drag a box 
around the area you want to magnify.

3 To pan to a different part of the drawing, 
drag the box.

For details, use this 
online Help keyword:

• Zooming

Pan & Zoom

window

View in Pan & Zoom window View in drawing page

A
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For CAD users: Drawing in Visio 2000

When you create an engineering drawing in 
Visio 2000, you use intelligent SmartShapes® 
symbols that graphically represent real-world 
objects and functionally behave like those real-
world objects. For example, when you draw a 
floor plan, you can add windows by simply 
dragging window shapes onto wall shapes. The 
window shapes automatically align with the 
wall shapes and assume the correct wall thick-
ness. When you move a wall in your drawing, 
the windows move with it.

Creating drawings by using intelligent shapes 
allows you to focus on the design of your 
building, process plant, electrical circuit, or 
ventilation system rather than on the tools you 
use to draw and redraw the symbols you need. 

Of course, if you do need to create your own 
shapes by using lines, circles, and arcs, you can 
use drawing tools and shape operations, such 
as Combine and Fragment. You can add intelli-
gent behavior to your shapes so that they are as 
easy to use as the shapes that are provided in 
Visio 2000.

Because you work with intelligent shapes in 
Visio 2000, many of the CAD operations you 
might have used in CAD programs do not 
exist. Other CAD operations are slightly differ-
ent (and easier) in Visio 2000. The following 
table matches some common CAD operations 
to their Visio 2000 equivalents. 
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CAD actions in Visio 2000

To perform this CAD action Do this in Visio 2000

Set drawing scale Choose File > Page Setup, click the Drawing Scale 
tab, and then select a scale. Unlike in CAD drawings, 
you generally set the scale for a Visio drawing before 
you begin the drawing.

Move an object Select the shape and drag it.

Move an object a specific distance Select the shape and choose Tools > Macros > Visio 
Extras > Move.

Copy an object Select the shape and use Ctrl+C and Ctrl+V to copy 
and paste the shape, or press Ctrl and drag the 
shape to copy it.

Plot a diagram Choose File > Print.

Create a block Use the Visio drawing tools to create a shape, and 
then drag the shape to a stencil.

Pan and zoom a drawing Choose View > Windows > Pan & Zoom to open a 
window in which you can adjust the view of a 
drawing.

Create objects by using operations such as 
Union, Fragment, and Join

Choose Shape > Operations and choose an action.

Add a hatch pattern to an object Select the shape and choose Format > Fill. Choose 
options from the Color, Pattern, and Pattern Color 
lists. You can also create your own patterns.

Use entity snaps or object snaps Choose Tools > Snap & Glue and check Shape 
Extensions. On the Advanced Tab, check the shape 
extension options you want (for example, Segment 
Midpoint).



Topics in this chapter

3
Working with
CAD drawings

You can insert existing CAD drawings into 
your Visio® 2000 Technical Edition drawings 
to use as background images or as detail 
images. For example, you might want to insert 
a floor plan drawn in Autodesk AutoCAD and 
add HVAC shapes on top of the floor plan. Or 
you might want to insert an equipment draw-
ing into a Process Engineering document. 

After you insert a CAD drawing, you can drag 
Visio shapes onto it, change its drawing scale, 
crop and pan it, and hide or show its layers or 
levels. 

If you need to modify or delete objects in the 
CAD drawing, you can convert the CAD 
objects into Visio shapes. You can also convert 
Visio drawings into CAD format.

Inserting CAD drawings into Visio 
drawings .............................................. 36

Modifying inserted CAD drawings .......... 39

Converting CAD drawings into 
Visio format ......................................... 41

Converting Visio drawings into 
CAD format ..........................................42
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Inserting CAD drawings into Visio drawings

When you insert existing CAD drawings into a 
Visio drawing, the inserted drawing is a copy of 
the original CAD drawing. Changes you make 
to the drawing within Visio 2000 do not alter 
the original drawing. 

You can insert CAD files in the following 
formats:

• Autodesk AutoCAD DWG and DXF file 
formats

• Bentley MicroStation DGN file format

Inserting CAD floor plans as 
background images
You can insert a floor plan drawn in a CAD 
package into your Visio drawing to use as a 
background page or as a reference layer. 

After you have inserted the floor plan, you can 
drag Visio shapes onto it, add comments, or 
hide layers. Visio shapes will snap to objects in 
an inserted DWG drawing.

To make it easier to select and move the shapes 
you drag onto a background image, you should 
lock the Visio layer that contains the inserted 
CAD drawing so that you do not accidentally 
select and move the CAD drawing instead of 
your Visio shapes.

CAD floor plan

You can drag Visio shapes onto an inserted CAD drawing.
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To insert a floor plan as a background image

1 Create a blank Visio drawing that has the 
page size and drawing scale you want. 

2 In the Visio drawing, choose Insert > CAD 
Drawing. 

3 Under Files Of Type, select the CAD draw-
ing file format you want. Locate the CAD 
file containing the background image and 
click Open.

4 If you plan to drag shapes such as office fur-
niture onto the CAD drawing, set the CAD 
drawing and the Visio drawing to the same 
scale. For details, see “Changing the scale of 
an inserted drawing” on page 39. 

5 On the General tab of the CAD Drawing 
Properties dialog box, check Lock Position 
and Lock Cropping so that you don’t acci-
dentally move or resize the drawing while 
you are working with it. Click OK to begin 
working with the inserted drawing.

6 To lock the Visio layer that contains the 
inserted drawing, right-click the inserted 
drawing and choose View > Layer Proper-
ties. Click the Lock column for the CAD 
Drawing layer, and then click OK.

Inserting CAD drawings as detail 
images
You can insert a CAD drawing into an existing 
Visio drawing to show a detail of a floor plan or 
of a mechanical part. 

After you have inserted the detail image, you 
can add comments to it, crop it, change its 
scale, or hide layers.

You can insert a CAD drawing to show a detail of a 
mechanical part, a portion of a floor plan, or an alternate 
view of an object.

For details, use these 
online Help keywords:

• CAD files
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To insert a CAD drawing as a detail image

1 Open the Visio drawing into which you 
want to insert the CAD drawing.

2 Choose Insert > CAD Drawing. 

3 Under Files Of Type, select the CAD draw-
ing file format you want. Locate the CAD 
file you want and click Open.

4 If you want to reduce or enlarge the image, 
set the CAD drawing scale on the General 
tab of the CAD Drawing Properties dialog 
box. 

If you are not planning to drag Visio shapes 
onto the inserted image, you can set the 
CAD drawing to a scale different from that 
of  the Visio drawing. For details, see 
“Changing the scale of an inserted drawing” 
on page 39. 

5 On the General tab, uncheck Lock Position 
and Lock Cropping so that you can move 
and crop the inserted CAD drawing. Click 
OK to begin working with the inserted 
drawing.

6 To position the CAD drawing on the Visio 
page, select the drawing and drag it.

7 If necessary, crop and pan the drawing so 
that only the portion of the CAD drawing 
that you want is visible. For details, see 
“Cropping inserted drawings” on page 40. 

8 When the CAD drawing is positioned where 
you want it, right-click the drawing and 
choose CAD Drawing Object > Properties. 
Check Lock Position and Lock Cropping, 
and then click OK.
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Modifying inserted CAD drawings

You can work with an inserted CAD drawing 
in many ways. You can drag Visio shapes onto 
it, rescale it, crop and pan it, or hide and show 
layers or levels. 

Changing the scale of an inserted 
drawing
When you insert a CAD drawing, Visio 2000 
chooses a drawing scale that fits the CAD 
drawing onto the Visio drawing page. You can 
change the scale of the CAD drawing to make it 
larger or smaller, and you can match the scale 
of the CAD drawing to the Visio drawing scale.

To change the scale of a CAD drawing

1 Right-click an inserted CAD drawing and 
choose CAD Drawing Object > Properties.

2 Click the General tab and choose a CAD 
Drawing Scale option. For details about 
these options, see the following table. 

3 Verify the size of the CAD drawing on the 
Visio drawing page by looking at the pre-
view. If the CAD drawing does not fit on the 
Visio drawing page, try the following 
actions:

• Choose a smaller CAD drawing scale 
or Visio drawing scale. For example, 
3/32 inch = 1 foot is a smaller scale than 
1/4 inch = 1 foot, and will show more of 
the inserted CAD drawing.

• Choose a larger page size. For example, 
the ANSI Architectural page size of 36 
inches by 24 inches might be large 
enough to display an entire floor plan. 
Click Page Setup. On the Page Size tab, 
select a page size, and then click OK.

4 Click OK to accept your changes. If you 
have chosen to set the CAD drawing to a 
scale different from that of the Visio draw-
ing, click Continue Without Matching Scale 
in the dialog box, and then click OK.  

For details, use these 
online Help keywords:

• CAD files

CAD drawing scale options

If you want to do this... Choose this CAD scale option...

Drag Visio shapes onto an inserted 
CAD drawing.

Click Pre-defined Scale, and then select Page Scale. This option 
matches the CAD drawing scale to the Visio drawing scale so 
that shapes are sized correctly when you place them on the 
CAD drawing.

Set the CAD drawing scale to a 
smaller or larger scale than the Visio 
drawing scale.

Click Pre-defined Scale, and then select an industry and a 
specific scale from the list. When you select this option, Visio 
shapes that represent physical objects (such as desks and 
chairs) are not sized correctly when you place them on the CAD 
drawing. You can, however, use annotation shapes or add text 
blocks to the inserted drawing.

Set your own scale. Click Custom Scale, and then type in a scale. CAD drawings 
generally have a custom scale when you first insert them. 
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Cropping inserted drawings
You can select an inserted CAD drawing and 
move it around the page like any Visio shape. 
You can crop the inserted drawing to focus on 
certain details. 

You can crop an inserted CAD drawing to focus on one 
part of the drawing.

To crop an inserted drawing

• Select the crop tool ( ), and then click the 
CAD drawing. Drag a selection handle ( ) 
to crop the drawing.

• To move the CAD drawing inside its draw-
ing border (pan the drawing), click inside 
the border and drag the drawing.

Hiding layers or levels
You can hide layers or levels to hide objects in 
an inserted CAD drawing. For example, you 
might want to turn off all the layers containing 
office furniture in a CAD floor plan so that you 
can drag Visio office furniture shapes onto the 
floor plan.

To hide layers or levels

1 In Visio 2000, right-click the CAD drawing 
and choose CAD Drawing Object > Proper-
ties. Click the Layer tab or the Level tab.

2 To hide a layer or level, uncheck it, and then 
click OK. 
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Converting CAD drawings into Visio format

When you insert a CAD drawing, you get an 
image of the CAD drawing that you cannot 
alter by deleting, resizing, or modifying the 
objects in the drawing. If you need to modify 
the CAD objects in a drawing, you must con-
vert those objects into Visio shapes. For 
example, if you want to move an interior wall 
in a floor plan, you must convert the CAD 
objects that represent the wall into Visio 
shapes. You select the objects to convert by 
selecting the CAD layer or level on which they 
appear.

Converting CAD objects into 
Visio format 
Whenever possible, convert only the CAD lay-
ers that contain objects that you want to 
modify. Working with an unconverted CAD 
drawing is faster and generally gives you better 
visual results. 

You can do many editing tasks on inserted 
CAD drawings that are not converted. You can 
drag Visio shapes onto unconverted layers, 
hide layers, redline or mark up layers, and 
resize or crop the inserted drawing.

To convert CAD objects

1 In Visio 2000, right-click the CAD drawing 
and choose CAD Drawing Object > Convert.

2 In the Convert Wizard, Ctrl+click to select  
the layers or levels containing the objects 
you want to convert. Click Next.

3 Choose whether to delete or hide the origi-
nal layers or levels. 

4 For DWG files, specify how you want to 
convert dimensions:

• To get dimension lines that are updated 
when you resize the associated Visio 
shapes, click Convert Into Visio’s 
Dimension Shapes. Converted 
dimension lines lose their original CAD 
font and line style.

• To preserve the CAD formatting of 
dimensions, including the font and line 
style, click Convert Into Lines And Text.

5 Click Finish to convert the objects on the 
selected CAD layers or levels.

For details, use these 
online Help keywords:

• CAD files
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Converting Visio drawings into CAD format 

You can convert, or export, Visio drawings 
into CAD format by choosing the Save As com-
mand. For example, if you work with engineers 
or customers who have a CAD drawing pro-
gram, you can create drawings in Visio 2000 
and convert them into CAD format when you 
send them for review.

You can convert files into the following 
formats:

• Autodesk AutoCAD DWG and DXF file 
formats

• Bentley MicroStation DGN file format

Converting drawings works best in one direc-
tion: either from CAD format into Visio 
format, or from Visio format into CAD format. 
Because each file format supports capabilities 
that are unique to its program, converting a file 
only once best maintains data integrity. For 
example, if you convert CAD dimension lines 
into Visio format, the dimension lines lose 
their formatting, such as fonts, line styles, 
and fills.

Visio 2000 converts the current Visio drawing 
page into CAD format. If you have a multipage 
Visio drawing, you must convert each page 
separately. 

To convert a Visio page

1 Go to the Visio drawing page you want to 
convert, and then choose File > Save As.

2 Under Save As Type, select the CAD draw-
ing file format (for example, AutoCAD 
Drawing [*.dwg]), and then click Save.
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4
Process Engineering: 
Drawing PFDs and P&IDs

Industries of all kinds rely on process plants to 
manufacture and deliver products or refined 
materials. Effectively managing the design of 
processes and the systems that support them is 
critical to the success of these plants.

The Process Engineering solution provides the 
drawing tools you need to create PFDs (pro-
cess flow diagrams) and P&IDs (piping and 
instrumentation diagrams) and tools for creat-
ing process component specifications.

Using the Process Engineering solution, 
you can

• Quickly and efficiently create and modify 
PFDs and P&IDs.

• Add data about process components 
directly to your diagrams and automatically 
generate lists or bills of materials from the 
diagrams.

• Automatically number or tag process com-
ponents.

• Create company-standard formats for doc-
uments such as datasheets and lists.

• Share diagrams with other team members.

Working in projects ......................................... 44

Creating PFDs and P&IDs ............................... 46

Working with component data....................... 50

Creating your own process shapes ............... 55

Sharing and reviewing PFDs and P&IDs....... 56

Customizing diagrams, datasheets, 
and lists ................................................57
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Working in projects

P&IDs are some of the most important draw-
ings in the design of a process plant. Before you 
actually build the process plant, the equipment 
and piping shown on a P&ID must be fully 
specified, ordered, and assembled. In the past, 
managing the volume of diagrams and related 
equipment lists (or bills of materials), 
datasheets, and assembly drawings required 
complex and expensive tools.  

In the Process Engineering solution, you work 
in projects where you create and edit the PFDs, 
P&IDs, datasheets, and lists for your project. 
The Project Explorer makes it easy to locate 
and open project-related documents. 

Exploring the sample project
Visio® 2000 Technical Edition includes a full 
sample Process Engineering project, including 
sample P&IDs, datasheets, and lists. Exploring 
the sample project is a good way to learn more 
about the Process Engineering solution.

Try it:  Explore the sample project

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click Open Existing 
File, and then double-click Browse Existing 
Files. In the Open dialog box, navigate to 
Visio\Samples\Process Engineering\Process 
Engineering Project. Select Sample 
Project.vsd and click Open. 

2 In the Project Explorer, click the Project 
tab. Double-click SamplePID1 to open the 
sample P&ID. 

3 Select the Centrifugal Pump shape in the 
diagram, and then choose Process 
Engineering > Datasheets > Edit Datasheet 
to see the specifications for the pump. 
Choose File > Close to close the datasheet.

     

Project view shows all 
of the diagrams in a 
Process Engineering  
project.

Components view shows 
the datasheets of all the 
components in a project. 
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4 In the Project Explorer, click the Compo-
nents tab to see a list of all the datasheets in 
the sample project. Click the plus sign (+) 
next to Valves to see the Valve datasheet, 
and then click the plus sign next to Valve to 
see the tags of all of the valves in the project 
that use that datasheet. Right-click any valve 
and choose Edit Datasheet to open its 
datasheet. 

5 In the Components tab, right-click any 
valve and choose Go To Shape. The valve is 
highlighted in the drawing.

6 When you are finished exploring, choose 
Process Engineering > Close Project.

Starting a new project    

To use the Process Engineering intelligent 
shapes and to access process component data, 
you must work in a project. Starting a new 
project is as easy as starting any new drawing in 
Visio 2000. After you have started and named a 
project, the Process Engineering menu appears 
on the Visio 2000 main menu bar. The com-
mands you need to work with drawings and 
data appear on that menu. 

You should create a Process Engineering 
project for each engineering project you are 
working on. You can create as many projects as 
you need, although you can open only one 
project at a time. You should store all of the 
Process Engineering files for a single project in 
the same project folder. 

Try it:  Start a new project 

1 Create a project folder on your computer 
named Heat Project. 

Each separate Process Engineering project 
should have its own folder.

2 In Visio 2000, choose File > New > Process 
Engineering > Process Engineering. Click 
the Create A New Project option, and then 
click the Browse button to locate and open 
the Heat Project folder. 

3 Name the project Heat_Proj.vsd, and then 
click Save. Click OK to open the new 
project.

TIP To make it easier to distinguish project files 
from diagrams, you should indicate in the 
file name whether a VSD file is a project file or 
a diagram.

Opening an existing project
To open an existing project that was saved in 
this release of Process Engineering, open the 
project file.

To open an existing project that was created in 
a previous release of Process Engineering, open 
the project file. Visio 2000 converts all of the 
project diagrams and documents into the new 
format for Visio 2000. Your documents will 
not lose any data; however, your existing files 
will be saved in a backup folder for 
safekeeping. 

For details, use this 
online Help keyword:

• Projects
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Creating PFDs and P&IDs

You create PFDs and P&IDs by dragging Pro-
cess Engineering shapes from stencils onto 
your drawing page. The Process Engineering 
solution comes with a library of SmartShapes® 
symbols that are specifically designed for pro-
cess engineering schematics.

Unlike objects drawn with a computer-aided 
design (CAD) program, Process Engineering 
shapes behave in ways that make it easy for you 
to create and modify your schematics. Shapes 
that represent related process components are 
associated in the diagram and move together. 
Pipelines stretch and contract as you move 
equipment shapes on the diagram, and valves 
reorient themselves as the pipeline they are on 
moves. You do not need to redraw shapes as 
you change your diagrams.  

Pipelines connect equipment shapes on a P&ID. 
Pipelines are drawn with Visio connectors.

Valves rotate into position and glue themselves to a 
pipeline as you drag them onto the pipeline.

Drawing PFDs and P&IDs
The most efficient order for drawing a PFD or 
P&ID is given in the following steps. For an 
example of a P&ID that is similar to the one 
you will create in this chapter, see 
SamplePID1.vsd in the sample project.

Try it:  Draw a P&ID

1 Open the Heat_Proj.vsd project file you cre-
ated in “Starting a new project.” If the 
default blank drawing page is open, choose 
File > Close to close it.

2 Choose Process Engineering > New Project 
Document > Drawing. Name the drawing 
Steam1.vsd, and choose a sheet format from 
the Based On list to determine the page size, 
border, and title block format of the new 
diagram. Click OK to open a drawing page 
that has the Process Engineering stencils 
next to it.

3 Click the Equipment - Pumps stencil to see 
the pump shapes, and then drag the Cen-
trifugal Pump shape from the stencil onto 
the drawing page. 

4 From the Equipment - Heat Exchangers 
stencil, drag the Shell And Tube shape to 
the right of the pump shape, and then 
choose Shape > Rotate Left. If necessary, 
press Ctrl+Shift+click to zoom in.

5 Click the connector tool ( ) on the Stan-
dard toolbar to draw a pipeline. Click the 
outlet arrow on the Centrifugal Pump shape, 
and then drag the connector tool to any con-
nection point on the Shell And Tube shape. 
The endpoints of the pipeline turn red when 
the two shapes are connected. 
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TIP You can connect a pipeline to any point 
on the outside of an equipment shape. 
Visio 2000 creates a new connection point 
wherever you attach the pipeline.

6 Click the pointer tool ( ), and then from 
the Valves And Fittings stencil, drag the 
Check Valve shape onto the pipeline. 

The valve is now associated with this pipe-
line and moves with it. You’ll learn more 
about association in the next section.

7 From the Instruments stencil, drag the Indi-
cator shape and place it above the pipeline 
to the right of the Check Valve.

8 Drag the association control handle ( ) 
from the instrument to the pipeline. 

A red dashed line appears, indicating that 
the instrument is now associated with the 
pipeline it monitors and will move with the 
pipeline.

9 Choose File > Save. 

You can quickly change some Process Engineering 
shapes by right-clicking the shape and choosing a 
different shape variation from the shortcut menu.

For details, use these 
online Help keywords:

• Process 
Engineering solution

A P&ID drawing

The Process Engineering solution provides drawing tools with which you can quickly and efficiently create and 
modify PFDs and P&IDs.
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Associating components in 
diagrams
A P&ID shows how physical components are 
functionally or mechanically related. In a 
Visio 2000 P&ID, this relationship is called an 
association. You can associate shapes when the 
shapes need to stay together in a drawing. You 
can also associate shapes when the components 
they represent are functionally dependent. For 
example, because a valve is physically mounted 
on a pipeline, the valve is functionally depen-
dent on the pipeline.

Visio 2000 automatically creates an association 
between a shape that represents an in-line 
component, such as a valve, and the pipeline 
shape to which the component is dragged. 
Pipelines are automatically associated with 
equipment and with other pipelines to which 
they connect.

You can manually create associations between 
shapes that represent offset components, such 
as a monitoring instrument that is not 
mounted directly in a pipeline. You can also 
manually associate annotation shapes with 
component shapes so that text you add to the 
diagram stays with the shape it describes. 

Drag the association control handle from an 
instrument (B) to a valve (A) to manually associate 
the two components.  

For details, use these 
online Help keywords:

• Associating shapes 
with data

B

A

Associating a valve

with a pipeline

Some components in a P&ID are automatically associated to show the relationship between them. The association 
control handle (A) turns red to show that this valve is associated with the pipeline.

A
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Grouping components
You can group Process Engineering shapes to 
make it easy to repeat the same sequence of 
shapes in a P&ID. For example, you could 
group the pumps, valves, and instruments used 
in feedwater lines. While a group is easy to 
move or copy as a unit, the components are 
still listed individually when you generate lists 
or add data to components. To group shapes, 
select the shapes and choose Shape > 
Grouping > Group.

Collections of components, or assemblies, are 
sometimes assembled as a unit and then 
installed in the process plant. You can create an 
assembly by grouping shapes and then convert-
ing the group into a Process Engineering shape. 
The assembly is treated as a single shape that has 
one datasheet and one tag. For more informa-
tion about converting shapes, see “Creating 
your own process shapes” on page 55. 

NOTE The Group command replaces the Process 
Engineering > Make Assembly command that 
was in previous releases of Process Engineering.

Modifying your diagrams
As you design and refine a process, you need to 
be able to manipulate components on your 
diagrams quickly and easily. The intelligent 
shapes in Visio 2000 make it easy for you to 
modify diagrams. 

To move an equipment shape, simply select it 
and move it. All of the pipelines connected to 
the shape move with it. Pipelines stretch or 
contract as needed; pipelines can even jump 
over other pipelines. Branched pipelines retain 
their branches.

Valve shapes move with the pipeline with 
which they are associated. To move a valve 
shape along a pipeline, select it and slide it. If 
you move the valve around a bend in the line, 
the valve will reorient itself to match the line.

To change a pipeline’s appearance, select the 
pipeline, and then select a new style from the 
Line Style list on the Format Shape toolbar. 
The Process Engineering solution provides 
styles for many types of pipelines and signal 
lines, including hydraulic and electrical lines.

For details, use this 
online Help keyword:

• Groups

Moving equipment 

shapes

As you move equipment shapes, the connecting pipelines are rerouted and valves are repositioned.
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Working with component data

From the piping and fittings you order from 
standard vendor catalogs to the custom equip-
ment you have manufactured for your plant, 
you specify and track large amounts of data 
about the components in your process plant. 
In the Process Engineering solution, you can 
add data directly to components in the dia-
gram—without calling up a separate database 
or spreadsheet program. 

Each component in a diagram has a related 
datasheet, an electronic form that contains 
fields of data for the component. For example, 
the datasheet for a pipeline generally specifies 
the line size, material, and design temperature 
and pressure. 

Storing component data in Process Engineer-
ing datasheets makes creating lists of 
equipment, valves, instruments, and pipelines 
easy. Instead of typing lists by hand, you can 
quickly generate lists of components directly 
from the datasheets, and you can quickly 
update component data directly from the dia-
gram or from the Components tab of the 
Project Explorer.

Add data to diagrams by filling out a datasheet for each 
Process Engineering component in your diagram.

VALVE

Tag V--1 Description

Physical Data

Valve Size inch End Connection* *

Line Size inch Minimum Wall Thickness* *
Schedule Diameter* *

inch

inch

Design Data

Design Temperature *

Design Pressure *
ANSI Class *

psig

deg F

Power *
Material *

Manufacturer Data

Manufacturer *

Model Number *

Type *

SubType *

General

Remarks

Default ProjectANSI

Visio

Seattle

SIZE

SCALE

FSCM NO DWG NO

SHEET1 : 1

A Def Proj 1

1 of 1
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Entering component data
You can enter all the data for one component 
at a time or finish a portion of a diagram and 
enter data for several components at once. You 
can always edit the datasheet for a component 
later as you refine component selection and 
add more detailed data.

The Datasheet window stays open so that you can add 
data to or edit data for several shapes at once.

A component might inherit values from 
another component. For example, all valves on 
a pipeline generally inherit the line size. Inher-
ited values are automatically placed in the 
datasheet for a secondary component.

Try it:  Enter data for a single component

1 Open the Steam1.vsd diagram you created 
in “Drawing PFDs and P&IDs.”

2 Select the Centrifugal Pump shape on the 
diagram, and then choose Process 
Engineering > Datasheets > Edit Datasheet.

3 Tab through the fields and fill them in with 
values that are typical for this type of pump. 
Some fields have a drop-down list that 
appears when you tab to the field; others 
have a check box. 

4 Choose File > Close to exit the datasheet 
and save your changes.

Try it:  Enter data for several components 

at once

1 In the Steam1.vsd diagram, choose Process 
Engineering > Datasheet Window. 

2 Select several valves in the diagram and set 
some values that are typical for these types 
of valves in the Datasheet window. The 
datasheet is automatically updated as you 
type values into the Datasheet window.

For details, use these 
online Help keywords:

• Datasheets

• Datasheet window
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Displaying component data in 
the diagram
You can display data from a component’s 
datasheet in special annotation labels on your 
diagram. For example, a label could show the 
Line Size field from a pipeline datasheet. When 
you update the datasheet, the label on the dia-
gram is automatically updated. 

Try it:  Display a data field in the diagram

1 From the Process Annotations stencil, drag 
the Automatic Label 1 shape onto the draw-
ing page near the pipeline.

2 Drag the association control handle from 
the Automatic Label 1 shape to the pipeline. 
In the Select Field To Display dialog box, 
select Line Size, and then click OK.

The Automatic Label 1 shape is now linked 
to the datasheet so that changes you make 
to the Line Size field are displayed in the 
Automatic Label 1 shape. 

3 In the Datasheet window, set the line size 
and update the label shape.

Automatic labels

Automatic Label shapes display data from a component’s datasheet directly on the diagram.

�

�

VALVE

Tag V--1 Description

Physical Data

Valve Size inch End Connection* *

Line Size inch Minimum Wall Thickness6 *
Schedule Diameter* *

inch

inch

VALVE

Tag V--1 Description

Physical Data

Valve Size inch End Connection* *

Line Size inch Minimum Wall Thickness8 *
Schedule Diameter* *

inch

inch
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Numbering or tagging 
components
Component tags often provide information 
about components. A pipeline tag might indi-
cate the line size, pressure rating, material, and 
type of fluid carried. 

To make entering tags faster, you can set up 
datasheets so that component tags are con-
structed directly from certain fields in a 
datasheet. These intelligent tags appear on the 
diagram when you enter data into the datasheet 
for the component. The default datasheets for 
components have intelligent tags. 

You tag a component by using the Edit Tag 
Number command. If a component does not 
have an intelligent tag, you simply type the new 
tag number into a dialog box. If a component 
has an intelligent tag, you type values into the 
datasheet fields that form the tag number. You 
can also override an intelligent tag and manu-
ally type in a tag number. 

You edit an intelligent tag by changing the datasheet 
fields from which the tag is constructed.

You can create your own tagging scheme by 
creating intelligent tags for your customized 
datasheets. For information on creating an 
intelligent tag, see “Creating intelligent tags” 
on page 60. 

Try it:  Tag a pipeline

1 Open the Steam1.vsd diagram you created 
in “Drawing PFDs and P&IDs.”

2 Right-click the major pipeline between the 
pump and the heat exchanger, and then 
choose Edit Tag Number.

3 In the Line Size field, type 4, and then click 
OK. Notice that the pipeline tag is updated 
to show the new line size.

4 To move the tag on the diagram, select the 
tag’s green control handle ( ) and move it. 
The tag moves with the control handle.

For details, use these 
online Help keywords:

• Intelligent tags
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Generating equipment, line, and 
valve lists
You can generate lists of equipment, pipelines, 
valves, and instruments directly from the data 
in datasheets. As you modify diagrams, you can 
quickly generate a new list from the updated 
datasheets. You can create lists in Microsoft 
Excel format or plain text format, or you can 
create a list in a new Visio drawing. You can 
copy and paste lists generated as Visio draw-
ings into P&IDs or other Visio 2000 drawings.

You can generate a list of all the components in 
a project, all the components in a diagram, or 
selected components in a diagram.

Try it:  Generate a list of all valves in a diagram

1 Open SamplePID1.vsd in Visio\Samples\
Process Engineering\Process Engineering 
Project. 

2 Choose Process Engineering > Lists > 
Generate List. From the List box, select 
Valve List. 

3 Under Include In List, choose Entire Docu-
ment. 

4 Under Output File, name the file. Click  
Write To Visio Drawing, and then click OK 
to generate the list.

Visio 2000 opens a new drawing page that 
contains the generated list. You can save the 
list, print it, or copy it to another Visio 2000 
drawing.

For details, use these 
online Help keywords:

• Lists of components
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Creating your own process shapes

Visio 2000 provides a number of industry-
standard shapes on the Process Engineering 
stencils. If you need additional shapes for your 
processes, you can draw your own shapes in 
Visio 2000 or import symbols created in a 
computer-aided design (CAD) program. You 
can import symbols created in Autodesk 
AutoCAD DWG or DXF format.

You must convert the shapes you create or 
import before you use them in Process Engi-
neering diagrams. Conversion adds intelligence 
to the shapes so that they can be associated 
with other shapes, have data in datasheets, and 
be included in lists. You can save the shapes 
you create or import on a stencil so that you 
can easily reuse those shapes. Stencils are saved 
with a project.

Try it:  Convert a CAD symbol library

1 Open the Steam1.vsd diagram you created 
in “Drawing PFDs and P&IDs.”

2 Choose Process Engineering > Shape Con-
version Wizard. Click Next to go to the sec-
ond screen.

3 Select the CAD Symbols From One Or 
More Files option, and then click Next. 

4 Use the Browse button to locate the file 
HeatExch.dwg in the Visio\Samples\
Process Engineering folder. Accept the 
default setting for Scaling and click Next.

5 In the table that shows the HEATEX-
CHANGER shape, click the Shape Type 
field and select Equipment from the drop-
down list. Click the Datasheet field and 
select Heat Exchanger. Click Next.

6 Map the block attributes from the DWG file 
into datasheet fields. For the MANUFAC-
TURER attribute, click the Assigned Fields 
column and select Manufacturer from the 
list. Similarly, set the TEMPERATURE 
attribute to the Design Temperature field, 
and set the PRESSURE attribute to the 
Design Pressure field. Click Next.

7 Name the stencil Imported Heat Exchanger.

8 Click Finish to complete the wizard. 

The Imported Heat Exchanger stencil 
appears next to your drawing.

9 Choose File > Save to save the diagram. 

The stencil is saved with the diagram.

For details, use these 
online Help keywords:

• Converting shapes 
for Process 
Engineering solution
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Sharing and reviewing PFDs and P&IDs

PFDs and P&IDs are frequently shared by engi-
neers in a group or reviewed by project 
members. You can set up projects so that the 
project documents are accessible to everyone 
on a team.

You can send PFDs and P&IDs to engineers in 
other work groups or companies for reviewing. 
Reviewers who do not have access to your Pro-
cess Engineering project can mark up or 
redline diagrams with comments.

Setting up project folders
To make projects accessible to members of a 
team, create your projects in a shared network 
folder. All engineers in the group can work on 
the same project files in the shared folder 
(although not simultaneously).

When you start a new project, Visio 2000 
places all of the diagrams, datasheets, and lists 
associated with the project in subfolders of the 
project folder. To make it easier to maintain 
projects, do not alter the default folder 
structure.

All engineers who access a shared project must 
be using Visio 2000 Technical Edition. A 
project cannot be shared with engineers who 
have a previous version of the Process Engi-
neering solution.

Sending diagrams to reviewers
You can send PFDs and P&IDs to any reviewer 
who has Visio 2000 to mark up or redline with 
comments. Simply send the Visio drawing file 
(.vsd) that contains the diagram. To organize 
reviewer comments, you can set up a redlining 
layer for each reviewer.

To add, delete, or move process components, 
however, reviewers must have the Process 
Engineering solution installed on their com-
puters, and must have access to all of the 
project documents (diagrams, datasheets, lists, 
the project file, and the project database). If 
you are working with an external group that 
needs to modify component data but does not 
have access to your network folders, you can 
send group members the entire project. 

Printing datasheets for review
You can print all of the datasheets in a category 
at once from the Project Explorer. For exam-
ple, you can print all of the valves in a project 
for distribution or review.

To print all datasheets in a category

• In the Project Explorer, right-click a 
datasheet category or a datasheet, and then 
choose Print Datasheets.

For details, use these 
online Help keywords:

• Projects

• Redlining drawings
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Customizing diagrams, datasheets, and lists

Engineering groups usually have company-
standard formats for diagrams, datasheets, and 
lists or bills of materials. Visio 2000 provides 
default formats for all diagrams and docu-
ments in a project, but you can create your 
own formats so that a project’s documents 
conform to your company’s standards. You 
can customize datasheets and lists to include 
the fields needed for a project. You can also 
specify a unit-conversion system to use 
throughout a project. 

Sheet formats, datasheet forms, and list forms 
are saved with a project. You can set up a 
project that has the company-standard formats 
you want your engineering group to use, and 
engineers can start new projects based on your 
standard project.

Creating your own sheet formats
New diagrams are based on sheet formats that 
determine the page size and orientation of the 
page, as well as the border and title block of the 
diagram. You can create a new sheet format by 
creating a new page that has the size and orien-
tation you want, adding the title block and 
border to the page, and then assigning the new 
formats to any new diagram you start in a 
project. 

You can also create sheet formats for lists and 
datasheets.

Sheet formats determine the page size, page 
orientation, border style, and title blocks for diagrams, 
datasheets, and lists in a project.

Try it:  Create a new sheet format for diagrams

1 Open the Steam1.vsd diagram you created 
in “Drawing PFDs and P&IDs.”

2 Choose Process Engineering > New Project 
Document > Sheet Format. In the Name 
field, type Project Sheet.

3 For Based On, select None, and then click 
OK. A blank drawing page and the Sheet 
Format stencil appear.

	 
 � � � � 
 �

	 
 � � � � 
 �

�

�

�

�

�

�

�

�

Default ProjectANSI

Visio

Seattle

SIZE

SCALE

FSCM NO DWG NO

SHEET1 : 1

A Def Proj 1

1 of 1

REV

A

For details, use these 
online Help keywords:

• Sheet formats
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4 Select a border shape from the stencil and 
drag it onto the page. The border shape 
automatically resizes to fit the page. You can 
adjust the page size by choosing File > Page 
Setup and selecting a new size.

5 Drag the Title Block Small shape onto the 
page. To type text in the title block, click in a 
title block field and start typing.

6 Choose File > Save to save your new sheet 
format, and then close it. To apply the new 
sheet format to a diagram, start a new draw-
ing and choose the Project Sheet format 
from the Based On list in the New Drawing 
dialog box.

Creating your own datasheet
Visio 2000 provides default datasheets for 
equipment, pipelines, valves, and instruments. 
You can modify the default datasheets, or you 
can create your own datasheets that conform to 
your company’s specific requirements.

When you create a datasheet, you control 
which data is tracked for a component, which 
data fields are included in lists or bills of 
materials, and the format for fields on the 
datasheet. You can create sheet formats for 
datasheets that provide project information, 
such as project name, company name, 
and date. 

Custom datasheets

When you create your own datasheet forms, you specify the label, format, and default unit for each field. 

VALVE

Tag V--1 Description

Physical Data

Valve Size inch End Connection* *

Line Size inch Minimum Wall Thickness6 *
Schedule Diameter* *

inch

inch

Design Data

Design Temperature 120

Design Pressure * psig

deg C

Power *



P R O C E S S  E N G I N E E R I N G :  D R A W I N G P F D S A N D P & I D S 59
When you create datasheet forms, you assign 
datasheets to categories. A category is a collec-
tion of similar datasheet formats. For example, 
you could create different datasheet formats 
for generators and reaction vessels and group 
the formats under the general category of 
equipment. The default categories in 
Visio 2000 are valves, instruments, equipment, 
and pipelines, and you can create new catego-
ries. For example, you could refine the 
equipment category by creating a new category 
for heat exchangers.

Datasheet categories help you manage compo-
nent views in the Project Explorer. Each 
Process Engineering component is automati-
cally assigned to a layer that contains 
components that have the same datasheet 
category. 

Try it:  Create a new datasheet

1 Open the Steam1.vsd diagram you created 
in “Drawing PFDs and P&IDs.”

2 Choose Process Engineering > New Project 
Document > Datasheet. In the New 
Datasheet dialog box, name the datasheet 
MyPump, and select Equipment from the 
Based On list and from the Category list. 
Click OK.

A fast way to create a new datasheet is to 
base it on an existing datasheet and add new 
fields or modify existing fields. In this pro-
cedure, you are basing a new datasheet on 
the default datasheet for equipment.

3 In the Datasheet Builder dialog box, type 
Motor in the Field Name box. The Label box 
is updated to use the same name. 

The field name is a unique identifier for the 
datasheet field; the label is the name that 
appears on the datasheet. 

4 For Unit Type, select Power. Accept the 
default settings for the rest of the dialog box 
and click Add Field.

A field shape is added to the datasheet page, 
and the dialog box is cleared so that you can 
create the next datasheet field.

5 Add more fields, if you want to, and then 
click OK to exit the dialog box. When you 
are finished, choose File > Save to save the 
new datasheet, and then close it.

To use the new datasheet, you use the Assign 
Datasheet Wizard to assign it to some compo-
nents in your project. For example, you could 
assign this MyPump datasheet to all of the 
shapes on the Equipment - Pumps stencil. 

For details, use this 
online Help keyword:

• Datasheets
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Creating intelligent tags
You can create component tags that are auto-
matically constructed from fields in the 
component’s datasheet. These intelligent tags 
are useful for component tagging schemes that 
provide information about the component, 
such as the line size, material, and fluid.

You can set up intelligent tags that substitute 
codes for values in a datasheet field. For exam-
ple, if the fluid carried by a pipeline is 
designated as Waste Water in the datasheet, the 
tag can substitute the code WW for that value. 
You can also create tags that are automatically 
incremented as components are added to a 
diagram. 

You can modify existing intelligent tags, or you 
can construct new intelligent tags when you 
create your own datasheets. In a new datasheet, 
you should create all of the other datasheet 
fields before creating the intelligent tag because 
the tag is built from existing fields. 

You can create intelligent tags for components that are 
automatically constructed from fields in the 
component’s datasheet.

Try it:  Create an intelligent tag

1 Open the Steam1.vsd diagram you created 
in “Drawing PFDs and P&IDs.”

2 Choose Process Engineering > Tags > 
Customize Tags.

3 In the Customize Tags dialog box, select the 
Pipelines category and the Pipeline 
datasheet. Click OK to open the Tag Builder 
dialog box.

4 Select everything in the Tag Expression box 
and delete it. From the Available Fields list, 
select Fluid System and click the Add Field 
button ( ). Notice that the selected field is 
added to the expression in the Tag Expres-
sion box. 

For details, use these 
online Help keywords:

• Intelligent tags

• Datasheets
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5 Type a hyphen after the Fluid System field 
in the Tag Expression box, and then add the 
Line Size field to the tag expression.

6 Type a hyphen after the Line Size field, and 
then click the Add Counter button ( ) to 
add a counter to the tag expression. 

A counter automatically numbers compo-
nents as they are added to a diagram.

7 Click the Substitutions button, and under 
Substitution Table Assignments, select Sys-
tem from the Substitution Table field for 
Fluid System.

A substitution table appears on the right. 
When you enter a pipeline fluid in the 
datasheet for a pipeline, Visio 2000 locates 
the appropriate abbreviation and inserts 
that into the tag for the pipeline. For exam-
ple, if you specify waste water as the pipe-
line fluid, the letters WW are used in the tag 
expression.

8 Click OK to accept the substitution table, 
and then click OK again to accept the intel-
ligent tag expression. 

Now, when you fill out the datasheet for any 
pipeline, the tag is automatically updated to 
show the current values. You can also use the 
Datasheet window or the Edit Tag Number 
command to change the datasheet fields and 
update the tag.

Creating a system of units
The default datasheets are set up with conver-
sion tables for units so that you can enter 
values using the unit system you want. When 
you change the displayed unit on a datasheet, 
the value is automatically converted.

The Process Engineering solution provides 
conversion tables for common measurements 
such as length, temperature, and pressure. You 
can add additional unit types for a project by 
choosing Process Engineering > Project 
Information > System Of Units and adding a 
new unit. 

Creating your own list form
You can create your own forms for lists or bills 
of materials that you generate for equipment, 
instruments, valves, and pipelines. When you 
create a new list form, you specify which 
datasheet fields are to be included. Like dia-
grams, lists can have a sheet format.

For details, use these 
online Help keywords:

• System of units

• Lists of components
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Try it:  Create a new list form

1 Open the Steam1.vsd diagram you created 
in “Drawing PFDs and P&IDs.”

2 Choose Process Engineering > New Project 
Document > List. 

3 In the New List dialog box, type My 
Equipment List in the List Name text box, 
and then select a sheet format.

4 From the Categories & Datasheets list, click 
Equipment to select the Equipment cate-
gory. 

When you select a category, all of the 
datasheets in that category are automatically 
selected.

5 Under Choose Fields, click the fields you 
want to include in the generated list. To 
select all of the fields, click the Select All 
button. 

6 To change the order of fields in the gener-
ated list, select a field and click the Move Up 
or Move Down button.

7 Click OK to create your new list form, and 
then save and close it. 

8 To use the new list form, choose Process 
Engineering > Lists > Generate List. From 
the List box, select My Equipment List. 

9 Click Entire Document to include all shapes 
in the document. In the Filename box, type 
a file name for your generated list.  Click 
Write To Visio Drawing, and then click OK 
to write out the list.

Custom list forms

You can create your own list form by specifying the datasheet fields you want to include in the generated list. 

Tag Description Design
Pressure

Design
Temperature

Manufacturer
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Facilities Management: Drawing 
facilities plans and tracking assets

The Facilities Management solution combines 
space-planning and asset-tracking capabilities 
in one easy-to-use software package. This 
solution offers two different views of your 
facility information: a spatial view when you 
use the facilities plan, and an organizational 
view when you use Visio® CAFM Explorer. 

You can

• Create and revise facility plans based on 
head count, workstation configuration, and 
other space requirements.

• Locate and list assets, such as furniture, 
equipment, and fixtures.

• Graphically view room assignments and 
quickly update them.
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Starting your facilities plan and connecting it to a database

When you work with the Facilities Manage-
ment solution, you draw a facilities plan and 
use the drawing to track information. Your 
drawing acts as a “visual database” that you can 
use to track information about the resources 
and assets in your facility, specifically the 

spaces, boundaries, people, fixtures, furniture, 
and equipment. When you start your facilities 
plan, you connect your drawing to a facilities 
database that contains the facilities informa-
tion you want to track for your organization. 

Facilities plan

By using the Facilities Management solution, you can draw facilities plans that have asset-tracking capabilities to 
assist in managing your facilities. Visio 2000 also offers other drawing types, such as floor plans, site plans, HVAC, 
security systems, and network diagrams that you can use in conjunction with your facilities plan.
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Setting up the facilities database
To get started quickly, you can use the basic 
database that is created by default when you 
start a facilities plan. The basic database is a 
Microsoft Access database stored on your com-
puter; you do not need special permissions or 
extensive database knowledge to create it. The 
basic facilities database contains commonly 
used information about organizations, and you 
can easily add additional tracking information.

If you want to create a facilities database that is 
located on a network server, create a custom 
database. Ask your database administrator to 
create an empty database in the appropriate 
format and a data source for that database. You 
will need the data source name, a user name, 
and a password (if the database is protected) to 
begin working with your remote facilities 
database. 

You can also create a custom facilities database 
in Microsoft SQL Server format instead of 
Microsoft Access format. 

Starting your facilities plan
When you start your facilities plan, you con-
nect to your facilities database. In this 
procedure, you will connect to the default 
database.

Try it: Start a facilities plan

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Facilities Management.

3 In the Drawing Type box, double-click 
Facilities Plan. 

4 On the first screen of the Facilities Manage-
ment Setup Wizard, click Next. On the next 
screen, select Yes to track information in 
your drawing. Select Basic: Facilities 
Data.mdb to track information in the basic 
database, and then click Next.

If you have connected to the basic database 
before, the option for the basic database 
changes to Recent: Facilities Data.mdb.

5 Enter a company name, location, building, 
and floor name. 

6 Click Finish until you exit the wizard.

Now that you’ve connected to the facilities 
database, you can begin creating the building 
shell of your facilities plan.

NOTE If you want to create a facilities plan that 
has no asset-tracking capabilities, or if you want 
to diagram “what-if” scenarios, start a facilities 
plan and choose no tracking in the wizard.

For details, use these 
online Help keywords:

• Facilities 
Management 
solution
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Creating a building shell

Each page in your Visio drawing represents a 
floor or a section of a floor in your facility. You 
can represent an entire floor on one page, or, 
for example, the northeast, northwest, south-
east, and southwest sections of a floor on four 
different pages. However, you can’t represent 
more than one floor on the same page.

The Facilities Plan template opens one drawing 
page at a drawing scale of 1/8"= 1'. You already 
associated this page with the floor you specified 
during the Facilities Management Setup Wiz-
ard. Now, you create a building shell for that 
floor of your facility. With the Facilities Man-
agement solution, you can

• Create a building shell from scratch using 
the shapes on the Walls, Shell And Structure 
and the Building Core stencils. You can also 
insert a building shell you’ve already created 
using these shapes.

• Insert a building shell from a CAD 
(computer-aided design) program such 
as Autodesk AutoCAD or Bentley 
MicroStation.

• Convert an existing facilities plan created in 
a CAD program. 

NOTE If your building shell for a particular floor 
starts getting too big for the drawing, just change 
the size or scale of the page by choosing File > 
Page Setup.

As you insert building shells for each floor, you 
need to insert other pages into your drawing 
that represent other floors in your facility and 
then create or import the building shell for 
each floor. 

To associate a floor in a facility with a page in a 

Visio drawing

1 Choose Insert > Page. 

2 In the Page Setup dialog box, click OK.

3 In the Site Information dialog box, type the 
name of the floor, and then click OK.

This step associates the floor with the page, 
and changes the name of the page to match 
the floor name.



F A C I L I T I E S  M A N A G E M E N T :  D R A W I N G  F A C I L I T I E S P L A N S  A N D  T R A C K I N G  A S S E T S 67
Creating a building shell for each 
floor of your facility
The Facilities Plan template contains shapes for 
walls, doors, and windows that you can use to 
create a building shell for a particular floor. 

Drag shapes from the Walls, Shell And Structure stencil 
onto the drawing page to quickly create this building 
shell with four office spaces. 

On the first page of your facilities plan, create 
the building shell by using the shapes on the 
Walls, Shell And Structure stencil. For more 
information about creating a building shell, see 
“Drawing a floor plan” on page 90. 

If you have already created a building shell by 
using the Walls, Shell And Structure stencil, 
just copy and paste your building shell into 
your facilities plan. If you created a building 
shell that includes space shapes, the space 
shapes designate spaces for asset tracking. You 
do not need to drag  space shapes from the 
Resources stencil into offices. 

Inserting existing building shells 
in CAD format
If you have existing building shells created in a 
CAD program, such as Autodesk AutoCAD or 
Bentley MicroStation, you can insert these 
drawings into your facilities plan to use as 
background images. Each page in your drawing 
represents one floor in your facility, so import 
each shell, one floor at a time. 

To import a building shell saved in a CAD file 

format

1 After you open the Facilities Plan solution 
and complete the Facilities Management 
Setup Wizard, choose Insert > CAD Draw-
ing to insert a building shell onto the active 
drawing page.

2 In the Insert CAD Drawing dialog box, nav-
igate to the folder that contains your CAD 
drawing, select the file you want to import, 
and then click Open. 

3 In the CAD Drawing Properties dialog box, 
click the General tab, and then select the 
CAD drawing scale settings you want. 

4 Click OK to begin adding spaces to your 
building shell.

For more information about inserting CAD 
drawings, see Chapter 3, “Working with CAD 
drawings.” 

For details, use these 
online Help keywords:

• Pages

• CAD files

• Floor plans
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Converting existing building 
shells and entire facilities plans
If your entire facilities plan is in CAD file for-
mat, you can convert the drawing into Visio 
format. This converts the CAD objects that 
represent assets into Visio SmartShapes® sym-
bols. You can then convert symbols that 
represent assets into Facilities Management 
shapes that have asset-tracking capabilities. For 
example, you could convert all of the CAD 
objects that represent chairs into Visio chair 
shapes and then convert the Visio chair shapes 
into Facilities Management chair shapes.

If you created a facilities plan by using the 
Facilities Management solution in Visio Tech-
nical 5.0 Plus, you can open the plan in 
Visio 2000 Technical Edition. Your facilities 
plan is automatically converted to the new 
format. 

If you created facilities plans by using an earlier 
version of a Visio product, you can copy and 
paste these drawings into your facilities plan. If 
you paste an entire facilities plan, including the 
shell and facilities shapes, you can convert the 
shapes into Facilities Management shapes with 
asset-tracking capabilities by choosing Convert 
Shapes from the Facilities menu. 

NOTE When you paste existing Visio drawings 
into your facilities plan, make sure the scale 
matches. To check or change the scale for your 
facilities plan, choose File > Page Setup, and then 
click the Drawing Scale tab.

For details, use these 
online Help keywords:

• CAD files

• Converting shapes 
for Facilities 
Management 
solution
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Tracking people, spaces, and areas in your facilities plan

Once you’ve completed the building shell for at 
least one floor, you can begin designating and 
tracking information for spaces, such as offices 
and conference rooms, and for areas, such as 
departments. You can also assign people to 
offices and calculate the square footage allotted 
to one or to multiple departments. For exam-
ple, if you’re planning an office move, you can 
calculate how much area a specific department 
needs and allocate space accordingly.

Designating spaces
You need to designate spaces in your facilities 
plan so you can associate people and assets 
with a particular space. Just drag the Space 
shape from the Resources stencil onto a space 
in your drawing, such as an office in your 
building shell. 

If you are using a building shell that you cre-
ated by using Visio wall, door, and window 
shapes, the Space shape will automatically 
resize itself to fit the office. Otherwise, you 
must manually resize the Space shape.

Dragging the 

Space shape into 

an office

To designate an office space, just drag the Space shape from the Resources stencil into an office on the drawing 
page. The Space shape will automatically resize itself to fit an office drawn with Visio wall, door, and window shapes.

�����
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If you are using a floor plan that you previously 
created by using the Building Architecture 
solution or the Office Layout solution and that 
already contains space shapes, you do not need 
to add space shapes to your floor plan. You can 
begin assigning assets to spaces. 

In this procedure, designate the four spaces in 
your building shell as offices.

Try it: Designate office spaces in your 

facilities plan

1 From the Resources stencil, drag the Space 
shape into the top-left office in your facili-
ties plan.  The Space shape automatically 
resizes to fit the office.

2 To specify information (properties) for the 
space, double-click the Space shape. In the 
Properties dialog box, select the area beside 
the property in the Value column, and then

• Type Office 101 for the Name property.

• Type Yes for the Is Occupied property.

• Type Office for the Space Type property.

3 Click OK.

The shape’s text automatically reflects the 
name you entered for the Name property. 

4 Copy and paste the Space shape into the 
other similarly shaped spaces, and then 
enter properties for each office, numbering 
the spaces as shown.

Double-click a shape to view its category and 
properties. Values in the Properties dialog box are 
saved as soon as you change them, as is the case when 
you change the fields in a database.

Once you size a shape to fit a particular space, you can 
duplicate the shape to fit other spaces that are the same 
size. 

For details, use these 
online Help keywords:

• Space shapes
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Resizing spaces
The Space shape is automatically resized when 
you drag the shape into an office created with 
Visio wall, door, and window shapes. If you 
move a wall, you can fit the Space shape to the 
new office by using the Auto Size command.

You can also use the Auto Size command when 
you drag the Space shape into an office created 
with shapes converted from a CAD drawing or 
any other Visio shapes, such as lines or wall 
shapes from previous versions of a Visio 
product.

If you are working with an inserted CAD build-
ing shell (one that you have not converted into 
Visio format) or with rooms that are not com-
pletely enclosed by Visio wall, door, and 
window shapes, you must resize the Space 
shape manually. For irregularly shaped rooms, 
use the Edit command to modify the Space 
shape.

To resize a Space shape by using the Auto Size 

command

• If the Space shape is completely bounded by 
Visio wall and door shapes, right-click the 
Space shape and choose Auto Size. The 
Space shape is automatically resized to fit 
the new room.

• If the Space shape is bounded by shapes 
converted from a CAD drawing or by any 
other Visio shapes, such as lines, right-click 
the Space shape and choose Auto Size. 
Ctrl+click to select each bounding wall of 
the room. Be sure to select any shapes or 
lines that represent interior structural fea-
tures, such as interior columns. Click OK to 
resize the Space shape.

To resize a Space shape 
completely bounded by 
Visio wall shapes, right-
click the Space shape 
and choose Auto Size.

The Space shape expands 
to fill the room.

For details, use these 
online Help keywords:

• Editing shapes
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To resize a space by using the Edit command

1 Right-click the Space shape, and then 
choose Edit. The pointer changes to the 
pencil tool ( ).

2 Using the pencil tool, add or move vertices 
( ) or points ( ) on the shape.

Designating areas
In addition to designating spaces, you can des-
ignate areas, such as departments or teams, by 
using the Boundary shape on the Resources 
stencil. This shape marks a boundary around 
an area. You use it for computational purposes 
only; you can’t associate people or assets with a 
boundary. For example, you can use this shape 
to outline an area for which you want to calcu-
late the square footage. You can calculate the 
square footage for multiple areas the same way 
you calculate it for multiple spaces.

Try it: Designate a department boundary in your 

facilities plan

1 From the Resources stencil, drag the 
Boundary shape onto the drawing page near 
the four offices. 

2 Size the shape so that it encompasses the 
four offices.

3 Double-click the Boundary shape. In the 
Properties dialog box, select the area next to 
the Name property in the Value column, 
and then type Finance Department. Then 
click OK.

For irregularly shaped areas, you can modify a 
Boundary shape the same way you modify a 
Space shape. 

To size a Space shape to fit 
an office with an interior 
corner column, right-click the 
Space shape and choose 
Edit. Press Ctrl and click the 
Space shape at the two 
points where the column 
intersects the wall.

Drag the outer corner 
vertex to accommodate 
the column.
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Assigning people to spaces
You assign people to spaces to associate them 
with that location. In many organizations, a 
manager might occupy an office in several 
buildings or locations, and two people might 
share an office. With the Facilities Manage-
ment solution, you can assign a person to more 
than one space, and you can assign more than 
one person to a single space. 

To assign a person to a space, just drag the Per-
son shape from the Resources stencil onto a 
Space shape. When you want to move a person 
to a new office or location, just drag the Person 
shape onto the Space shape in the new location.

Try it: Assign a person to each office space in 

your facilities plan

1 From the Resources stencil, drag the Person 
shape onto the Space shape for Office 101.

When you drag a resource or asset onto a 
Space shape, you are associating it with the 
space. You must associate resources and 
assets with Space shapes if you want to use 
the Find command on the Facilities menu 
to locate them by their space later.

2 To specify information (properties) about 
the person, double-click the Person shape. 
In the Properties dialog box, select the area 
beside the property in the Value column, 
and then

• Type Eileen Adams for the Name 
property.

• To add Eileen’s manager, type Jullian 
Elliot for the Manager property.

• Type Accountant for the Title property.

3 Drag Person shapes onto the Space shapes 
for the rest of the offices in your facilities 
plan, and enter properties for each person.

NOTE You can use Visio CAFM Explorer to 
organize people within departments. For more 
information about organizing people by depart-
ment, see “Tracking organizational data by using 
Visio CAFM Explorer” on page 83. 
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Tracking assets in your facilities plan

Just as you associate people with spaces, you 
also associate assets with spaces. You can use 
the asset data you track to locate assets in your 
facilities plan or to create lists of assets.

To track assets such as fixtures, furniture, and 
equipment, you must assign asset shapes to a 
category. Many of the shapes provided with the 
Facilities Management solution are already 
assigned to categories; however, you can 
change the category of shapes or create your 
own shapes and assign a category to them. 

NOTE You might have assets that are associated 
with a floor instead of a space. For example, all 
the people on a floor might use the same fax 
machine. In this case, the fax machine doesn’t 
belong to a particular person or department, so 
you wouldn’t associate it with a space. When you 
don’t associate an asset with a space, the asset is 
associated with the floor, or page.

Assets associated

with a space

To associate an asset with a space, just drag the asset onto the space. To associate an asset with a floor, just drag it 
onto the drawing page, in an open area.
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Tracking data by using asset 
shapes
To track your assets, just drag an asset shape 
from the appropriate stencil onto a Space 
shape to associate it with that space, and then 
double-click the asset shape to specify proper-
ties. In this procedure, you will add some office 
furniture to your offices by associating the fur-
niture with specific Space shapes, and then you 
will enter property values for your assets.

NOTE When diagramming “what-if” scenarios, 
make a backup copy of your facilities plan and 
database first so that you can revert to them later 
if necessary. For detailed information about 
making backup copies of your drawing and data-
base, view Readme.wri located in the Visio folder 
on your Visio 2000 Technical Edition CD.

Try it: Add assets to your facilities plan and 

track data for each asset

1 From the Office Furniture stencil, drag a 
Corner 2, Chair, and File shape onto the 
Space shape for Office 101 in your facilities 
plan. Size them to fit your office. To rotate 
the chair, drag the control handle ( ) on 
the shape.

2 Double-click each furniture shape, and then 
specify properties.

Shapes such as desks, chairs, and filing cabinets 
belong to the Furniture category and have furniture 
properties, such as color and style. To find out 
which category a shape belongs to, double-click the 
shape to view the Properties dialog box.

3 Repeat steps 1 and 2 for Offices 102 and 103 
in your facilities plan.

4 Choose File > Save. Save your drawing fre-
quently so that your drawing and the facili-
ties database are synchronized.

For details, use these 
online Help keywords:

• Asset information in 
facilities plans
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Designating new tracking information

The facilities information that you decide to 
track is organized into categories—the groups 
to which shapes belong—and properties—the 
information you can track for a given category. 
Many shapes included with the Facilities Man-
agement solution are already assigned to a 
category. For example, furniture shapes belong 
to the Furniture category, and office equip-
ment shapes belong to the Equipment 
category. 

Every category has Name, Ref (user-defined reference 
word or number), and Notes properties and other 
properties specific to that category. For example, the 
default properties for the Furniture category are Name, 
Ref, Notes, Color, Style, and Warranty Expiration Date. 

You can customize the default categories to 
track information specific to your organization 
by adding your own properties to the default 
categories or by adding your own subcategories 
and properties. A subcategory is a category 
based on one of the default categories provided 
with the Facilities Management solution. 
When you add a subcategory, it inherits the 
properties of the category on which you base it. 
For example, you could add a new Printer sub-
category based on the Equipment category. 
The Printer subcategory inherits the Equip-
ment category’s properties, and you can add 
your own properties, such as Department, 
Printer Type, RAM, Duplex, and Color.

After you add a subcategory, you must assign it 
to the appropriate shapes. For example, you 
must assign your Printer subcategory to your 
printer shapes so that the shapes belong to the 
Printer subcategory and use its properties. For 
more information on assigning subcategories 
to shapes, see “Assigning a category to a shape” 
on page 77. 
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Try it: Add new categories and properties

1 Choose Facilities > Customize > Categories.

2 In the Categories dialog box, add the fol-
lowing subcategories and properties in this 
order: 

• Computer subcategory (base this subcat-
egory on the Equipment category) and 
these properties: Manufacturer, Part 
Number, Processor, RAM, and Hard 
Drive Size

• Cost Center Number property for the 
Person category

• Contractor and Employee subcategories 
(base these subcategories on the Person 
category)

Notice that for the Person category, you 
added the new property first, and then you 
added the new Contractor and Employee 
subcategories, which inherited the new 
property you added for the Person category. 

Assigning a category to a shape
The Facilities Management solution offers the 
flexibility to track any information you want 
for your facility. To track facilities information 
with a shape, you must assign the shape to a 
category that has properties for the informa-
tion you want to track. 

You can create your own shapes and assign a 
category to them as well as change or assign a 
category to any shape on a Visio stencil. You 
can assign a category to one or more shapes on 
the drawing page or stencil. If you change the 
category of a shape on the drawing page, only 
that particular shape will belong to the new 
category. If you change the category of a shape 
on a stencil, the shape will belong to the new 
category any time you drag it onto the drawing 
page.

In a previous procedure, you added the Com-
puter subcategory and properties for it. Now, 
you need to assign the Computer subcategory 
to the PC and Tower PC master shapes on the 
Office Equipment - Electronic stencil so that 
you can use these shapes to track computer 
information.

For details, use these 
online Help keywords:

• Categories in 
facilities plans
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Try it: Assign a category to shapes on a stencil

1 Make sure nothing is selected on the 
drawing page, and then choose Facilities > 
Convert Shapes. Click Next.

2 In the second screen of the wizard, choose 
the Office Equipment - Electronic stencil 
from the list, click Next, and then click Yes 
to open the original stencil.

3 In the next screen, uncheck Show Only 
Unassigned Shapes so that you can see all of 
the shapes.

4 From the Categories list, select Computers.

5 Under Shapes, select PC, and then 
Ctrl+click to select Tower PC. Click Add.

6 Click Finish to reassign the shapes. Click No 
to indicate that you are finished assigning 
categories.

7 From the Office Equipment - Electronic 
stencil, drag a PC shape onto the desk in 
Office 101 of your facilities plan.

8 Double-click the PC shape to enter infor-
mation for the Manufacturer, Part Number, 
Processor, RAM, and Hard Drive Size prop-
erties.

9 Repeat steps 7 and 8 to add PC shapes to the 
rest of the offices in your facilities plan.

10 For the purpose of this exercise, don’t save 
the changes you made to the stencil. How-
ever, if you were creating a real facilities 
plan, you would click the stencil title bar of 
the stencil you changed and then choose 
File > Save.

11 With the drawing window active, choose 
File > Save to save your facilities plan.
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Sample 

facilities plan

If you followed the procedures in this chapter, your facilities plan should look similar to this one. After you create a 
facilities plan, you can use it as a tool to list, locate, and print your facilities information.
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Using data from existing databases

Much of the information you would track in a 
facilities plan already exists in databases within 
your organization. For example, a Human 
Resources database might contain employee 
information such as a Social Security number 
or manager’s name. An Information Services 
database might contain equipment informa-
tion, such as the make and model of all the 
printers in your organization. 

You can link properties in your facilities plan 
to fields in existing databases so that you do 
not need to reenter the existing data into your 
facilities plan. Whenever the external database 
is updated, your facilities plan is also updated 
so that you always have the latest information.

You can link properties to fields in existing databases to 
reuse your organization’s data. 

To access an external database, you must know 
its data source name. If the database is pro-
tected, you also need a user name and 
password. Contact the database administrator 
for that information. 

To link your facilities properties to database 
fields, you need to know enough about the 
database tables to select the data you want.

To connect to an existing database and 

choose data

1 Choose Facilities > Customize > Get Exter-
nal Data. 

2 Click Create to create a new connection, or 
link, to the existing database.

3 Type a connection name for this connection 
to the database. 

You create a unique connection name for 
each Facilities Management category you 
link to a table or view in the external data-
base. For example, if you were accessing a 
Human Resources database, you could 
name the connection Employees.

4 Select the data source that points to the 
existing database, and then click Next.

5 Under Object Types, click the type of data-
base objects you want to view, and then 
under Database Objects, select the particu-
lar table or view you want. Click Next.

Use the preview of the selected object to 
verify that you have located the correct data.

Facilities
database

Corporate
database
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6 Choose one or more columns (database 
fields) to use as the primary key to identify 
each record in the table, and then click 
Next.

A primary key is one field or a set of fields 
that uniquely identify the records stored in 
a table. For example, in an employee table, 
an Employee ID field could be the primary 
key. You can use up to five columns as the 
primary key for a table.

7 Select the Facilities Management category 
that will use data from the existing database.

For example, if you were connecting to an 
existing Human Resources database, you 
would choose Person from the categories 
list.

8 Select a Facilities Management property and 
a database field to link together, and then 
click Add.

For example, you could link the Hire Date 
property with a Hire Date field from an 
employee table in a database.

9 When you have finished linking Facilities 
Management properties to database fields, 
click Finish.

To use linked data in your facilities plan

1 Double-click the asset or the Person shape 
in your facilities plan.

2 In the Properties dialog box, click Use Exist-
ing Item.

3 In the Search For box, type text to locate the 
correct record in the external database.

For example, to locate the record associated 
with an employee, type the person’s first 
name or last name. 

4 Select the record you want, and then click 
OK.

Any property that is linked to a database 
field is automatically filled in. Linked prop-
erties are unavailable for editing in the 
Properties dialog box.

5 Click OK to save your changes and close the 
Properties dialog box.

For details, use these 
online Help keywords:

• Databases 
(Facilities 
Management)

• Properties in 
facilities plans
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Working with your facilities plan and information

After you create your facilities plan and add 
information to it, you can easily maintain and 
revise it by dragging a shape to relocate an 
asset, or by double-clicking a shape to change 
facilities information. Your facilities plan 
becomes a useful tool for quickly listing and 
locating assets and sorting and printing facili-
ties information. 

You can

• Use Visio menu commands or Visio CAFM 
Explorer to list and locate people or assets.

• Use Visio CAFM Explorer to work with 
your facilities information within the struc-
ture of your company—organizationally 
rather than spatially. 

• Print or electronically distribute a copy of 
your facilities plan.

Listing and locating assets in 
your facilities plan
One of the most important uses of your facili-
ties plan is to list assets and track their location 
in your facilities plan. For example, you can 
locate a person in your facilities plan or list all 
of the copiers on a particular floor.

In this procedure, you will use Visio menu 
commands to list and locate all the chairs in 
your facilities plan.

NOTE To locate the assets for a space, you must 
place them on Space shapes in your facilities 
plan. Any asset on a drawing page that is not 
associated with a Space shape is associated with 
the floor, or page.

Try it: List and locate the chairs in your 

facilities plan

1 Choose Facilities > Find.

To find Steelcase furniture that has particu-
lar specifications, choose Facilities > 
Furniture > Find.

2 In the Find Facilities Data dialog box, on 
the Name & Location tab, type chair in the 
Search For box and select the Furniture 
category.
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3 Click Find Now.

All shapes that match the criteria appear in 
the list at the bottom of the dialog box. To 
sort and print your list, select all the items 
you want to print, right-click any item, and 
then choose Properties. In the Properties 
dialog box, click the Sort By tab, click the 
property by which you want to sort the list, 
click the As Web Page tab, and then click 
Print.

4 From the list of shapes, select the chairs you 
want to locate in your facilities plan, right-
click any one of the selected chairs, and then 
choose Add-Ons > Locate.

Visio 2000 selects the chair in your 
facilities plan.

5 Click Close.

You can also use Visio CAFM Explorer to list 
assets and locate them in your facilities plan. 
Choose Facilities > Explorer > View to start 
Visio CAFM Explorer, and then click View Full 
Screen on the Facilities Explorer toolbar. 
Choose Edit > Find. From this point, follow 
steps 1–5 of the previous procedure, “List and 
locate the chairs in your facilities plan.” 

TIP When you use Visio CAFM Explorer to list 
assets that have a price property, the total cost is 
displayed on the status bar.

Tracking organizational data by 
using Visio CAFM Explorer
Visio CAFM Explorer offers a hierarchical 
(organizational) view of your facilities data. 
You can set up departments and organize peo-
ple within departments so that you can quickly 
view the structure of your company. Or, you 
can enter information for a department that 
you wouldn’t track in your facilities plan, such 
as the total budget for a department.

Visio CAFM Explorer complements your facilities plan by 
offering a hierarchical view of your organization and 
facilities information, rather than a spatial view of your 
facility.
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You can also use Visio CAFM Explorer as a 
holding place for information about resources 
or assets that you haven’t placed in your facili-
ties plan yet. For example, suppose the Human 
Resources department just hired an employee, 
but the manager doesn’t know where the 
employee will sit yet. Or, suppose an Account-
ing manager just bought a new printer, but she 
doesn’t know where she’s going to put it yet. 
Visio CAFM Explorer is the ideal place to store 
this information until you determine location 
information and can add the resource or asset 
to the facilities plan.

In this procedure, you will relate Eileen Adams, 
one of the people in your facilities plan, to the 
Finance department.

Try it: Relate a person to a department in 

your organization

1 Choose Facilities > Explorer > View to start 
Visio CAFM Explorer.

2 Navigate to the Companies folder and then 
to the Departments folder.

3 Right-click the Departments folder, choose 
New > Department, type Finance, and then 
press Enter.

4 Click the Finance item to view the People 
folder.

5 Navigate to Eileen Adams, the employee 
you want to associate with the department.

6 Right-click Eileen Adams, choose Relate To, 
and then click the People folder under the 
Finance item.

When you choose Relate To, your pointer 
changes to an icon appropriate for the item. 

To set up a relationship, just drag an item onto a folder 
within the boundaries of the hierarchy. For example, you 
can drag a person onto the People folder in a 
department to relate the person to the department. 
However, you can’t drag a department onto a person.

In this procedure, you will add a new 
employee, who is not yet represented in your 
facilities plan, to a department.

Try it: Add new employee information to 

Visio CAFM Explorer

1 In Visio CAFM Explorer, navigate to the 
department to which the new employee 
belongs.

2 Right-click the People folder, choose 
New > Person, type the new employee’s 
name, and then press Enter.

3 Right-click the new employee name, and 
then choose Properties to enter information 
you know about the new employee.

For details, use these 
online Help keywords:

• Searching for 
facilities plans 
shapes

• CAFM Explorer
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When you determine where the new employee 
sits, you can add a Person shape to your facili-
ties plan. You can find the new employee’s 
name and any other information you added 
using Visio CAFM Explorer by double-clicking 
the Person shape. This opens the Properties 
dialog box. On the Item tab, click Use Existing 
Item, and then type the employee’s name. 
Click Find Now and select the correct 
employee from the list. Click OK to update the 
Person shape.

Distributing your facilities plan
You can print or electronically distribute your 
facilities plan to space planners, electricians, 
telecommunications specialists, and contrac-
tors—anyone who needs your plan. 

For more information on distributing your 
facilities plan, see Chapter 8, “Sharing your 
drawings with others.” 





Topics in this chapter

6
Building Architecture: 
Drawing floor plans and site plans

Whether you are an architect designing a 
commercial building or a facilities manager 
planning interior spaces, Visio® 2000 
Technical Edition provides the drawing tools 
you need to quickly and easily draw floor plans 
and site plans.

With Visio 2000, you can

• Draw space plans that show the approxi-
mate size and location of rooms and areas. 
You can then transform space plans into 
floor plans.

• Draw floor plans that show the location 
of walls, doors, and windows, as well as 
building core features (such as stairways 
and elevators) and electrical and telecom-
munications systems (such as lights, 
outlets, and switches).

• Draw architectural or landscape site plans 
complete with roads, parking lots, and 
plants.

• Lay out a manufacturing plant with shapes 
for shop floor equipment.

• Draw a home plan for your own remodel-
ing, interior design, or landscaping 
projects.

Drawing a space plan ..................................... 88

Drawing a floor plan ....................................... 90

Drawing a home plan ..................................... 94

Drawing a site plan ......................................... 96

Drawing a manufacturing plant layout ......... 99
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Drawing a space plan

Architects sometimes start a floor plan from a 
bubble diagram. Bubble diagrams are concep-
tual design sketches that show the required 
spaces in a building and the relationships 
between spaces. As the architect refines the 
placement and size of the spaces, the sketches 
begin to accurately reflect the size and location 
of the final rooms, corridors, and common 
areas. 

Bubble diagrams show the relationships between 
spaces and help you plan the layout of rooms and 
common areas.

In Visio 2000, you can create a space plan that, 
like a bubble diagram, shows the rough loca-
tion of spaces in your building. When you have 
finalized the layout of your building, you can 
convert the spaces into rooms outlined by fully 
dimensioned wall shapes. You can then con-
tinue to create a full floor plan with as much 
detail as necessary.

Visio 2000 provides shapes and tools you can 
use to create a space plan in two ways:

• By dragging space shapes onto your drawing 
page and then converting them into wall shapes

• By drawing lines or rectangles to represent 
rooms or to trace the outline of your floor plan, 
and then converting the lines or rectangles to 
wall shapes

To start your space plan

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Building Architecture.

3 In the Drawing Type box, double-click 
Floor Plans.

4 To change the page size or drawing scale, 
choose File > Page Setup.

5 Click the Page Size tab and choose a page 
size, and then click the Drawing Scale tab to 
choose a drawing scale. 

6 Click OK to accept the new settings and 
begin working on your space plan.

To create rooms by using space shapes

1 From the Walls, Shell And Structure stencil, 
drag a space shape onto the drawing page.

2 To resize the space shape, drag any corner 
of the shape. 

The shape is updated to show its new area.
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3 To create a room that is not rectangular, 
position several space shapes to represent 
the room. Select all of the shapes, right-click 
them, and then choose Union, Subtract, or 
Intersection to combine them.

4 Position shapes to represent all of the rooms 
and common areas in your space plan.

5 To convert a space shape into a room, right-
click the shape and choose Convert To Walls.

6 In the Convert To Walls dialog box, check 
Add Dimensions and Add Guides so that 
you can reposition the walls easily after they 
are created.

7 Under Original Geometry, click Retain to 
keep the original space shape. 

TIP Keep the space shape if your floor plan 
will be used with the Facilities Management 
solution. For details, see Chapter 5, “Facilities 
Management: Drawing facilities plans and 
tracking assets.” 

8 Click OK to create the room. 

To create rooms by drawing lines

1 Use the line tool ( ) or the rectangle tool 
( ) from the Standard toolbar to draw an 
outline of a room.

2 Draw the outlines of all of the rooms and 
common areas in your space plan.

3 To convert lines into walls, select the lines 
that represent the rooms, and then choose 
Architecture > Convert To Walls.

4 In the Convert To Walls dialog box, check 
Add Dimensions and Add Guides so that 
you can easily reposition the walls after they 
are created.

5 Under Original Geometry, click Convert To 
Space Shape to delete the original lines and 
insert a space shape into the converted 
room.

6 Click OK to create the room.

To resize rooms

1 To change the size of a room, drag the 
guides to which the walls are attached.

2 If the room contains a space shape, update 
the space shape by right-clicking it and 
choosing Auto Size.

Join two space shapes 
together by right-clicking 
the shapes and choosing 
Union.

Choose Architecture > 
Convert To Walls to 
convert the space shape 
into wall shapes.

For details, use these 
online Help keywords:

• Building 
Architecture 
solution

• Creating shapes
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Drawing a floor plan

Floor plans are the core drawings in a set of 
construction documents and are frequently 
used as background images in a wide range of 
drawings, from office furniture layouts to elec-
trical wiring diagrams.

Visio 2000 gives you the shapes you need to 
draw walls quickly and easily, add doors and 
windows, and dimension your floor plan. 

Floor plan

The Architecture solution simplifies the complex task of drawing scaled floor plans.
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Starting a floor plan
You can use wall shapes from the Floor Plans 
stencils to draw a detailed floor plan. You can 
also create a floor plan by creating a space plan 
and then converting the spaces into walls. For 
details about creating a space plan, see “Draw-
ing a space plan” on page 88. 

If you are constructing a simple office layout 
for only a few rooms, you can also use the 
Office Layout template. 

To start a floor plan

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Building Architecture.

3 In the Drawing Type box, double-click 
Floor Plans.

4 To change the page size or drawing scale, 
choose File > Page Setup.

5 Click the Page Size tab and choose a page 
size, and then click the Drawing Scale tab to 
choose a drawing scale. For details, see 
“Setting the drawing scale” on page 26. 

6 Click OK to accept the new settings and 
begin working on your floor plan.

Drawing the building shell
The building shell includes exterior and inte-
rior walls and columns, and major structural 
features, such as stairways and elevators. 
Visio 2000 provides wall shapes that you can 
glue together to form exterior or interior walls. 
When wall shapes that form a T-joint or corner 
joint are glued together, the joint is automati-
cally redrawn so that it is displayed correctly. 

Wall joints are displayed correctly when you glue the 
endpoints of walls together.

For details, use these 
online Help keywords:

• Office layout 
drawings

• Floor plans
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To draw the building shell

1 Drag guides from the horizontal and vertical 
rulers and position the guides on the page 
so that they indicate the perimeter of the 
building.

2 For each exterior wall, drag a wall shape onto 
the page. Drag the endpoints of the wall shape 
to the intersections of the horizontal and ver-
tical guides to glue them to the guides.

3 To reposition exterior walls, drag the guides 
to which they are attached.

4 Add columns or other structural shapes 
from the Walls, Shell And Structure stencil 
or the Building Core stencil.

5 Position interior and cubicle walls by drag-
ging the wall shapes onto the page. Drag the 
endpoint of one wall to another wall to join 
them.

6 Add guides to interior walls by right-click-
ing a wall and choosing Add A Guide.

7 To reposition interior walls, drag the guides 
to which they are glued. 

8 To change wall properties, such as thick-
ness, right-click a wall and choose Set Wall 
Properties.

Adding doors, windows, and 
openings
It’s easy to add the shapes for doors, windows, 
and other openings to your floor plan. When 
you drag a door or window shape onto a wall, 
the door or window automatically rotates to 
align with the wall and glues itself to the wall. 
Door and window shapes also acquire the 
wall’s thickness.

To add doors, windows, and openings to walls

1 Drag a door, window, or opening shape 
from the Walls, Shell And Structure stencil 
onto a wall. 

2 To reposition a door or window, drag it 
along the wall.

3 To change door or window properties, such 
as width or offset within a wall, right-click a 
door or window and choose Set Door Prop-
erties or Set Window Properties. 

For details, use these 
online Help keywords:

• Doors

• Walls

• Windows in 
space plans
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Changing the appearance of 
walls, doors, and windows
For detailed construction drawings, you can 
change how walls, doors, and windows are dis-
played. For example, you can hide door header 
or frame components or display walls as single 
lines instead of double lines.

You can set the default appearance for all walls, 
doors, and windows on a drawing page. You 
can always override the settings for any indi-
vidual wall, door, or window.

You can quickly change walls from double-line to 
single-line walls.

To change the appearance of walls, doors, and 

windows

1 To change the appearance of all walls, 
doors, or windows on a page, right-click the 
page and choose Set Architecture Page 
Properties.

2 Click the Doors, Walls, or Windows tab and 
choose the settings you want. For more 
information about the settings on a tab, 
click the Help button ( ).

3 To override the default appearance of a 
wall, door, or window, right-click the shape 
and choose Set Wall Properties, Set Door 
Properties, or Set Window Properties.

4 Click the Overrides tab and change the 
settings for the individual wall, door, or 
window.

Measuring and dimensioning
In Visio 2000, you can add dimension lines to 
walls at any time. As you refine your plan, the 
dimensions are automatically updated. You 
can also find out the area and perimeter of 
rooms in your floor plan.

To add dimension lines to a wall

1 Select the walls to which you want to add 
dimensions.

2 Right-click the walls, and then choose Add 
A Dimension.

To measure the area and perimeter of rooms

1 Select the shapes.

2 Choose Tools > Macros > Visio Extras > 
Shape Area And Perimeter.
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Drawing a home plan

Visio 2000 provides the shapes and tools you 
need to draw home plans. Home plans are easy 
to draw—you do not need to be an architect to 
create your own initial drafts of remodeling 
plans, experiment with new kitchen or furni-
ture arrangements, or draw up plans to add a 
new room to your home. For building projects, 
you can then give your plans to your architect 
to create construction plans.

Home plan shapes are complete enough for the 
professional architect. You draw a home plan 
using the same wall, door, and window shapes 
you would use to create a commercial building, 
and you can use architectural dimensioning 
and annotation shapes to create a complete 
construction document.

Home plan

Use home plans for remodeling your house or for a complete residential floor plan.
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Creating your home plan
Before you begin drawing a home plan for a 
remodeling project, measure the existing 
rooms and note the size and location of win-
dows and doors. Measure the length and width 
of existing appliances, cabinets, or furniture 
that you want to use in your home plan. 

To start a home plan

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Building Architecture.

3 In the Drawing Type box, double-click 
Home Plans.

4 To change the page size or drawing scale, 
choose File > Page Setup.

5 Click the Page Size tab and choose a page 
size, and then click the Drawing Scale tab to 
choose a drawing scale. For details, see 
“Setting the drawing scale” on page 26. 

6 Click OK to accept the new settings and 
begin working on your home plan.

To complete your home plan

1 Use the shapes on the Walls, Shell And 
Structure stencil to draw the exterior and 
interior walls. For details, see “Drawing the 
building shell” on page 91. 

2 Alternatively, you can draw a floor plan by 
starting with a space plan and converting 
spaces into rooms. For details, see “Drawing 
a space plan” on page 88. 

3 After you have assembled the walls, drag 
door, window, or opening shapes from the 
Walls, Shell And Structure stencil onto 
walls.

4 Add shapes for electrical symbols, fixtures, 
and appliances.

5 Add furniture shapes. 

6 For landscaping projects, add shapes from 
the Garden Accessories stencil.

For details, use these 
online Help keywords:

• Building 
Architecture 
solution

• Page setup
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Drawing a site plan

Visio 2000 provides the shapes and tools 
you need to draw landscape or architectural 
site plans. 

Starting your site plan
Before you begin your site plan, measure the 
perimeter of the property and the size and 
placement of existing buildings, or obtain a 
legal description of the property. For landscape 
plans, measure the size and placement of exist-
ing plants or garden structures that you want 
to keep in your new plan. 

Site plan

Use site plans to show how a building is situated on a piece of property or to show how a site will be landscaped.
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To start your site plan

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Building Architecture.

3 In the Drawing Type box, double-click Site 
Plans.

4 To change the page size or drawing scale, 
choose File > Page Setup.

5 Click the Page Size tab and choose a page 
size, and then click the Drawing Scale tab to 
choose a drawing scale. For details, see 
“Setting the drawing scale” on page 26. 

6 Click OK to accept the new settings and 
begin working on your site plan.

Incorporating buildings into your 
site plan
To incorporate buildings and other structures 
into your site plan, you can

• Draw a building outline by using the line 
tool ( ) on the Standard toolbar.

• Use wall shapes from the Walls, Shell And 
Structure stencil to draw the structures. To 
open the stencil, choose File > Stencils > 
Building Architecture > Floor Plans > 
Walls, Shell And Structure.

• Insert a floor plan created in a CAD 
(computer-aided design) drawing program, 
such as Autodesk AutoCAD or Bentley 
MicroStation. 

• Open an existing floor plan you created in 
any Visio product and create the site plan in 
that drawing.

For details, use these 
online Help keywords:

• CAD files

• Property Line tool

• Building 
Architecture 
solution
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Adding roads, parking lots, and 
pathways
Visio 2000 provides shapes for architectural 
site plans, which show the location of roads, 
driveways, parking lots, and walkways at the 
site. Site plans might also show the location of 
utility lines, lighting, and other architectural 
features. 

To lay out roads, parking lots, and pathways

1 Drag guides from the horizontal and verti-
cal rulers and position the guides on the 
page to mark the locations of the site perim-
eter, stalls, and roads in the drawing. 

2 Drag curbs and driveways from the Parking 
And Roads stencil into position. Use lines to 
connect curbs and driveways.

3 Drag parking strips, stalls, and parking 
islands into position.

4 Drag pathways from the Garden Accessories 
stencil into position.

5 Position vehicles, parking accessories (such 
as lights), and plant shapes around the 
parking strips.

Adding plants and landscape 
features
Visio 2000 provides shapes for landscape site 
plans, which show the location of plants, irri-
gation equipment, fences and walkways, and 
recreational equipment, such as pools and 
swing sets.

To add plants and landscape features

1 Add shapes for fences and paths from the 
Garden Accessories stencil.

2 Add recreational equipment from the Sport 
Fields And Recreation stencil.

3 Add plants from the Planting stencil and 
irrigation systems from the Irrigation sten-
cil.

4 Use the Plant Callout shape from the Plant-
ing stencil to label plants. 

For details, use these 
online Help keywords:

• Dimensions of 
shapes

• Guides and 
guide points
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Drawing a manufacturing plant layout

You can use Visio 2000 to design shop floors 
for manufacturing plants. Plant layouts show 
the building, machinery, storage facilities, and 
shipping and receiving facilities of a manufac-
turing plant. 

Plant layout

Use plant layouts for manufacturing plant designs that show equipment, storage and distribution, and shipping and 
receiving areas.

Manufacturing Plant Layout - West Campus
SCALE:  1/8"=1'-0"
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Creating your plant layout
If you are modifying an existing plant, deter-
mine the dimensions of the warehouse or 
factory structure and of the external loading 
area. Determine the size of the loading bays 
and doors, and note the directions for door 
swings. Obtain the dimensions of existing or 
proposed equipment, such as machines, 
cranes, racks, and shelving. 

To start a plant layout

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Building Architecture.

3 In the Drawing Type box, double-click 
Plant Layout.

4 To change the page size or drawing scale, 
choose File > Page Setup.

5 Click the Page Size tab and choose a page 
size, and then click the Drawing Scale tab to 
choose a drawing scale. For details, see 
“Setting the drawing scale” on page 26. 

6 Click OK to accept the new settings and 
begin working on your plant layout.

To complete the plant layout

1 Use the shapes on the Walls, Shell And 
Structure stencil to draw the building shell 
of the plant. For details, see “Drawing the 
building shell” on page 91. 

2 Add shapes for shop floor machines and 
equipment.

3 Add shapes for transferring materials and 
for loading and unloading equipment from 
the Shop Floor - Storage And Distribution 
stencil.

4 Add shapes for shipping and receiving.

5 Add shapes for transporting materials and 
manufactured goods from the Vehicles 
stencil.

For details, use these 
online Help keywords:

• Building 
Architecture 
solution
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Additional industry drawings

Using Visio® 2000 Technical Edition, you can 
create industry-specific drawings such as

• Building services diagrams of HVAC con-
trol systems, basic duct layouts, fire and 
security plans, and lighting and electrical 
designs.

• Electrical and electronic schematic dia-
grams for control systems; general electrical 
diagrams, such as wiring diagrams; printed 
circuit board diagrams; and circuit and 
logic diagrams. 

• Part and assembly drawings for the 
mechanical engineering design of manufac-
tured products.

• Hydraulic and pneumatic circuit diagrams 
for fluid power systems.

Building Services: HVAC, electrical, and 
plumbing diagrams ................................. 102

Electrical Engineering: electrical and 
electronic diagrams ................................. 108

Mechanical Engineering: part and 
assembly drawings....................................110

Fluid power diagrams....................................112
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Building Services: HVAC, electrical, and plumbing diagrams

Visio 2000 provides shapes that let you create 
building services diagrams of HVAC control 
systems, basic duct layouts, fire and security 
plans, and lighting and electrical designs. 

Creating an HVAC control logic 
diagram
Visio 2000 provides shapes for creating HVAC 
control logic diagrams that show a schematic 
view of the equipment, wiring, and sensors 
used to control an HVAC system.

HVAC plan

Using the Building Services solution, you can draw HVAC plans to show ductwork for heating, ventilation, and air 
conditioning systems.
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To create an HVAC control logic diagram

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Cancel to start with no open drawing.

3 Determine where you want to create your 
HVAC control logic plan. You can lay out 
your plan on a blank drawing page or on 
top of an existing floor plan:

• To draw your plan on a blank page, 
choose File > New > Building Services > 
HVAC Control Logic Diagram.

• To draw your plan on a floor plan drawn 
in a CAD (computer-aided design) 
program, choose File > New > Building 
Services > HVAC Control Logic 
Diagram, and then insert the floor plan. 
For details, see “Using an existing floor 
plan” on page 107. 

• To draw your plan on a floor plan created 
in a Visio product, open the floor plan, 
and then open the stencils you need. For 
details, see “Using an existing floor plan” 
on page 107. 

4 Drag HVAC shapes onto the drawing page. 

You can configure many shapes by right-
clicking them and choosing Set Properties 
from the shortcut menu. For example, you 
can change ducts from double line to single 
line.

5 To label a shape, select it and type the label 
text. You can reposition a label by dragging 
the label’s control handle ( ).

6 Save your drawing.

Creating an HVAC plan
Visio 2000 provides ductwork, pipe, and valve 
shapes for creating single-line and double-line 
HVAC plans that show the location and con-
figuration of ductwork and piping. 

To create an HVAC plan

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Cancel to start with no open drawing.

3 Determine where you want to create your 
HVAC plan. You can lay out your plan on a 
blank drawing page or on top of an existing 
floor plan:

• To draw your plan on a blank page, 
choose File > New > Building Services > 
HVAC Plans.

• To draw your plan on a floor plan drawn 
in a CAD program, choose File > New > 
Building Services > HVAC Plans, and 
then insert the floor plan. For details, see 
“Using an existing floor plan” on 
page 107. 

• To draw your plan on a floor plan created 
in a Visio product, open the floor plan, 
and then open the stencils you need. For 
details, see “Using an existing floor plan” 
on page 107. 

For details, use these 
online Help keywords:

• Building Services 
solution
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4 Drag ductwork shapes onto the drawing 
page. Ductwork shapes rotate into position 
and glue to other ductwork shapes.

You can configure many shapes by right-
clicking them and choosing the appropriate 
command from the shortcut menu. For 
example, you can change the angle and 
radius of a Variable Bend shape.

5 To label a shape, select it and type the label 
text. You can reposition a label by dragging 
the label’s control handle ( ).

6 Save your drawing.

Creating plumbing drawings
Visio 2000 provides shapes to create plumbing 
and piping drawings that show the layout of 
pipes, valves, and fittings in a building.

To create a plumbing drawing

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Cancel to start with no open drawing.

3 Determine where you want to create your 
plumbing and piping plan. You can lay out 
your plan on a blank drawing page or on 
top of an existing floor plan:

• To draw your plan on a blank page, 
choose File > New > Building Services > 
Plumbing And Piping Plans.

• To draw your plan on a floor plan drawn 
in a CAD program, choose File > New > 
Building Services > Plumbing And 
Piping Plans, and then insert the floor 
plan. For details, see “Using an existing 
floor plan” on page 107. 

• To draw your plan on a floor plan created 
in a Visio product, open the floor plan, 
and then open the stencils you need. For 
details, see “Using an existing floor plan” 
on page 107. 

4 Drag plumbing fixtures, pipes, and valves 
from the stencils onto the drawing page to 
lay out your plumbing components. 

You can configure many shapes by right-
clicking them and choosing the appropriate 
command from the shortcut menu.

5 To connect shapes, drag pipes onto the 
drawing page. Glue each end of the pipe 
shapes to connection points on the other 
shapes. To resize a pipe, drag an endpoint 
(  or ).

6 To label a shape, select it and type the label 
text. You can reposition a label by dragging 
the label’s control handle ( ).

7 Save your drawing.



A D D I T I O N A L  I N D U S T R Y  D R A W I N G S 105
Creating fire and security 
system plans
Visio 2000 provides shapes you can use to cre-
ate fire and security system plans.

To create a fire or security system plan

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Cancel to start with no open drawing.

3 Determine where you want to create your 
fire and security plan. You can lay out your 
plan on a blank drawing page or on top of 
an existing floor plan:

• To draw your plan on a blank page, 
choose File > New > Building Services > 
Fire And Security Systems.

• To draw your plan on a floor plan drawn 
in a CAD program, choose File > New > 
Building Services > Fire And Security 
Systems, and then insert the floor plan. 
For details, see “Using an existing floor 
plan” on page 107. 

• To draw your plan on a floor plan created 
in a Visio product, open the floor plan, 
and then open the stencils you need. For 
details, see “Using an existing floor plan” 
on page 107. 

4 Drag security shapes for alarm access and 
control, initiation and annunciation, and 
video surveillance onto the drawing page. If 
you are prompted for information about a 
shape, fill in the appropriate data and click 
OK. 

You can change custom properties data for 
a shape at any time by right-clicking the 
shape, choosing Properties from the short-
cut menu, and selecting a new property 
from the list. For example, the Card Access 
shape has a Mount Type property that indi-
cates where the reader is mounted. 

5 Save your drawing.

Creating electric and 
telecom plans
Visio 2000 provides shapes that you can use to 
create electric and telecom plans that show the 
location of lighting, electrical wiring and ser-
vice panels, and telecommunications outlets. 

To create an electrical and telecom plan

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Cancel to start with no open drawing.

3 Determine where you want to create your 
electrical and telecom plan. You can lay out 
your plan on a blank drawing page or on 
top of an existing floor plan:

• To draw your plan on a blank page, 
choose File > New > Building Services > 
Electric And Telecom Plans.

• To draw your plan on a floor plan drawn 
in a CAD program, choose File > New > 
Building Services > Electric And Telecom 
Plans, and then insert the floor plan. For 
details, see “Using an existing floor plan” 
on page 107. 

For details, use these 
online Help keywords:

• Connecting shapes

• Building Services 
solution
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• To draw your plan on a floor plan created 
in a Visio product, open the floor plan, 
and then open the stencils you need. For 
details, see “Using an existing floor plan” 
on page 107. 

4 Drag shapes for lighting, outlets, and 
switches onto the drawing page. 

5 To label a shape, select it and type the label 
text. You can reposition a label by dragging 
the label’s control handle ( ).

6 Save your drawing. 

Fire and security 

system plans

You can create fire and security system plans by using Visio 2000.
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Using an existing floor plan
Many HVAC, electrical, and plumbing draw-
ings are created on a floor plan or building 
shell to show the location of the components in 
the building. You can insert an existing floor 
plan in DWG, DXF, or DGN format, or you 
can insert a floor plan drawn in Visio 2000.

To use a floor plan saved in a CAD file format

1 Create a blank Building Services drawing, 
and then choose Insert > CAD Drawing.

2 In the Insert CAD Drawing dialog box, nav-
igate to the folder that contains your CAD 
drawing, select the file you want to import, 
and then click Open.

3 In the CAD Drawing Properties dialog box, 
click the General tab and select the page and 
scale settings you want. Click OK.

4 Choose View > Layer Properties. Select the 
CAD Drawing layer and check Lock. 

TIP Lock the layers of a floor plan to make it 
easier to select the shapes you drag onto the 
floor plan instead of accidentally selecting the 
floor plan itself.

5 Click OK to begin working on your draw-
ing. For details, see Chapter 3, “Working 
with CAD drawings.” 

To use a floor plan saved in a Visio product 

format

1 Choose File > Open. In the Open dialog 
box, navigate to the folder that contains 
your Visio drawing, select the Visio drawing 
file you want to use, and then click Open.

2 Choose View > Layer Properties. Select each 
floor plan layer and check Lock.

3 Choose File > Stencils > Open Stencil. In 
the Open Stencil dialog box, navigate to the 
folder that contains the stencils you want. 
Ctrl+click each stencil you want to use, and 
then click Open.

For example, to open the stencil for electri-
cal and telecom plans, navigate to 
Visio\Solutions\Building Services and open 
the file Electrical And Telecom.vss.

4 Begin working with your drawing.

For details, use these 
online Help keywords:

• CAD files

• Layering shapes
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Electrical Engineering: electrical and electronic diagrams

Using Visio 2000, you can create electrical and 
electronic schematic diagrams and wiring dia-
grams. You can also generate a netlist from 

your diagram that you can use to input infor-
mation into a circuit analysis program. 

Electrical and 

electronic 

schematic 

diagrams

Using the Electrical Engineering solution, you can draw electrical and electronic schematic diagrams for control systems; general electrical 
diagrams, such as wiring diagrams; printed circuit board diagrams; and circuit and logic diagrams.
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To draw an electrical or electronic diagram

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Electrical Engineering, and then dou-
ble-click the type of electrical or electronic 
drawing you want to create:

• To create schematics for integrated 
circuits and logic circuits, select 
EE - Circuits And Logic.

• To create general electrical diagrams, 
such as schematic, one-line, and wiring 
diagrams, select EE - General.

• To create schematics for control systems, 
select EE - Industrial Control Systems.

• To create schematics for printed circuit 
boards, select EE - Systems.

3 Add electrical component shapes. For 
example, to draw a simple lamp circuit, add 
a battery, resistor, switch, and lamp. 

You can configure many shapes by right-
clicking them and choosing the appropriate 
command from the shortcut menu. For 
example, you can change a resistor from 
variable to fixed.

4 Click the connector tool ( ) on the Stan-
dard toolbar, and drag from a connection 
point ( ) on one component shape to a 
connection point on another to connect 
them.

5 To label a shape, select it and type the label 
text. You can reposition a label by dragging 
the label’s control handle ( ).

6 Save your drawing. 

Generating a netlist
You can generate a netlist file from your elec-
trical or electronic diagram to use as an input 
file for a circuit analysis program, such as 
SPICE. 

To generate an accurate netlist, you must draw 
your diagram in a certain way:

• Use the connector tool ( ), rather than 
the line tool, to connect components on the 
diagram.

• Label components sequentially with a name 
that begins with a component designator 
(such as R for resistor or C for capacitor) 
and ends with the component’s value. For 
example, you might label a resistor R6 10k.

• Use 2-D (two-dimensional) component 
shapes. The Visio electrical and electronic 
shapes are all 2-D; if you create your own 
shapes or use other Visio shapes, be sure 
they are 2-D.

To generate a netlist

1 In your drawing, select the components that 
make up the circuit you want to analyze.

2 Choose Tools > Macros > Electrical 
Engineering > Netlist Generator.

3 In the Netlist Generator dialog box, specify 
a prefix for unnamed nodes and a location 
for the netlist file.

4 Click OK to generate the netlist.

For details, use these 
online Help keywords:

• Electrical 
Engineering solution

• Netlist Generator
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Mechanical Engineering: part and assembly drawings

Visio 2000 supplies shapes that let you create 
part drawings and assembly drawings that pro-
vide information for manufacturing a product. 
Part drawings (or detail drawings) show each 
part contained in a product. Assembly draw-
ings show how all the parts fit together. 

To create part and assembly drawings

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Mechanical Engineering.

3 In the Drawing Type box, double-click Part 
And Assembly Drawing.

4 To create a title block, drag shapes from the 
Title Blocks stencil. 

TIP If you are creating a drawing that has 
more than one page, create a background page 
and add your title block to the background 
page so that you don’t need to repeat it on 
every page of the drawing. 

5 To draw outlines of objects, drag shapes 
from the Drawing Tool Shapes stencil onto 
the drawing page. You can configure many 
shapes by right-clicking them and choosing 
the appropriate command from the short-
cut menu.

6 Drag shapes from the Fasteners 1, Fasteners 
2, and Springs And Bearings stencils onto 
the drawing page. If you are prompted for 
information about a shape, fill in the appro-
priate data and click OK. 

You can change custom properties data for 
a shape at any time by right-clicking the 
shape and choosing the appropriate com-
mand from the shortcut menu. For exam-
ple, bolts have thread diameter, shaft length, 
and thread length properties.

7 Add dimensions to your drawing.

8 Add datum feature symbols and feature 
control frames by dragging shapes from the 
Geometric Dimensioning And Tolerancing 
stencil onto the drawing page.

9 Add welding symbols by dragging shapes 
from the Welding Symbols stencil onto the 
drawing page.

10 Add callouts and other reference notes by 
dragging shapes from the Annotations sten-
cil onto the drawing page.  

For details, use these 
online Help keywords:

• Mechanical 
Engineering solution

• Pages

• Dimensions of 
shapes
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Part and assembly 

drawing

Using the Mechanical Engineering solution, you can draw part drawings and assembly drawings for manufactured products.

Working drawing and detail assembly
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Fluid power diagrams

Visio 2000 provides shapes and tools for creat-
ing schematic diagrams of pneumatic or 
hydraulic circuits. You can use the valve shapes 
provided with Visio 2000, or you can create 
your own valve shapes by using the Valve 
Builder.

Creating fluid power diagrams
You can create fluid power diagrams to docu-
ment hydraulic or pneumatic circuits, such as 
those used in factory automation systems, 
heavy machinery, or automobile suspension 
systems.

Fluid power 

diagram

You can use the fluid power shapes and tools to create fluid power control system drawings and circuit schematics.
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To create a fluid power diagram

1 Start Visio 2000. In the Welcome To 
Visio 2000 dialog box, click OK.

2 In the Choose Drawing Type dialog box, 
click Fluid Power.

3 In the Drawing Type box, double-click 
Fluid Power.

4 Drag valve and equipment shapes onto the 
drawing page. 

You can configure many fluid power shapes 
by right-clicking them and choosing the 
appropriate command from the shortcut 
menu. For example, you can quickly change 
the Pump/Motor (Simple) shape from 
hydraulic to pneumatic.

5 Use the connector tool ( ) to connect 
components. 

You can also choose File > Stencils > Anno-
tation > General - Connectors to open a 
stencil with connector shapes. Drag connec-
tor shapes onto the page and glue their end-
points ( ) to connection points ( ) on the 
equipment or valve shapes.

6 To label a shape, select it and type the label 
text. You can reposition a label by dragging 
the label’s control handle ( ).

7 Add text, labels, callouts, and other refer-
ence notes by dragging shapes from the 
Annotations stencil onto the drawing page.

8 Save the drawing.

Creating your own valves
Visio 2000 provides shapes for commonly used 
valves, such as a two-way, two-position direc-
tional control valve (a 2/2 valve). You can use 
the Valve Builder to efficiently create a wide 
range of additional valve shapes. 

To create your own valve

1 Drag the Valve Builder shape from the Fluid 
Power - Valves stencil onto the drawing 
page. Position it where you want the new 
valve to appear.

2 In the Valve Builder dialog box, specify the 
number of positions and ports you want the 
valve to have.

3 From the list under Positions and Ports, 
select a flow path.

4 Under Arrowheads, specify the number and 
direction of arrowheads for the valve.

5 Under Fluid Type, select Hydraulic or 
Pneumatic.

6 Under Control Location, specify the loca-
tion for the control. 

7 Under Control Type, select the type of con-
trol you want from the list.

8 Click Build to create the valve.

Visio 2000 places the valve on the page. 

For details, use these 
online Help keywords:

• Fluid Power solution

• Valve Builder
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Sharing your drawings 
with others

After you create a drawing, you can print it for 
coworkers or business clients, or publish it to a 
company’s intranet or Web site.  

You can also

• Automatically update your drawings with 
any new information by adding hyperlinks 
to shapes.

• Route your drawings to other departments 
for comments and evaluation.  

Printing your drawings ..................................116

Publishing drawings to the Web...................119

Routing your drawings for comments ........122
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Printing your drawings

Most Visio® 2000 Technical Edition drawing 
types are set up so that the drawing page and 
printed page sizes are the same, so you don’t 
have to change page settings to get the printed 
drawing you expect.  You can view your draw-
ings or diagrams before you print them to 
make sure they print the way you want.

If you want to change the size, orientation, or 
scale of the drawing page as you create your 
drawing, keep the following terms in mind as 
your set up your drawing for printing:

• The drawing page is the white page you see 
on the screen.

• The printer page is the paper in the printer 
on which you print your Visio diagram.

• The printed drawing is your end result: the 
image on your drawing page printed onto 
one or more printer pages.

Using print preview to view 
your drawing
You can preview your drawing before you print 
to make sure you get the results you expect.

If you preview your drawing and notice that 
the drawing page and printer page orientations 
do not match, you should adjust either your 
printer page or drawing page settings so the 
two match.

To preview a drawing before printing

• Click the Print Preview button ( ) on the 
Standard toolbar. 

To match the printer page orientation to the 

drawing page orientation

1 Choose File > Page Setup.

2 In the Page Setup dialog box, specify the 
drawing page orientation as Portrait (taller 
than it is wide) or Landscape (wider than it 
is tall).  
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Print setup for large and multiple-
page drawings
When you work with large drawings or dia-
grams, it’s possible to have a drawing page that 
is larger than the printer page. If the size of a 
drawing is larger than the paper in your 
printer, Visio 2000 tiles the drawing, which 
means that the drawing appears across several 
sheets of paper. 

For example, if you create a large organization 
chart and, in order to accommodate the draw-
ing on your printer page, you increase the size 
of the drawing page without changing the 
paper size in your printer, Visio 2000 prints the 
drawing across as many pages as necessary.  

You can preview a large drawing to see if it will 
require more than one printer page. When you 
know your drawing will appear across multiple 
printer pages, you can choose how much a tiled 
drawing overlaps on adjacent pages. This gives 
you some room to overlap the parts of the 
drawings so that they fit together as a whole. 
You can also specify the number of pages you 
want your drawing to be tiled over.

To determine whether a large drawing will print 

on several pages

• Choose View > Page Breaks.

Gray bands appear on the drawing page, 
indicating the printer page size and margins 
selected in the Print Setup dialog box.

Printing  large 

drawings

You can print a drawing on large printer paper or across several smaller sheets of paper.
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To reduce or enlarge the size of a printed 

drawing

1 Choose File > Page Setup.

2 On the Print Setup tab, under Print Zoom 
(All Pages), choose one of the following 
options:

• To reduce the size of the drawing, select 
Adjust To, and then type a number less 
than 100.

• To enlarge the size of the drawing, select 
Adjust To, and then type a number 
greater than 100.

• To set the drawing to print across 
multiple sheets of paper, select Fit To, 
and then type the number of pages across 
and down on which you want the 
drawing to print.

3 Look at the preview to see if your drawing 
page and printer page are the way you want, 
and then click OK.

To increase the area where tiled drawings 

overlap

1 Choose File > Page Setup, and then on the 
Print Setup tab click the Setup button.

2 Type larger amounts for the margin set-
tings, and then click OK.

The larger the margins, the greater the 
overlap.

3 Click OK in the Page Setup dialog box.

To specify the number of pages for a tiled 

drawing  

1 Choose File > Page Setup, and then on the 
Print Setup tab click the Setup button.

2 Under Print Zoom, select Fit To, and then 
specify the number of sheets across and 
down. Choose the number of pages that 
represents an area proportionate to the 
drawing page. 

3 Click OK in both the Print Setup and Page 
Setup dialog boxes.  

For details, use these 
online Help keywords:

• Drawing scales

• Printing
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Publishing drawings to the Web

With Visio 2000, publishing your drawings or 
diagrams to the Internet or an intranet site is as 
easy as saving a file. Visio 2000 automatically 
adds the HTML codes necessary to display the 
drawing in a Web browser, so all you have to 
do is make sure your drawing looks the way 
you want.

You can make your drawing a launching point 
for users who want more detail and related 
information by adding hyperlinks to shapes. 
When users click a “hot” shape, they jump to 
the linked location. 

Converting Visio 

drawings to Web 

pages

You can easily convert Visio drawings to Web pages by saving them in HTML format.
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Adding hyperlinks to drawings
You can add one or more hyperlinks, or jumps, 
to Visio shapes and drawing pages. A link can 
jump to another page in the same Visio draw-
ing or diagram, another Visio drawing, or a 
non-Visio document.

When you add hyperlinks to other pages in 
the same drawing, you can use them to move 
among pages in the Visio drawing. For 
example, you can link a Process shape in a 
flowchart to Total Quality Management 
(TQM) documentation in a Microsoft Word 
document for that process.

When you link a shape or page to a file, you 
can decide whether the path to the link should 
be a relative path or an absolute path.

• Relative path A relative path describes the 
location of the linked file in relation to the 
Visio drawing or another path (set on the 
Summary tab in File > Properties). You can 
move the Visio drawing and the linked file 
together (that is, move the entire path struc-
ture) without breaking the link, but if you 
move the drawing or file separately, you 
break the link.

• Absolute path An absolute path spells out 
the exact location of the linked file in terms 
of drive, folder, and file name. You can 
move the Visio drawing file without affect-
ing the link, but if you move the linked file, 
you must reset the path.

To link a shape or page to another Visio 

drawing page, a Web page, or a non-Visio file  

1 Create or open a Visio drawing. To add a 
link to a page, display the page with nothing 
selected. To add a link to a shape, select the 
shape.

NOTE If you are linking to a Visio 2000 
drawing, make sure to save the drawing so 
that you can open the source to which you are 
linking.

2 Choose Insert > Hyperlink.

3 Do one of the following:

To link to a Web site For Address, type the 
Web site’s URL.

If you don’t know the URL, click Browse, 
and then choose Internet Address to open 
your default Web browser.

To link to a file For Address, click Browse, 
and then click Local File. Navigate to the file 
you want, and then click Open. (If necessary, 
change the type of file in Files Of Type.)

4 If you are linking to a file and you want to 
display a particular page, click Browse next 
to Sub-Address, select the page you want, 
and then click OK.

5 Under description, type a name for the link 
that identifies the location to which you’re 
linking.

For details, use these 
online Help keywords:

• Hyperlinks

• HTML and Internet 
tools
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6 Do one of the following:

To specify an absolute path Uncheck Use 
Relative Path For Hyperlink. 

To specify a relative path Check Use Rela-
tive Path For Hyperlink. To set a path that is 
not based on the location of the Visio draw-
ing, choose File > Properties. For Hyperlink 
Base, type the base path that you want.

7 If you want to add another hyperlink for the 
selected shape or page, click New, and then 
repeat steps 3 through 6.

8 If you want to link to another page within 
the document, or to a shape in the docu-
ment, click the Browse button to the right 
of Sub-Address, specify the page, shape, and 
zoom level you want, and then click OK. 

Converting drawings to HTML
After you create Visio 2000 drawings, you 
can convert them into Web pages with links 
to other Web pages by saving them as 
HTML files.

To convert a drawing to an HTML file  

1 Open the drawing you want to save as an 
HTML file, and then choose File > Save As.

2 Type a name for the HTML file, using the 
.htm extension, such as Drawing.htm.

3 For Save As Type, choose HTML Files 
(*.htm, *.html), and then click Save.

4 In the Save As HTML dialog box, accept the 
default settings, and then click OK.

You are prompted to view the HTML pages.

5 Click Yes to view the new Web pages in 
your default browser. 
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Routing your drawings for comments

You can use e-mail to send a Visio drawing or 
diagram to another user.  For example, if you 
need information from coworkers to complete 
your drawing, you can route the drawing to 
them electronically and ask for their 
comments.  

The Visio program also lets you take advantage 
of Microsoft Office routing features, including 
sending drawings to Microsoft Exchange fold-
ers, adding routing slips to drawings you send 
by means of e-mail, and adding journal entries 
to Microsoft Outlook.

NOTE Visio products are compatible with elec-
tronic mail programs that support the Messaging 
Application Program Interface (MAPI) protocol. 

To send a drawing with a routing slip

1 Display the drawing you want to send, and 
then choose File > Send To > Routing 
Recipient.

2 In the Routing Slip dialog box, click 
Address to open your address list, select the 
individuals or groups to whom you want to 
route your diagram, and then click OK.

3 If you want to route the drawing to people 
in a specific order, select a person’s name, 
and then click the up or down arrow in the 
Move section to change that person’s posi-
tion in the list.

4 Under Route To Recipients, specify whether 
to route the drawing to one person at a time 
or to everyone at once.

If you choose to route the drawing to one 
person at a time, the first person on the list 
views or updates the drawing, routes the 
drawing to the next person, and so on.

If you route the drawing to a designated 
group (called a group alias), all group 
members will receive the drawing at the 
same time.

5 Check Track Status to receive an update as 
each person on the list passes the drawing to 
the next person, or check Return When 
Done if you’d rather not see the drawing 
again until everyone has seen it.

6 Under Message Text, type the text you want 
in the e-mail message, and then click Add 
Slip.

7 Choose File > Send To > Next Routing 
Recipient to send the drawing to the first 
person on the routing list.

TIP If you receive a routed drawing and want 
to route it to the next person, choose File > 
Next Routing Recipient.
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Go further: Creating 
shapes, styles, and templates

As well as providing you with ready-to-use 
solutions, Visio® 2000 Technical Edition gives 
you the flexibility to build your own. You can 
create your own shapes and styles that you and 
others can reuse. 

You can, for example,

• Use drawing tools or menu commands to 
create or customize shapes, and add these 
shapes to stencils for use in future drawings 
or diagrams. 

• Create new styles, such as color fills and 
text styles, that you can reuse to give shapes 
a consistent look and make them easier to 
revise. 

• Create new templates that include stencils 
and drawing page settings you know you’ll 
use again.

Creating your own shapes ........................... 124

Reusing shapes you create and save .......... 126

Defining and editing styles ........................ 128

Designing your own templates.................... 129
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Creating your own shapes

There are several ways to create your own 
shapes in Visio 2000 Technical Edition. 
You can

• Draw a shape from scratch using Visio 
drawing tools, such as the line, rectangle, 
ellipse, and freeform tools. For example, if 
you want to add a freeform arrow to a block 
diagram, you can draw the arrow with the 
freeform tool ( ). 

• Merge a shape with other shapes to create a 
new, unique shape. For example, if you 
want to create a round sign with an arrow in 
its center, you can place an arrow shape on 
top of a circle and then use the Combine 
command to create the shape you want. 

• Revise an existing Visio shape to create a 
new, unique shape. For example, if your 
company uses a special process shape in 
flowcharts, you can modify the Visio Pro-
cess shape, save it on the Basic Flowchart 
Shapes stencil, and then use it in future 
flowchart drawings.

Using Visio drawing tools to 
create shapes
When you use the Visio drawing tools to create 
shapes, keep in mind that a shape can be either 
open or closed. 

Open shapes are lines, arcs, or zigzag shapes. 
You can format their ends, but you can’t fill 
them with colors or patterns because they con-
tain no enclosed space. 

Closed shapes, such as rectangles or circles, are 
surrounded by a continuous line. You can fill 
them with colors and patterns.

You can apply a pattern to a closed shape, such as a 
rectangle. You can add ends to open shapes, such as 
lines.

To draw a shape from scratch using the Visio 

drawing tools 

1 Choose a drawing tool from the Standard 
toolbar.

2 Click and drag on the drawing page to cre-
ate the shape you want. 

Click the arrow next to the rectangle tool and
the line tool to see more Visio drawing tools.

When you use the 
pencil, line, rectangle, 
or ellipse tool, try 
holding down the 
Shift key while you 
draw, to see how that 
constrains the 
drawing behavior.
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Merging existing shapes to create 
new shapes 

An easy way to create a complex shape is to 
select simple shapes and then use the shape 
operation commands, such as Fragment, Com-
bine, and Union, to create the new shape.

NOTE The new shape you create using any shape 
operation command inherits the formatting of 
the first shape you select. 

For details, use these 
online Help keywords:

• Drawing tools

• Multiple shapes
Using shape operations commands

Command Result Example

Fragment Breaks a shape into smaller parts or creates new 
shapes from intersecting lines or from 2-D (two-
dimensional) shapes that overlap.

Combine Creates a new shape from selected shapes. If the 
selected shapes overlap, the area where they overlap 
is cut out (discarded), creating a cookie-cutter effect.

Union Creates a new shape from the perimeter of two or 
more overlapping shapes.

Subtract Creates a new shape by subtracting the area where 
selections overlap from the primary selection.

Intersect Creates a new shape from the area where the 
selected shapes overlap, eliminating non-overlapping 
areas.

Offset Creates a set of parallel lines or curves to the right 
and left of the original shape.
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Revising existing shapes 
You can revise any Visio shape or shape you 
draw from scratch as long as the shape isn’t 
locked to prevent specific changes. When a 
shape is locked, you see padlocks in place of 
corner handles when you select the shape.

When you select shapes for revision using the 
pencil tool ( ), the line tool ( ), the arc tool 
( ), or the freeform tool ( ), the selection 
handles turn into vertices ( ),  which are 
green diamond-shaped handles that you can 
drag to change the appearance of a shape.

To revise an existing shape

• Select the shape with the pencil tool ( ), 
and then drag, add, or delete vertices ( ). 

• To change curves, drag a control point ( ). 

You can reshape shapes using the pencil tool. Select 
the shape, and then drag, add, or delete vertices.  

Reusing shapes you create and save

If you’ve created or modified a shape and want 
to keep it for future drawings or diagrams, you 
can make the shape a master by saving it on a 
stencil. All masters are stored on stencils. 
When you drag a shape from a stencil onto the 
drawing page, you are creating an instance, or 
copy, of the master.

You can also import graphics in other formats 
to save as masters. For example, if your com-
pany logo is in WMF format and you use it on 
all of your reports, you can import it into a 
Visio drawing, and then save it as a new master 
on a stencil. 

For details, use these 
online Help keywords:

• Masters

• Stencils
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Adding your own shapes to 
a stencil
If you want to reuse your own shapes the next 
time you open a particular drawing type, you 
can save your own shapes to existing stencils in 
your drawing, and then save the file as a tem-
plate (.vst). 

You can also create a new stencil, and then add 
your own shapes as well as any existing Visio 
shapes you want to it. Then, you can save the 
stencil in a template file, so that you and others 
can reuse it in other drawings. 

To add your own shape to an existing stencil

1 Open the template containing the stencil 
you want to add your own shape to.

2 Click the icon on the stencil title bar ( ), 
and then choose Edit from the menu.

A red asterisk appears on the stencil icon  
( ) to indicate that the stencil is editable. 

3 Hold down the Ctrl key, and then drag your 
own shape from the drawing page onto the 
stencil.

A new icon representing your own shape 
appears on the stencil with a generic name, 
such as Master .01.

4 Click the new master on the stencil, click it 
again, and then type the name you want for 
the new shape.

5 Click the stencil icon ( ), and then choose 
File > Save As to open the Save As dialog 
box. Navigate to the Solutions folder in 
which you want to save the stencil, and then 
type a name for the stencil in the File Name 
box. For Save As Type, choose Stencil 
(*.vss), and then click Save to save your 
stencil.

When you open the stencil again, you can 
use the new shape as you do any other 
Visio 2000 master.

To add your own shape to a new stencil

1 Choose File > Stencil > New Stencil. You 
can also choose View > Toolbars > Stencil, 
and then click the New Stencil toolbar 
button ( ) from the Stencil toolbar.

The new stencil appears docked to the left 
side of the drawing window. The stencil 
icon has a red asterisk ( ) to indicate that 
it is editable.

2 Hold down the Ctrl key, and then drag your 
own shapes, one at a time, from the drawing 
page onto the new stencil.

3 Click the Save icon on the right side of the 
stencil title bar ( ).

The Save As dialog box appears.

4 In the Save As dialog box, navigate to the  
folder where you want to save the stencil, 
and then type a name for the stencil in the 
File Name box. Check to make sure Save As 
Type is Stencil (*.vss), and then click Save.

For details about saving files as templates, see 
“Creating and saving your own template” on 
page 129. 
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Defining and editing styles

A style in Visio 2000 Technical Edition is a 
named collection of formatting attributes that 
you can apply to your shapes. You can create 
styles that format the elements of a shape: fill, 
line, and text. For example, you might create a 
style that gives shapes a black outline, a green 
fill, and black bold italic text.

When you define or edit styles in a drawing file, 
the changes you make are available only in the 
current drawing or diagram. To make a style 
available for future drawings, you can define or 
edit it in an existing template. The style is 
included in every new drawing you create.

For details about designing your own template, 
see “Designing your own templates” on 
page 129. 

To define a new style  

1 Choose Format > Define Styles.

2 Type a name for the new style in the Style 
list.

3 If you want to base the new style on an 
existing style, select that style from the 
Based On list.

4 Under Includes, check the attributes that 
your style includes. A style can include for-
matting from any combination of the three 
attributes.

5 Under Change, click Text, Line, or Fill to 
change the settings for each attribute you 
included in Step 4.

6 When the style contains the settings you 
want, click Apply to add the new style and 
apply it to selected shapes.

To change a style

1 Choose Format > Define Styles.

2 In the Style list, select the style you want to 
change.

3 To rename the style, click the Rename but-
ton, type a new name in the Rename Style 
dialog box, and then click OK.

4 To change style settings, click the Change 
button. When you finish changing the 
attributes, do one of the following:

• Click Apply.

• Click Change to add the changes and 
continue working in the dialog box.

For details about formatting shapes, see 
Chapter 1, “Visio basics.” 
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Designing your own templates

Designing your own template enables you to 
set up the Visio drawing environment, such as 
your page settings, tools, and stencils, exactly as 
you prefer. Then you can save the file as a tem-
plate file and reuse it as often as you want. You 
can also share your customized template with 
coworkers. 

You might want to create your own templates  
when your drawings

• Require customized settings such as page 
size or scale, window size and position, or 
shape or text styles.

• Often use a particular background or set of 
layers. For example, if you place your com-
pany logo in every drawing, you can create a 
template with that background or set of 
layers in place.

Creating and saving your own 
template
The easiest way to create a template is to set up 
a drawing file the way you want, open the sten-
cils you want, and then save the settings as a 
template (.vst) file. 

If you simply want to change some of the set-
tings of an existing Visio template, you can 
base a drawing on that template, save the draw-
ing with a new name, and then make your 
changes.

To create and save your own template  

1 Open your drawing or start a new drawing 
based on the template you want to modify.

2 Open any additional stencils you want to 
save with the template by choosing File > 
Stencils > Open Stencil and then choosing 
the stencil(s) you want.

3 Change drawing page settings and styles to 
those you want to use in future drawings 
that are based on this template.

4 Choose File > Save As, and then do the fol-
lowing:

• For Save As Type, select Template (*.vst).

• For File Name, type a name for your 
template.

• For Save, make sure Workspace is 
checked.

• For Save In, select the folder in which you 
want to save the template.

5 Click Save.

Using background pages to 
display common page elements
You can set up background pages that appear 
each time your customized template opens. 
For example, if you want your company logo 
to appear on all of your future drawings, you 
can create a background page that contains 
the logo graphic and then assign it to the 
foreground page. When you save the drawing 
file as a template, the logo appears on the draw-
ing page each time you open the template.
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To create a background for a drawing

1 Right-click a page tab in the lower-left 
corner of the drawing window, and then 
choose Insert > Page from the shortcut 
menu.

2 On the Page Properties tab, for Type, click 
Background.

3 If necessary, click the Drawing Scale tab to 
change the scale or the Page Size tab to 
change the page size for the new page, and 
then click OK.

4 Place the design element you want to use as 
a background onto the drawing page.

To assign a background to a drawing  

1 Display the page to which you want to 
assign the background.

2 Choose File > Page Setup, and then click the 
Page Properties tab.

3 In the Background list, select the name of 
the background that you want to assign, and 
then click OK.

The background appears behind the shapes 
on the foreground page.

To display a background so you can edit it

• Display the page to which the background is 
assigned, and then choose Edit > Go To > 
Background.

  

For details, use these 
online Help keywords:

• Background pages

Background pages

Use a background to repeat a common element on several drawings. For example, the sailboat appears on each of 
these three pages.



Glossary

Attribute  An individual formatting element 

such as line color, fill color, and line weight 

that you can apply to shapes. A style can have 

more than one attribute. See also Style, 

Format.

Association  In the Process Engineering 

solution, a hierarchical relationship between 

two shapes that shows how the shapes are 

functionally or mechanically related. For 

example, valves automatically form an 

association with the pipeline on which they are 

dropped.

Background  A page that you can assign to 

another page to create multiple layers in a 

drawing. You can see shapes displayed on a 

background when the page it is assigned to is 

displayed. You can’t select or edit the 

background without displaying the 

background page. See also Foreground, Layer.

Bubble diagram  A conceptual design sketch 

that shows the required spaces in a building 

and the relationships between spaces.

Closed shape  A shape that is surrounded by a 

continuous outline, such as a rectangle or 

circle. You can fill a closed shape with color or 

a pattern. See also Open shape.

Color scheme  A set of colors you can assign to 

some drawing types. You can choose from 

preset color schemes, or you can create a new 

color scheme. 

Connection point  A point on a shape where a 

connector can be glued. You can create 

connection points inside, outside, or on the 

perimeter of a shape, using the connection 

point tool ( ). See also Glue.

Connector  Any one-dimensional (1-D) shape 

that can be glued between two shapes in a 

drawing to connect the shapes. You can also 

use lines and other shapes you draw as 

connectors. See also Glue, One-dimensional 

shape.

Control handle  A handle ( ) that specifies 

unique behavior for certain shapes. For 

example, in some shapes you can use a control 

handle to reposition text on the drawing page. 

You can pause the pointer over a control 

handle to see what it does.
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Crop  To reduce or expand an object from 

another application used in a Visio® drawing. 

Although cropping appears to clip off parts of 

the object, the Visio application retains the 

clipped portions of the object in memory. You 

crop an object by selecting it with the crop tool 

( ) and dragging one of its handles.

Custom property  Information about shapes in 

your drawings. Some Visio shapes come with 

custom properties already defined. You can 

edit or delete existing custom properties or 

create new ones.

Datasheet  In the Process Engineering solution, 

an electronic form you use to add and edit data 

for components in a project. 

Drawing file  A Visio file with a .vsd extension 

that contains a drawing. You can create a new 

drawing from scratch or base it on a template, 

and then save the file. See also Template.

Drawing scale  The ratio of page scale to a 

specified number of drawing units, such as one 

centimeter is equal to one meter. See also Scale.

Drawing type  A Visio file (template) with a .vst 

extension that opens with the stencils, styles, 

and settings you need to create a particular 

type of drawing. See also Stencil, Template.

Dynamic grid  Lines that show the most 

desirable location for the next shape you drag 

onto the drawing page.

Embed  To insert a Visio drawing in another 

application’s document (a container 

application) to establish a dynamic connection 

between the drawing and the other document. 

In the container application, you can open the 

embedded Visio drawing to edit it. See also 

Link.

Endpoint  Either of the square handles at the 

end of a selected line, arc, or other one-

dimensional (1-D) shape. The endpoint at the 

beginning of the shape is an x. The endpoint at 

the end of the shape is a plus sign (+).

Fill  The color and pattern inside a closed 

shape. The default fill for Visio shapes is solid 

white.

Foreground  The top page of a drawing. Shapes 

on the foreground page appear in front of 

shapes on the background page and are not 

visible when you edit the background of the 

drawing. See also Background.

Format  The visual appearance of a shape (such 

as the thickness and color of its lines, the color 

and pattern inside the shape, and its font). You 

can change the format of a shape by applying a 

style or by changing its individual attributes. 

See also Attribute, Style.

Glue  A property of shapes that causes them to 

stay together even when one of the shapes is 

moved. When you attach a connector to a 

shape, you glue the connector. See also 

Connector.

Grid  Nonprinting vertical and horizontal lines 

that appear at regular intervals on the drawing 

page.
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Group  A shape composed of two or more 

shapes. You can move or size groups as a unit, 

but group members retain their original 

appearance and properties. 

Guide, guide point  Reference lines you can drag 

onto the drawing page to position shapes 

precisely. A horizontal guide is dragged from 

the horizontal ruler, a vertical guide is dragged 

from the vertical ruler, and the guide point is 

deagged from the upper-left corner of the 

drawing window where the horizontal and 

vertical rulers meet.

Instance  A copy of a master shape that you 

drag from the stencil onto the drawing page. 

See also Master.

Intelligent tag  In the Process Engineering 

solution, a tag that contains information about 

a component, such as the line size of a pipeline.

Isometric drawing  A two-dimensional drawing 

that represents three-dimensional objects.  

Layer  A named category of shapes. You can 

organize shapes in your drawing by assigning 

them to layers. You can selectively view, edit, 

print, or lock shapes on layers. See also 

Background, Foreground.

Link  To establish a dynamic connection 

between an object in a Visio drawing and 

another application’s file. When changes occur 

in the original file, you can update the linked 

file so that the most current version of the 

object appears in the linked file. See also 

Embed.

Master  A shape on a stencil that you use over 

and over to create drawings. When you drag a 

shape from a stencil onto the drawing page, the 

shape becomes an instance of that master. See 

also Instance, Stencil.

Nudge  To move a shape a small amount using 

the arrow keys. Select the shape, and then click 

the up, down, right, or left arrow key. (Make 

sure the Scroll Lock key is turned off.)

One-dimensional (1-D) shape  Either a straight 

line you draw using Visio drawing tools or a 

shape that has a beginning point and ending 

point and can be glued between two shapes to 

connect them. See also Two-dimensional 

(2-D) shape. 

Open shape  A shape such as a line, arc, or 

zigzag. You can format an open shape with line 

patterns and ends, such as by changing a solid 

line to a dashed line and adding an arrow to 

one end. See also Closed shape. 

Page  The printable area in a drawing window 

that contains a drawing. A page can be either a 

foreground or background page. Each page has 

a size, which usually corresponds to a standard 

paper size, and a scale, which the Visio 

program preconfigures for particular drawing 

types. See also Background, Foreground, Scale.

Pan  To move an OLE object, such as an 

inserted CAD drawing, with the crop tool by 

holding down the left mouse button and 

shifting the object within the object’s border.
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Point-to-point  A method of connecting shapes. 

The actual point of connection stays the same 

no matter how you move the connected 

shapes. You connect shapes point-to-point by 

dragging a connector from a connection point 

on one shape to a connection point on another 

shape. See also Connection point, Connector, 

Shape-to-shape. 

Polyline  A shape made up of one or more 

connected line or arc segments.

Redline  To review and mark up or add 

comments to a drawing.

Scale  A measure of the relationship between 

actual distances and distances represented in a 

Visio drawing. For example, a floor plan might 

have a scale of one meter of actual distance to 

one centimeter in the drawing. See also 

Drawing scale.

ScreenTips  Tips that appear when you pause 

the pointer over certain elements in the Visio 

program, including masters on stencils, toolbar 

buttons, and the ruler.

Selection  Shapes in a drawing that you have 

selected and can perform actions upon. 

Selected shapes have selection handles ( ). 

Selection also refers to text selected in a text 

block. Selected text is highlighted when it is 

editable. 

Selection handle  A square handle ( ) that 

appears on a shape selected with the pointer 

tool ( ). Selection handles indicate that you 

can move or size the shape.

Shape  1. An open or closed object created 

using Visio drawing tools or commands. 2. A 

grouped collection of shapes. 3. An instance of 

a master that is dragged from a stencil onto the 

drawing page. See also Instance, Master.

Shape Explorer™  A Visio tool you can use to 

locate shapes when you’re not sure what 

stencils they’re on. For example, if you know a 

3-D Box shape exists, but don’t know where to 

find it, use the Shape Explorer to determine 

which stencil contains the shape, and then 

open the stencil or use the Shape Explorer to 

add the shape to your drawing. See also Shape.

Shape-to-shape  A method of connecting 

shapes. The actual point of connection might 

change when you move the connected shapes. 

You make shape-to-shape connections by 

dragging a connector from the center of one 

shape to the center of another shape. As you 

place the mouse over the center of each shape, 

a red box appears to indicate that you’re 

creating a shape-to-shape connection. See also 

Connection point, Connector, Point-to-point. 

Snap  The ability of shapes, guides, and grid 

lines to pull shapes and other elements into 

position when they are moved and sized.

Solution  The file folder that contains templates 

for particular drawing types. For example, the 

Project Schedule solution folder contains the 

Calendar, Gantt Chart, PERT Chart, and 

Timeline templates that you use to create those 

particular drawing types. See also Template.
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Stacking order  The order in which shapes 

overlap other shapes on the page and the order 

in which shapes are selected. You can change 

the stacking order of shapes by using 

commands on the Shape menu.

Stencil  A collection of masters associated with 

a particular Visio drawing type, or template. 

Stencils that open with a template are docked 

on the left side of the drawing window, by 

default. You can open stencil files (.vss) 

independently of a template. See also Master, 

Template.

Style  A collection of attributes that has a name 

and is saved with a template or drawing file. See 

also Attribute, Format.

Template  A Visio file (drawing type) with a .vst 

extension that opens with the stencils, styles, 

and settings you need to create a particular 

type of drawing. See also Drawing file, Drawing 

type, Stencil.

Text block  The text area associated with a 

shape, which appears when you click the shape 

with the text tool ( ) or select it with the 

pointer tool ( ).

Tile  1. A printing technique used when 

oversized drawing pages are printed on 

multiple sheets of paper. 2. A command on the 

Visio Window menu that opens multiple 

drawings side by side in the main window.

Toolbar  The rows of boxes, buttons, and bars 

that appear below the menu bar. To choose 

which toolbars you want to display and to 

create custom toolbars, choose View > 

Toolbars. 

Two-dimensional (2-D) shape  A shape that has 

four selection handles you can use to resize the 

shape proportionally. See also One-

dimensional shape.

Vanishing point  In the Blocks With Perspective 

template, a point that represents where the 

perspective recedes in your drawing. You can 

move the vanishing point to any location on 

the drawing page.

Vertex, vertices  One of the diamond-shaped 

handles that appears between two segments on 

a multiple-segment shape, or at the end of a 

segment. You can reshape a shape or connector 

by dragging its vertices. See also Endpoint.

Workspace  A Visio file (.vsw) that contains 

information about the size and position of 

stencils and drawings. 





Index

Numerics
1-D shapes  12, 133
2-D shapes  12, 135

A
Absolute paths for hyperlinks  120–121
Access, Microsoft database for facilities plan  65
Action toolbar, viewing  15
Action tools, flipping and rotating shapes  15
Activating text rulers  18
Add A Dimension dialog box  93
Add A Guide command  92
Add-ons. See Tools
Addresses, Visio Web site  2
Alarms in fire and security plans  105
Aligning shapes  11

to geometric points  28
to grids, guides, and guide points  28
by moving a specified distance  30
by using the dynamic grid  29

Angle dimension lines  27
Annotations stencil  110
Annotations, labels for data  52
Annunciation shapes in fire and security 

plans 105
Appliances, adding  95
Applying formatting to shapes

color schemes  23
colors  16
fills  16, 132
shadows  16
styles  23

Architectural site plans  96–98

Areas
designating  72
measuring  72, 93
tracking  69–73

Assemblies, defined  49
Asset tracking

about assets  74–75
assigning categories to shapes  77–78
assigning people to spaces  73
converting existing building shells  68
creating building shells  66–68
data from existing databases  80–81
designating areas  72
designating new tracking information  76–78
designating spaces  69–70
distributing facilities plans  85
for floors or pages  74
linking data  81
listing and locating assets  82–83
people, spaces, and areas  69–73
printing lists  83
removing  65
sample drawings  64, 79
searching for assets  73, 82–83
setting properties for  75
setting up databases  65
starting  65
tracking data with asset shapes  75
Visio CAFM Explorer  83–84

Assign Datasheet Wizard  59
Associations  48, 131
Auto Size command  71, 89
AutoCAD files. See CAD files
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Autodesk AutoCAD. See CAD files
Automatic Label 1 shape  52
Automation, finding Help for using  3
Automation systems, factory  112
Automobile suspension systems  112
Axes, specifying for shapes  30

B
Background images, inserting CAD files as  36–37
Background pages  22, 129–130, 131
Backups

facilities plans and databases  75
folder for previous versions  45

Baseline dimension lines  27
Basic: Facilities Data.mdb  65
Batteries, adding  109
Bentley MicroStation. See CAD files
Bill of materials

creating your own  61–62
customizing  58–59

Blocks in CAD files  34
Borders

shapes  58
sheets  57–58

Boundary shape  72
Bubble diagrams  88, 131
Budgets, adding to facilities plans  83–84
Building Architecture solution  5, 70
Building Core stencil  92
Building facilities  99–100
Building Services solution  5, 102–107
Building shells

converting existing  68
creating  66–68
drawing  91
drawing outlines  97
indicating perimeters  92
inserting CAD files  67

C
CAD Drawing dialog box  37, 38
CAD Drawing Properties dialog box  67, 107
CAD files

adding hatch patterns  34
converting symbol libraries  55
converting to Visio building shells  68
converting to Visio format  41
copying objects  34
creating blocks  34
creating from Visio drawings  42
creating objects  34
cropping  40
dimension lines  41
drawing in Visio 2000  33–34
drawing scale  39
hiding layers  40
importing as building shells  67
importing for process shapes  55
importing in Visio format  41
inserting as background images  36–37
inserting as building shells  67
inserting as detail images  37–38
layers in  41
levels in  41
moving objects  34
new features in Visio 2000  5
panning and zooming  34
plotting diagrams  34
resizing Space shapes  71
sample drawings  36, 37
setting drawing scale  34
snaps  28, 34
symbol libraries  55
using existing in Visio 2000  107
using Visio layers  36
using with electric and telecom plans  105
using with fire and security system plans  105
using with HVAC control logic diagrams  103
using with HVAC plans  103
using with plumbing drawings  104

CAFM Explorer, Visio  83–84
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Calculating, square footage  72
Categories

adding for tracking  76–78
assigning datasheets to  59
assigning to shapes  77–78
creating new  59
default  59
defined  59, 76
viewing  70

Categories dialog box  77
Centrifugal Pump shape  44, 46, 51
Chair shapes  75
Check Valve shape  47
Choose Drawing Type dialog box  65, 88, 91, 95, 

97, 100, 103, 104, 105, 109, 110, 113
Circuit boards, printed  109
Circuit schematics  109
Closed shapes  124, 131
Codes, substitution  60
Color schemes  131

applying  23
Colors, adding to shapes, lines, and text  16
Columns  91, 92
Combine command  125
Company standards

customizing PFDs and P&IDs for  57–62
datasheets  58–59
sheet formats  57

Components
adding data  51
assemblies  49
associating  48
creating intelligent tags for  60–61
displaying data  52
functionally dependent  48
grouping  49
in-line  48
intelligent tags  53
layer categories  59
lists of  54
mechanically related  48
numbering or tagging  53

offset  48
storing data in datasheets  50
view in Project Explorer  44

Concepts, finding Help for  3
Connecting shapes  13–15

point-to-point  13–15, 134
shape-to-shape  13–15, 134

Connection points  131
adding to shapes  15

Connector shapes  13, 131
Constraining drawing behavior  124
Construction documents, floor plans in  90–93
Contents tab (Visio Help window)  3
Control handles  11, 131
Control system diagrams  109
Convert Shapes Wizard  68, 78
Convert To Walls utility  89
Convert Wizard  41
Converting

CAD files to Visio format  41
CAD symbol libraries  55
drawings to HTML  121
from previous Visio versions  45
shapes  68, 78
symbols of processes  55
units for tables  61
Visio files to CAD format  42
walls  89

Coordinates for positioning shapes  29
Corner 2 shape  75
Corner joints  91
Creating your own

shapes  124
templates  129–130

Cropping
CAD drawings  40
defined  132
tool  40

Cubicle walls  92
See also Walls

Curbs, adding  98
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Custom properties  132
Custom Properties window  4
Customize Tags dialog box  60

D
Dashed red lines  47
Data

from existing databases  80–81
linking in facilities plans  81

Data fields  52
adding to components  51
creating intelligent tags  60–61
creating your own lists for  61–62
including in datasheets  58–59
units for  58, 61

Databases
on network servers  65
setting up facilities  65
using existing  80–81

Datasheet Builder dialog box  59
Datasheet Window  51, 52, 61
Datasheets

adding data to  51
categories  59
creating  58–59
creating intelligent tags  60–61
creating new formats  57–58
default unit for fields  58
defined  50, 132
displaying data  52
including data fields  58–59
intelligent tags  53
labels for  58
lists of components  54
printing  56
sample drawing  58
units system  61
valves  45

Datum feature symbols  110
Defaults

categories  59
for data field units  58

Defining styles  128

Deleting elements
drawing pages  21–22
shadows  16
shapes from groups  20
text from shapes  17

Departments
designating areas  72
relating people to  84
tracking  69–73

Dependent components, functionally  48
Designing your own templates  129–130
Desk shapes  75
Detail images, inserting CAD files as  37–38
Developing Visio Solutions  2
DGN files. See CAD files
Diagrams

viewing page tabs  21
See also Drawings, Pages

Dimension lines  27
adding to walls  93
in CAD files  41

Directional maps
color scheme availability  23

Displaying backgrounds for editing  130
Displaying ScreenTips  11
Door shapes  92, 93, 95
Dragging shapes  30
Drawing Explorer window  4
Drawing files  132
Drawing pages

adding  66
adding and deleting  21–22
changing drawing scales  26
changing scale  66
changing size  66
linking to another page or file  120–121
matching orientation to printer pages  116
navigating between  4, 22
resizing  22
setting measurement units  27
tracking assets on  74
See also Pages
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Drawing scales  132
in CAD files  39
changing  26, 66, 68
defined  26
in CAD files  34
overview  26

Drawing shapes  30–31, 124
Drawing Tool Shapes stencil  110
Drawing types  4, 10, 127, 132

basing drawings on  9
Building Architecture  5
Building Services  5, 102–107
directional maps  23
Electrical And Telecom  105–106
Facilities Management  5
Fire And Security Systems  105
Floor Plans  88–93
Fluid Power  112–113
General Electrical Engineering  108–109
Home Plans  94–95
HVAC Control Logic  102–103
HVAC Plans  103–104
Mechanical Engineering  110–111
Office Layout  5
Part And Assembly  110–111
Plant Layout  99–100
Plumbing And Piping  104
Process Engineering  5, 43–62
Site Plans  96–98
See also Templates

Drawings
assigning backgrounds  130
creating  8–16
creating backgrounds  130
enhancing  23
finding and changing text  18
grouping shapes  19–20
printing  24, 116–118

publishing to the World Wide Web  119–121
routing for comments in e-mail  122
saving  24
scales  26
tips for file names  45
Visio 2000 workspace  8
zooming  32
See also Diagrams, Drawing types

Driveways, adding  98
Ductwork in HVAC plans  103–104
Duplicating shapes  70
DWG files. See CAD files
DXF files. See CAD files
Dynamic grid, aligning shapes to  11, 29, 132

E
E-mail, routing drawings  122
Edit Datasheet dialog box  44, 51
Edit Tag Number dialog box  53, 61
Electrical And Telecom solution  105–106

sample drawing  108
using existing CAD floor plan  107
using with CAD files  105

Electrical And Telecom stencil  107
Electrical Engineering solution  108–109
Electrical wiring

adding symbols  95
electric and telecom plans  105–106

Electronic diagrams  108–109
Elevators, drawing  91
Ellipse tool, constraining drawing behavior  124
Embedding drawings  132
Employees. See People
Endpoints  12, 132
Enhancing drawings  23
Enlarging drawings. See Drawing scale, Zooming
Enlarging sizes of printed drawings  118
Entity snaps in CAD files  34
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Equipment
adding  100
creating your own lists  61–62
default category  59
Heat Exchangers stencil  46
HVAC systems  102–103
lists  54
Pump stencil  46
shapes  113
tracking  74–75

Examples of drawings. See Sample drawings
Explorer, Visio CAFM  83–84
Exporting

CAD to Visio files. See CAD files
Visio drawings as CAD files. See CAD files
Visio files in CAD format  42

Extension lines  30–31
Exterior walls  91, 92

See also Walls
External databases, using data from  80

F
Facilities databases  65
Facilities Data.mdb  65
Facilities Management Setup Wizard  65
Facilities Management solution  5

assigning categories to shapes  77–78
assigning people to spaces  73
building shells  66–68
Convert Shapes Wizard  78
data from existing databases  80–81
designating areas  72
designating new tracking information  76–78
designating spaces  69–70
distributing facilities plans  85
Facilities Management Setup Wizard  65
Get External Data Wizard  80
inserting CAD files  67
listing and locating assets  82–83
printing  85
printing lists  83
resizing spaces  71–72

sample drawings  64, 79
setting up databases  65
starting  65
tracking assets  74–75
tracking data with asset shapes  75
tracking people, spaces, and areas  69–73
Visio CAFM Explorer  83–84
without asset tracking  65

Facilities plans. See Facilities Management 
solution

Factory automation systems  112
FAQs online  2
Fasteners 1 stencil  110
Fasteners 2 stencil  110
Favorites tab (Visio Help window)  3
Feature control frames  110
Features, finding Help for using  3
Fences, adding  98
Fields

creating intelligent tags  60–61
creating your own lists for  61–62
data  52
including in Datasheets  58–59
units for  58, 61

Files
converting drawings to HTML files  121
linking to drawings and Web pages  120–121
tips for project names  45

Filing cabinets  75
Fill color palette  16
Fill dialog box  34
Find and change text  18
Find dialog box  73, 83
Find Facilities Data dialog box  82
Finding assets  73, 82–83
Finding shapes using the Shape Explorer  10
Finding Technical Support information  2
Finding text in large drawings  18
Fire And Security Systems solution  105

sample drawing  106
using existing CAD floor plans  107
using with CAD files  105
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Fittings in plumbing drawings  104
Fixtures

adding  95
tracking  74–75

Flipping shapes  15
Floor Plans solution  88–93

adding pages for  66
building shells  66–68
changing size and scale  66
hiding layers  40
inserting CAD files  67
inserting CAD files as background 

images  36–37
inserting CAD files as detail images  37–38
sample drawing  90
starting  91
tracking assets on  74
using existing  70
using existing CAD files  107

Floors, converting existing building shells  68
Fluid Power solution  112–113
Fluid Power - Valves stencil  113
Folders

setting up for projects  56
tips for projects  45

Foreground pages  129, 132
Formats  132
Formats, sheets  57–58
Formatting line styles  16
Formatting shapes  23
Formatting text in shapes  18
Forms, creating your own  61–62
Forwarding drawings in e-mail  122
Fragment command  125
Frames, hiding  93
Functionally dependent components  48
Furniture  74–75, 95

G
Garden Accessories stencil  95, 98
General Electrical Engineering solution  108–109
Generate List dialog box  54, 62
Geometric Dimensioning And Tolerancing 

stencil  110
Get External Data Wizard  80
Glossary terms, appearance in chapters  2
Glue  13, 132
Go To Shape command  45
Grids  132

align shapes to the dynamic grid  29
dynamic  11
snap shapes to  28

Grouping components  49
Grouping shapes  19–20
Groups  133

components  49
creating  19
modifying  19
working with  20

Groups of shapes  19–20
Guide points  28, 133
Guides  133

changing the size of rooms  89
snap shapes to  28

H
Handles

control handles  11, 131
selection handles  11, 134
shape handles  11

Hatch patterns in CAD files  34
Headers, hiding  93
Heavy machinery  112
Help. See Online Help
Hiding the navigation pane (Visio Help 

window) 3
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Hierarchical view of assets  83–84
Home Plans solution  94–95
HTML, converting drawings to  121
HVAC Control Logic solution  102–103, 107
HVAC Plans solution  103–104

sample diagram  102
using existing CAD floor plan  107
using with CAD files  103

Hydraulic circuit diagrams  112–113
Hyperlinks

adding to drawings  120–121
Hypertext Markup Language. See HTML, 

converting drawings to

I
Importing

CAD files as building shells  67
CAD files in Visio format  41
symbols of processes  55

In-line components  48
Index tab (Visio Help window)  3
Indicator shapes  47
Initiation shapes  105
Insert CAD Drawing dialog box  67, 107
Insert Page dialog box  66
Installing Visio 2000 Technical Edition  2
Instances  133

See also Masters
Instruments

creating your own lists  61–62
default category  59

Instruments stencil  47
Integrated circuit schematics  109
IntelliCAD files. See CAD files
Intelligent tags

creating  60–61
defined  53, 133

Interior walls  91, 92
See also Walls

Internet address for Visio Corporation  2
Internet, publishing drawings to  119–121

Intersect command  125
Intranets, publishing drawings  119–121
Irrigation stencil  98
Irrigation systems, adding  98
Isometric drawings

defined  133
using extension lines for  30–31

J
Joints, T- and corner  91

K
Keywords, searching online Help for  2
Knowledge Base  2

L
Labels

for data  52
for datasheets  58

Lamp shapes  109
Landscape site plans  96–98
Large drawings

finding and changing text  18
printing  117

Layer Properties dialog box  107
Layers  133

in CAD files  36, 40, 41
categories and components  59
locking  107
redlining  56
for review comments  56

Layout, Office solution  5
Levels in CAD files  40, 41
Libraries of CAD symbols  55
Lighting

adding  98
in electric and telecom plans  105–106

Line lists  54
Line styles  16
Line tool  89
Linear dimension lines  27



I N D E X 145
Lines
creating rooms with  89
dimension  27, 93
dimension in CAD files  41
extension  30–31
red dashed  47

Linking shapes and pages  120–121
Links  133
Lists

assets  82–83
components  50, 54
creating new formats for  57–58
creating your own  61–62
customizing  58–59
printing  83
sorting  83

Loading equipment shapes, adding  100
Locate command  83
Locating assets  82–83
Locked shapes  17
Locking layers  107
Logic circuit schematics  109

M
Machines, adding  100
Macros. See Tools
Magnifying drawings  32
Manufactured goods shapes, adding  100
Manufacturing plant layout  99–100
Masters  126, 133

converting CAD symbol libraries to  55
See also Instances

Materials transfer shapes, adding  100
Measurement units  27, 61
Measuring

area and perimeter  93
square footage  72

Mechanical Engineering solution  110–111
Mechanical part, inserting CAD files as detail 

images  37–38
Mechanically related components  48

Menu commands, finding Help for using  3
Merging existing shapes to create new shapes  125
Messaging Application Program Interface (MAPI) 

protocol, compatibility  122
Microsoft Access database, for facilities plans  65
Microsoft SQL Server database, for facilities plans  

65
MicroStation files. See CAD files
Mistakes, correcting  11
Move tool  30, 34
Moving groups  20
Moving shapes  11, 30, 49
Moving stencils  10
Multiple shapes

moving  12
Multiple-page drawings

navigating  22
printing  117
viewing page tabs  21

N
Navigating between pages  4, 22
Navigation pane (Visio Help window)  3
Netlist Generator  109
New Datasheet dialog box  59
New Drawing dialog box  58
New List dialog box  62
Nudging shapes  12, 30, 133
Number of pages

determining for large drawings  117
specifying for tiled drawings  118

Numbering components  53

O
Objects in CAD files  34
Office Equipment - Electronic stencil  78
Office Furniture stencil  75
Office Layout solution  5, 70

assigning people to offices  73
designating spaces  73
floor plans in  90–93
tracking  69–73

Offset command  31, 125
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Offset components  48
Offsetting shapes  31
One-dimensional (1-D) shapes  12, 133
Online Help  2–3
Open dialog box  44, 107
Open shapes  124, 133
Open Stencil dialog box  107
Opening additional stencils  10
Organization view of assets  83–84
Orientation of pages

matching printer pages to drawing pages  116
setting  21

Orientation of sheets  57–58
Outline view of assets  83–84
Outside dimension lines  27

P
P&IDs (piping and instrumentation diagrams). 

See Process Engineering solution
Page Setup dialog box  26, 27, 34, 66, 68, 88, 

91, 95, 97, 100
Page size, sheets  57–58
Pages  133

adding  66
adding and deleting  21–22
changing drawing scales  26
changing scale  66
changing size  66
determining number for large drawings  117
displaying common page elements  129–130
linking to another page or file  120–121
navigating using page tabs  21
resizing  22
setting measurement units  27
setting orientation  21
specifying number for tiled drawings  118
tracking assets on  74
zooming  32

Pan & Zoom window  4, 32, 34
Panning drawings  32, 133
Parallel shapes, creating  31
Parking And Roads stencil  98
Parking shapes, adding  98
Part And Assembly solution  110–111
Parts, inserting CAD files as detail images  37–38
Paths for hyperlinks

absolute  120–121
relative  120–121

Pathways, adding  98
Patterns in CAD files  34
PC shape  78
People

adding information about  84
assigning to spaces  73
linking data  81
locating  73
relating to departments  84
tracking  69–73

Perimeter, building  92, 93
Person shape  73, 85
PFDs (process flow diagrams). See Process 

Engineering solution
Pin, positioning  29
Pipelines

associating with valves  48
changing appearance  49
creating your own lists  61–62
default category  59
drawings of  104
how they move  49
in HVAC plans  103–104
in P&IDs  46
storing data in datasheets  50

Piping and instrumentation diagrams. See Process 
Engineering solution



I N D E X 147
Plans
facilities. See Facilities Management solution
floor  90–93
hiding layers  40
home  94–95
inserting CAD files as background 

images  36–37
inserting CAD files as detail images  37–38
site  96–98
space  88–89

Plant Callout shape  98
Plant Layout solution  99–100
Plants, adding  95, 98
Plotting CAD diagrams  34
Plumbing And Piping solution  104, 107
Pneumatic circuit diagrams  112–113
Point-to-point connections  13–15, 134
Pointer tool  11, 19
Polyline, defined  134
Pools, adding  98
Positioning shapes  11

by dragging  30
to geometric points  28
to grids, guides, and guide points  28
using coordinates  29
using the dynamic grid  29

Previewing drawings before printing  116
Previous Visio versions  45
Print dialog box  34
Printed circuit boards  109
Printer pages, orientation  21, 116
Printing

datasheets  56
facilities plans  85
lists  83

Printing drawings  24, 24, 116–118
Process Annotations stencil  52
Process Engineering menu  45

Process Engineering solution  5, 43–62
Assign Datasheet Wizard  59
associating components  48
changing shapes by right-clicking  47
component data  50–54
creating  46–49
creating datasheets  58–59
creating intelligent tags  60–61
creating process shapes  55
creating your own lists  61–62
customizing  57–62
displaying component data  52
drawing  46–47
entering component data  51
grouping components  49
lists of components  54
modifying  49
numbering or tagging components  53
pipelines  46
printing datasheets  56
projects for  44–45
redlining layer  56
sample drawing  47
sharing and reviewing  56
system of units  61
valves  46

Process flow diagrams. See Process Engineering 
solution

Process shapes, creating  55
Project Explorer window  44, 50, 56
Projects

creating datasheets  58–59
creating sheet formats  57–58
opening existing  45
printing datasheets  56
sample for P&IDs  44–45
setting up folders  56
starting new  45
tips for file names  45
tips for folder management  45
view in Project Explorer  44
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Properties
adding for tracking  76–78
for assets  75
assigning categories to shapes  77–78
defined  76
viewing  70

Properties dialog box  39, 40, 70, 73, 75, 81, 
83, 84, 85

Publishing drawings to the World Wide Web  
119–121

R
Radius dimension lines  27
Rectangle tool  89
Red dashed lines  47
Redlining

defined  134
layer for comments  56
PFDs and P&IDs  56

Redo button  11, 22
Reducing drawings. See Drawing scales, Zooming 

in or out on drawings
Reducing sizes of printed drawings  118
Reference point, positioning  29
Relate To command  84
Relationships, for people and departments  84
Relative paths for hyperlinks  120–121
Remodeling plans  94–95
Remote database for facilities plan  65
Reports. See Lists
Resistor, adding  109
Resizing pages  22
Resizing shapes  11
Resources stencil  67, 69, 70, 72, 73
Restricting shape movement to horizontal or 

vertical  12, 124
Reusing shapes  126–127
Reviewing PFDs and P&IDs  56
Revising shapes  126
Roads, adding  98

Rooms
creating with lines  89
creating with space shapes  88
irregularly shaped  71
resizing  89

Rotating shapes  15
Routing drawings for comments  122
Rulers

for perimeter of building  92
setting measurement unites  27

S
Sample drawings

Bubble diagrams  88
CAD detail images  37
CAD floor plans  36
datasheets  58
electrical and electronic schematic 

diagrams 108
facilities plans  64, 79
fire and security systems  106
floor plans  90
fluid power  112
home plans  94
HVAC plans  102
manufacturing plant layouts  99
mechanical engineering  111
P&IDs  46, 47
process engineering  46, 47
sheet formats  57
site plans  96
space plans  88

Sample Project.vsd  44
SamplePID1.vsd  44, 46, 54
Save As dialog box  42
Saving drawings  24

before linking  120
Saving templates  129
Scale  134
Scaling drawings. See Drawing scales
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Schematics for integrated circuits and logic 
circuits  109

ScreenTips  11, 134
Searching for assets  73, 82–83
Searching for online Help keywords  2
Security and fire plans. See Fire And Security 

Systems solution
Select Field To Display dialog box  52
Selecting groups of shapes  19
Selecting individual shapes in groups  20
Selecting text in shapes  17
Selection handles  11, 134
Selections  134
Sensors in HVAC systems  102–103
Service panels in electric and telecom 

plans  105–106
Set Architecture Page Properties dialog box  93
Set Door Properties dialog box  92, 93
Set Wall Properties dialog box  92, 93
Set Window Properties dialog box  92, 93
Setting dynamic grids  11
Setting page orientation  21
Shadows, applying and removing  16
Shape Area And Perimeter tool  93
Shape Conversion Wizard  55
Shape Explorer  10, 134
Shape handles  11
Shape operations commands  125

Combine command  125
Fragment command  125
Intersect command  125
Offset command  125
Subtract command  125
Union command  125

Shape-to-shape connections  13–15, 134
Shapes  134

1-D  12, 133
2-D  12, 135
adding and changing text  17–18
adding categories for  76–78
adding properties for tracking  76–78

adding to drawings  11
adding to stencils  127
aligning to the dynamic grid  29
assigning categories to  77–78
changing by right-clicking  47
closed  124, 131
connecting  13–15
converting  68, 78
creating  55
creating from CAD symbol libraries  55
creating your own  124–126
duplicating  70
extension lines  30–31
finding Help for using  3
finding with Shape Explorer  10
grouping in drawings  19–20
isometric extensions  30–31
joining together using Union  89
merging existing  125
modifying  15–16
moving  30, 49
moving and resizing  11
offsetting  31
open  124, 133
positioning to coordinates  29
revising existing  126
snapping to geometric points  28
snapping to grids, guides, and guide points  28
tips for  3
viewing categories and properties  70
zooming in on  32
See also Stencils

ShapeSheet Automation, finding Help for using  3
Sharing

facilities plans  85
PFDs and P&IDs  56

Sheet formats
creating  57–58
sample drawing  57

Shell And Tube shape  46
Shells. See Building shells
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Shipping and receiving shapes, adding  100
Shipping facilities  99–100
Shop Floor - Storage And Distribution stencil  100
Shop floors  99–100
Sidewalks, adding  98
Site Information dialog box  66
Site Plans solution  96–98
Size

changing for pages  66
showing with dimension lines  27

Size & Position window  4, 29
Sizing pages  22
Sizing shapes  11
SmartShape symbols for Process Engineering  46
Snap  11, 134

to extension lines  30–31
in CAD files  34
shapes to geometric points  28
shapes to grids, guides, and guide points  28

Snap & Glue dialog box  28, 29, 31, 34
Solutions  4, 127, 134

Building Architecture  5
Building Services  5, 102–107
Electrical And Telecom  105–106
Facilities Management  5
Fire And Security Systems  105
Floor Plans  88–93
Fluid Power  112–113
General Electrical Engineering  108–109
Home Plans  94–95
HVAC Control Logic  102–103
HVAC Plans  103–104
Mechanical Engineering  110–111
Office Layout  5
Part And Assembly  110–111
Plant Layout  99–100
Plumbing And Piping  104
Process Engineering  5, 43–62
Site Plans  96–98
See also Drawing types

Sorting lists  83
Space plans  88–89

Space shapes  70, 73, 75
assigning people to  73
creating rooms with  88
designating  69–70
irregularly shaped  71
resizing  71–72
tracking  69–73
tracking data with asset shapes  75
updating  89
when not to convert to walls  89

SPICE, generating netlist files for  109
Sport Fields And Recreation stencil  98
Springs And Bearings stencil  110
SQL Server, Microsoft databases for facilities 

plans  65
Square footage, calculating  72
Stacking order  135
Stairway shapes  91
Starting drawings  10
Stencil toolbar  10
Stencils  10, 135

adding your own shapes to  127
converting CAD symbol libraries to  55
editing  127
moving  10
opening additional  10, 107

Storage facilities  99–100
Structural view of assets  83–84
Structures, adding  97
Styles  135

applying  23
defining and editing  128

Subcategories
adding for tracking  76–78
defined  76

Substitution codes  60, 61
Subtract command  125
Surveillance in fire and security system plans  105
Swing sets, adding  98
Switches, adding  109
Symbols libraries (CAD)  55
System Of Units dialog box  61
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T
T-joint  91
Tables, substitution  61
Tags

components  53
creating intelligent  60–61
intelligent, defined  133

Teams, designating areas  72
Technical Support

finding information about  2
Telecom and electric plans  105–106
Templates  10, 135

designing your own  129–130
See also Drawing types

Terms, finding Help for  3
Text

adding and changing  17–18
setting indents and tabs  18

Text blocks  17–18, 135
Text ruler  18
Text-only shapes, creating  18
Tiled drawings  117, 135

increasing area of overlap  118
specifying number of pages  118

Tips for shapes  3
Title Block Small shapes  58
Title blocks for sheets  57–58
Title Blocks stencil  110
Toolbars

Action  15
Stencil  10
viewing  9, 135

Tools
Convert To Walls  89
crop  40
extension lines  30–31
isometric extensions  30–31
Move  30, 34
Netlist Generator  109
Shape Area And Perimeter  93

Tools, drawing  124
ToolTips for shapes  3
Tracking assets. See Asset tracking
Transporting materials shapes, adding  100
Trees, adding  95, 98
Trimming CAD drawings  40
Two-dimensional (2-D) shapes  12, 135

U
Undo button  11, 22
Ungrouping shapes  20
Union command  89, 125
Units

converting  61
for datasheets  61
of measure, setting  27

Unloading equipment, adding  100
Utility lines, adding  98

V
Valve Builder dialog box  113
Valves  46

associating with pipelines  48
creating your own  113
creating your own lists  61–62
datasheets  45
default category  59
how they move  49
HVAC plans  103–104
lists  54
moving  49
plumbing drawings  104
shapes  112, 113

Valves And Fittings stencil  47
Vanishing points in block diagrams with 

perspective  135
Variable Bend shape  104
Vehicles stencil  100
Vehicles, adding  98
Versions, previous  45
Vertex  135
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Vertices  126, 135
Video surveillance in fire and security system 

plans  105
View Full Screen command  83
Viewing Action toolbar  15
Viewing drawings before printing  116
Viewing fill color palette  16
Viewing page tabs for multiple-page diagrams  21
Viewing toolbars  9
Visio 2000

installing Technical Edition  2
new features in  4–5
Technical Support  2

Visio CAFM Explorer  83–84
Visio Corporation

Visio Knowledge Base  2
World Wide Web address  2

Visio format, converting CAD to  41, 42
Visio Help window  3
Visio Technical 5.0 Plus drawings, converting  68

W
Walkways, adding  98
Walls

adding  95
changing appearance  93
changing from double-line to single-line  93
changing properties  92
converting  89
cubicle  92
doors  92
drawing  91
exterior  92
interior  92
joining  92

repositioning  92
shapes  91
windows  92

Walls, Shell And Structure stencil  67, 88, 92, 93, 
95, 97, 100

Web sites. See World Wide Web
Web, publishing drawings to  119–121
Welcome To Visio 2000 dialog box  44, 65, 88, 91, 

95, 97, 100, 103, 104, 105, 109, 110, 113
Welding Symbols stencil  110
What’s new in Visio 2000  4–5
Window shapes  92, 93, 95
Wiring diagrams  102–103, 108–109

See also Electrical wiring
Wizards

Assign Datasheet Wizard  59
Convert Shapes Wizard  78
Convert Wizard  41
Facilities Management Setup Wizard  65
Get External Data Wizard  80
Shape Conversion Wizard  55

Workspace  8, 135
World Wide Web

publishing drawings  119–121
Visio Corporation  2

X
x-coordinate, positioning for shapes  29, 30

Y
y-coordinate, positioning for shapes  29, 30

Z
Zooming in or out on drawings  32
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